x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Is it possible to create a cavity in a mesh collision?

i made a big static mesh, Its supposed to be a floating rock with a cave inside. I made a simplified version of it for collision and named it UCX_bigrock. In the world its floating so i couldn't have just made it out of terrain. The issue is UE4 deletes the cave part. it keeps the custom collision i made, but it just stitched up the opening for the cave and now its a flat surface. There are no holes in the mesh, its like if you took a play dough cube and pushed your finger in it, its still intact, theres just a cavity in it. i could understand why you wouldnt want this if you were say making a vase or an open box but this mesh is big enough for me to walk around on. i can see the entrance and everything but its closed up. if at all possible, how can i make ue4 keep the collision mesh i made, as is?

Product Version: UE 4.9
Tags:
more ▼

asked Sep 07 '15 at 04:50 AM in Using UE4

avatar image

Omninaut
8 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first
  1. make sure that you have disable "one convex hull per..." and "auto generate collision" in your import settings

  2. just use a per poly collision -> in the static mesh editor in the details panel set the collision mode to "use complex as simple" :)

more ▼

answered Sep 07 '15 at 04:19 PM

avatar image

fighter5347
5k 160 21 144

avatar image PeteX Sep 07 '15 at 04:29 PM

Oh that's what use complex as simple means! I'd been wondering about that. :-)

avatar image Omninaut Sep 09 '15 at 09:07 PM

Thank You! Works perfectly

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question