x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Blueprint Third Person" project can't play with multiple clients?

I've watched the recently uploaded (and awesome) tutorial videos on blueprint networking, and wanted to start testing it out myself, however when I start a new project with the "Blueprint Third Person" project and set it to '2; clients in the play option, only one character spawns and the other clients (even when trying more than 2 clients or ticking for a dedicated server setup) just show this strange resulting image-

http://puu.sh/89i6M.png

An initial guess would be that it's just a camera stuck at 0,0,0? But I'm not sure why that's the case, there wasn't anything I could find after looking through the tutorial videos that instruct me on something I'm missing, and I've searched through the documentation and the settings in the Unreal Engine for the possibility that I'm meant to set it up to connect to 127,0.0.1, but can't find that anywhere-so I'm imagining it does that by default for tests in-editor. Additionally the windows seem to be flicking back and forth between occasionally for a moment between '"Preview Server" and "Preview Client 1", which I doubt is meant to happen.

Was there meant to have been options or configurations setup that weren't shown in the video tutorials because the person instructing had setup everything before hand, or should I in fact be able to just start the "Blueprint Third Person" new project and have that functioning, but something is going horribly wrong? I'd greatly appreciate some help on this as I'd love to start testing multiplayer functionality.

Product Version: Not Selected
Tags:
more ▼

asked Apr 15 '14 at 04:55 AM in Blueprint Scripting

avatar image

SwiftIllusion
237 23 30 33

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I was able to reproduce this at home, so I'll need to poke around the office when I get in tomorrow and figure out what changed (I filmed the videos before the latest update). I didn't do anything special beforehand in the map in the video.

I think what's happening now is it is attempting to spawn both characters in the same spot and rejecting creating the second one due to collision, but obviously that wasn't happening during the video. Very sorry for the inconvenience, will investigate what happened tomorrow, confirm what the issue is, and try to report back.

more ▼

answered Apr 15 '14 at 05:59 AM

avatar image

Billy Bramer STAFF
66 1 2 5

avatar image SwiftIllusion Apr 15 '14 at 06:29 AM

Thank you very much for your response and clarification.

With that idea in mind regarding collision, it does indeed seem to be what's happening. I went into the collision preset settings for the pawn (which is the collision group the "MyCharacter" asset is set to), and changed in the "Pawn" profile, the collision from Pawn:Block to Pawn:Ignore, and all the characters are created now (it must have deleted the characters because of the "spawn even if colliding option" which I forget the location of and haven't been able to find, but seemed to keep the camera).

http://i.imgur.com/Jgv3MSG.png

The windows keep flickering between "Preview Client 1/Preview Client 2/Preview Server", but thankfully at the very least that doesn't seem to effect your active window (though it would make the testing of synch, etc like was done in the tutorial videos difficult with all that flickering).

Important to note though is that you'll need to move your character (with wasd/etc) when you build-because with all players in the same position the cameras are pushed together and you can't see the player model until you start moving forward and get away from the other 2 players. I imagine that would also be a collision setting somewhere that needs to be adjusted (if you don't want the camera to be pushed forward by other player objects).

EDIT: These settings fix the camera issue (In the Pawn collision preset profile again, changed 'Camera:Block to Camera:Ignore')-

http://i.imgur.com/qnzpYce.png

avatar image Billy Bramer STAFF Apr 15 '14 at 04:06 PM

I verified with the latest code this morning that this bug is actually fixed up and should be coming very soon in the 4.1 release.

I've not actually seen the windows flickering issue on my home released build or at work though. I'll ping around and see if anyone else has seen that. Sorry again for the issues!

avatar image SwiftIllusion Apr 16 '14 at 04:27 AM

That's awesome news! Thank you very much for your help with this, really looking forward to 4.1 :)!

No worries, thank you very much for your concern :)! After doing a bunch more testing with the window flickering issue I've found it to be an issue with the editor windows in general, and I've tried various nvidia settings as well as making clean installs of multiple versions of the drivers and none of that impacted the issue. Also I've discovered patterns with the problem that make me feel it most likely to be an Unreal Engine 4 problem, though I'm not sure how you haven't encountered it. The reason I believe it's a UE4 issue is that the windows seem to flicker between similar types. For example if I open the Project Settings and Editor Settings at the same time they'll flicker between eachother, however If I open a Blueprint to edit they won't flicker to that. Also I've opened multiple blueprints and seperated them (so they are separate windows and not just tabs in the same window), and discovered that they specifically flicker with the window above them. So for example if I open the windows and they are layered like:

BlueprintA (Active) - BlueprintB (Behind A) - BlueprintC (Behind B)

BlueprintC will flicker between C and B, Blueprint B will flicker between B and A, and A being the active window won't flicker. Also when clicking on a different type of editor window, the last active window will stay stable. So when I have the Project Settings and Editor Settings windows open, and I select the Editor Settings window, causing Project settings to flicker back and forth to the Editor Settings window, if I then select BlueprintA, Editor settings will continue to be stable, while Project settings keeps flickering.

Hopefully that might somehow give you an idea of what's going on, though I understand it would be hard to try and fix without being able to see/replicate the issue.

avatar image Billy Bramer STAFF Apr 16 '14 at 08:37 PM

I asked a couple people here so far and they've unfortunately not been able to reproduce the flickering issue, but I'll also email QA and see if they can get it to happen. Could you possibly share a little more information about your computer setup that might be helpful? Are you running in SLI with your GPU(s)?

avatar image SwiftIllusion Apr 16 '14 at 09:40 PM

Thank you so very much for yours and everyone's effort with this.

I don't have SLI. Here's my graphics card details via 'GPU-Z' - http://i.imgur.com/PiaYtO5.png - and here is my system information via dxdiag - http://i.imgur.com/Teo6bog.png

I've also got intel built in, but I have NVIDIA set as the preferred processor and that's what runs the UE4 editor.

avatar image Billy Bramer STAFF Apr 17 '14 at 02:32 AM

Great, thanks, we'll check it out! Also, as a work-around to this issue that I completely forgot about until a helpful Youtube user pointed it out:

Because this is due to the collision, you can just move the server away from the spawn spot, then go to the client window, open the console (tilde key), and then type "reconnect" without the quotes. The client should spawn in if the server is out of the way. Sorry for not remembering that in the first place!

avatar image SwiftIllusion Apr 17 '14 at 03:15 AM

Awesome :)!

Oh that's perfect, worked an absolute treat, thank you very much for letting me know and no worries ^^!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question