x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Linux][OpenGL][4.9] Black screen in Editor's viewport when use -opengl4

I mentioned in several reports about this problem, but to insist on a speedy solution to it I decided to open a resporte too.

The problem it's easy, when i init the editor without any command they works fine: alt text

alt text

It's ok, not very good, is very slowly when we charge any external process, like create a new project, for example, or create a blueprint or custom class. But, for this isse it doesn't matter.

The problem happend when i use the -opengl4 command for init the editor, i get a editor with a blackscreen in the viewport, i don't know why happen this:

alt text

But when i play the level i can see all very clear: alt text

And yes, i tried creating a new project and i get the same error.

I see that this bug presets since Unreal 4.5 and i think that is very incredible that doesn't fixed yet. So bad.

This is my especifications:

  1. Ubuntu 15.04

  2. nVidia 525M

  3. 6GB Ram

  4. glxinfo | grep "OpenGL version" -> OpenGL version string: 4.5.0 NVIDIA 355.11

I'm doing now the fix recommendations.

Thank yoy very much for your great work, i like Linux and i like this great engine :D.

Product Version: UE 4.9
Tags:
more ▼

asked Sep 10 '15 at 06:30 AM in Linux

avatar image

SalahAdDin
21 4 11 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first
more ▼

answered Sep 10 '15 at 10:04 AM

avatar image

Yaakuro
314 13 7 19

avatar image SalahAdDin Sep 10 '15 at 06:14 PM

Thank man, this solve the bug for now, but, for better linux integration is very important that solve this bug within the code.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question