x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

"Set Location at Spline Point" doesn't work

I have a blueprint with Spline component. This Spline component has many points and I want to change location of certain points during gameplay. So i call the Set Location at Spline Point node, but it just doesn't work, nothing happens. I've tried with different points, both Local and World coordinates, different location vectors...

Is there some bug that prevents changing location of spline points via this node?

Product Version: UE 4.9
Tags:
more ▼

asked Sep 10 '15 at 11:44 PM in Blueprint Scripting

avatar image

Slavq
2k 157 153 207

avatar image ambhar Sep 11 '15 at 03:06 AM

Can you show some screenshots of how you are doing this?

avatar image Slavq Sep 11 '15 at 11:29 AM

Sure: alt text

But! I've discovered that it's because my spline is set in construction script! Then its points become pink (instead of white) and spline isn't editable anymore :( When I don't add spline points in Construction Script, it becomes white again and Set Location at Spline Point works! Looks like it's a new change that doesn't allow editing splines when they're set in construction script: https://forums.unrealengine.com/showthread.php?81332-4-9pre4-SplineComponents-built-with-construction-script-are-not-editable

I hope that there is some workaround... Maybe through C++...

1.png (52.8 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Problem solved, it was my mistake. Full information in my thread HERE.

more ▼

answered Sep 11 '15 at 03:24 PM

avatar image

Slavq
2k 157 153 207

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question