x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Global Vector fields

Hello !

I am tring to use Global Vector fields like explained in the official documentation, but without any success. I have a GPU particle emitter with the global vf module activated, a field in a vector actor volume on my scene, but both seems to completely ignore each other.

I tried to use the same vector field in a local vector field of my emitter and it works just fine ! I have tried to use the same vector field in global mode with other emitter too, but without any reaction.

Could you help me understand what I did wrong ?

Thank you !

Product Version: UE 4.9
Tags:
more ▼

asked Sep 11 '15 at 06:24 AM in Using UE4

avatar image

Cerambyx Cerdo
6 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I answer my own question, it could be useful to a future user :

  • First, I tried to reproduce a basic snow emitter (found in this tutorial : https://www.youtube.com/watch?v=G9vKSqRzhGQ). The original emitter works with Global Vector field, but not my copy. Finally, it was besauce I didn't enabled "set fixed bounds" in the top menu (even if I checked "Use Fixed Relative Bounding Box" in Particle system details). After fixed bounds enabled, GBF was recognized.

  • Then, when I tried to apply this discovery to my working emitter, I got stuck again. The particles didn't reacted to GBF even with bound fixed. It was besause I had "Use Local Space" checked in Required module details of the particle.

Finally, it works like a charm !

more ▼

answered Sep 12 '15 at 10:35 AM

avatar image

Glitch Bliss
16 2 6 5

avatar image breno4551 Oct 07 '15 at 10:57 AM

These details should totally be added to the various wikis about working with Global Vector Fields

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question