x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lost asset after trying to move it

Hello,

I know this is a common issue but that one is starting to be very painful.

I wanted to reorganize some of my widgets into subfolders, moving them resulted in errors. It said it couldn't save it because the asset was externally referenced (unknown reason). I tried many ways to resolve that but no luck. Eventually I had to close the editor.

When restarting the editor, the incriminated asset was purely gone. I guess the engine deleted it from the original location but couldn't save it in the new one.

The externally referenced issue is happening really often, it makes the process of cleaning a project dangerous.

I wanted to know if this was an issue being investigated. Thanks

Product Version: UE 4.9
Tags:
more ▼

asked Sep 12 '15 at 09:16 PM in Bug Reports

avatar image

Genova
268 21 24 35

avatar image Rudy Q ♦♦ STAFF Sep 14 '15 at 03:12 PM

Hello Genova,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in clean project?

  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints that may be involved with this issue?

  4. Could you try going into your backup folder (automatically created) and seeing if the lost asset has been backed up (Default path: C:\Users\YourUserName\Documents\Unreal Projects\YourProjectName\Saved\Backup )?

avatar image Genova Sep 14 '15 at 03:45 PM

Hello Rudy, Will do later.

as for 4. yes the autosave was there. Although for some reasons, bringing it back in the project broke all of its the references to other actors it had. For instance, it was casting to the player controller to Set a variable, on reopening the project that value was no longer valid and all connections were gone, so i had to delete the CastTO and the Set Value and recreate them. Tedious and painful task :)

avatar image Rudy Q ♦♦ STAFF Sep 14 '15 at 05:58 PM

Hello Genova,

I am happy that you were about to retrieve the lost asset, please let me know when you have the other information requested above and I will be more than happy to assist you further.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello Genova,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered Sep 17 '15 at 06:23 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question