x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.9 BUG] Blueprint nodes not firing off iOS devices but works on Windows

EDIT: So after further debugging, its the same issue as my previous issue where event tick is not firing off mobile https://answers.unrealengine.com/questions/258015/weird-bug-event-tick-not-running-on-ios-but-works.html but this time I have no idea what is causing it. Unfortunately it is not producing any error logs on my device so I can't debug further

I spent a few days trying to debug this issue but I am running out of ideas. I am currently having a bug that I have no idea what is causing it as it only happens on mobile devices (iOS). It works fine on PC and it worked fine on mobile devices (iOS) during 4.8.

It has something to do with rendering that is somehow not doing it correctly as printing the results show that it is visible but in game it is not shown at all. (Only on mobile devices iOS using 4.9)

The node in question: alt text Crackable Egg Sprite, Crackable Particle, Crack Sprite are all not visible initially and will be toggled to visible during this phase as shown in picture below (Windows version), however the iOS version does not toggle even though it still prints out true when I get the visibility from Crackable Egg Sprite.

**Please ignore the fish differences, they are randomly spawned for testing purposes and have no effect on eggs.* As you can see, Windows version scales up the egg properly and shows the crack sprite: alt text

But on iOS, the egg gets stuck at its initial size and never shows the crack sprite nor move to the center of the screen: alt text

If any staff can look into this, I will gladly send my project file and steps to reproduce the issue. Thank you in advance.

Product Version: UE 4.9
Tags:
nodeinquestion.png (78.7 kB)
more ▼

asked Sep 13 '15 at 03:53 PM in Bug Reports

avatar image

SmileyJeff
131 11 20 30

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Jeff,

Please post your project and I'll take a look at it. You can mail me directly jack.porter at epicgames.com if you don't want to post the link here.

It would be extremely helpful if you can modify the contents so that the issue occurs immediately when the level loads.

  • Jack

more ▼

answered Sep 15 '15 at 09:34 AM

avatar image

JackP_oldaccount
1.3k 37 11 46

avatar image SmileyJeff Sep 15 '15 at 01:41 PM

I've emailed you the modified project zip file (you can spawn eggs directly without having to go through the game) and steps to reproduce the issue. Thanks for looking into this.

avatar image JackP_oldaccount Sep 16 '15 at 10:32 AM

Thanks Jeff, it might take me a couple of days but I'll have a look at the project and see what is going on.

Cheers Jack

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question