x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Is it possible to disable friction on capsules?

I've been looking for a way to prevent my pawn's capsule from getting caught and spun when it hits a wall on an angle. Does anyone know if it's possible to disable friction on capsules or pawns through blueprints?

Thanks!

Product Version: Not Selected
Tags:
more ▼

asked Apr 15 '14 at 03:52 PM in Blueprint Scripting

avatar image

Heisenburger
143 15 20 198

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You should be able to set the physical material of the capsule component. Set the material's friction to 0.

Note that when the capsule hits the wall, the average friction is used. So if your wall has friction 0, but the capsule doesn't, the average friction will be the capsule friction divided by two.

In your case you'd want to set the friction to 0 for both the walls and the capsule.

Hope that helps.

more ▼

answered Apr 17 '14 at 07:40 PM

avatar image

[Epic]Ori Cohen STAFF
1.4k 25 14 59

avatar image Heisenburger Apr 17 '14 at 09:24 PM

I am creating a test "NoFrictionMat" material and assigning a physics material to it that has friction = 0.0. I am then assigning NoFrictionMat to one of the walls in my scene. Then on the Begin Play Event I am setting the material (and the shape material just in case) to NoFrictionMat on my Capsule Component.

This doesn't seem to be having an effect. When I fly (my level has no gravity and locomotion is down their forces applied to the capsule) my pawn towards the wall at an angle, as soon as I collide there is a strong angular force that causes the camera direction to sharply rotate towards the wall.

Any insight into why this is happening would be greatly appreciated.

Thanks.

avatar image [Epic]Ori Cohen STAFF Apr 17 '14 at 10:23 PM

I tested something similar to this, but I was applying the material in the actual blueprint component setup not in Begin Play Event. Doing it this way worked for me, and I'd expect it to work in Begin Play but maybe there's something not working with that.

Could you try assigning the material to the capsule as a component property of blueprint instead of in the blueprint graph?

avatar image tdorsey Apr 18 '14 at 03:56 PM

I'm working with Heisenburger on this. Just tested out setting the physics material override in the component setup instead of the blueprint and I no longer see rotational forces being applied to the capsule.

avatar image Heisenburger Apr 18 '14 at 11:15 PM

Thanks! That worked. Apparently attempting to set materials on Begin Play does not work for this case.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question