x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Actors/Objects visible inside editor preview window, but not visible in Play mode

Hey guys,

So I have a level with a bunch of actors that were animated in Maya, exported as FBX, and imported into Unreal. I am controlling their animations via Matinee. All of the objects work except for two, which render fine and are visible in the editor preview window (and when running the Matinee) but when I enter Play mode, it doesn't seem that they are rendering at all. The weirder part is that sometimes they will render and I will be able to see them just fine, but this is rare. I've reimported a dozen times, and the settings are all the exact same as all the other objects. I've tried changing materials as well but to no avail. I've also tried increasing the bounds scale, have verified that 'Visible' is checked and that 'Actor Hidden in Game' is not checked. I am desperate at this point, as I have only until Sept. 24th to get this working, and I can't seem to find anyone with the same problem. Help would be greatly, greatly appreciated. Thank you.

Product Version: UE 4.8
Tags:
more ▼

asked Sep 14 '15 at 11:28 PM in Bug Reports

avatar image

jessekirbs
108 7 13 22

avatar image Logan Bailey ♦♦ STAFF Sep 15 '15 at 02:27 PM

Hello jessekirbs,

From what you describe you have many assets that have been imported into UE4 from Maya. In UE4 you are controlling the animation that was made in Maya by way of Matinee. All of your assets work fine except for two. These two are visible in your editor but not when you press play.

I have a few questions for you.

  1. Can you create this in a fresh project?

  2. Does this happen when you create a project with this animation and objects in 4.9?

  3. Can you link me a screenshot or YouTube with this happening?

If you would link me your DxDiag along with the rest of this information then I will continue to investigate this problem at that time.

Thank you,

Logan

avatar image jessekirbs Sep 16 '15 at 05:43 AM

Can you create this in a fresh project?

Yes. I created a new project, imported FBX's with their animations, setup Matinee, and pressed 'Play'. At first they worked and I thought it was fixed, but after running it again the objects disappeared as in my main project. I also tried converting my main project 4.9 and the problem is still there.

Does this happen when you create a project with this animation and objects in 4.9?

Yes.

Can you link me a screenshot or YouTube with this happening?

https://youtu.be/kKoaVgcmrh4 You will see me play the scene using Matinee at first, and you can see the lasers and sparks, and then when I enter 'Play' mode, the lasers and sparks are gone.

My DxDiag output can be downloaded here https://www.dropbox.com/s/m4y9kpkywy2dkep/DxDiag.txt?dl=0

Thanks, Logan.

avatar image Logan Bailey ♦♦ STAFF Sep 16 '15 at 03:25 PM

Hello jessekirbs,

If you could please link me a test project where this is occurring and I can test this on my end.

I will then continue the investigation on my end.

Thanks,

Logan

avatar image jessekirbs Sep 16 '15 at 09:20 PM

Logan,

You can download my 4.9 test project below:

https://www.dropbox.com/s/2ry74oosm68djsa/LunaTest.zip?dl=0

The objects that are disappearing are LaserBeam1, LaserBeam2, LaserSphere1, LaserSphere2, and SpaceStation. Thank you for your help.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hello Jessekirbs,

I downloaded your project and then followed these steps.

  1. Open Project

  2. Go to Matinee and press play.

  3. Observed the lasers firing.

  4. Stopped matinee.

  5. Pressed play in viewport(PIE)

  6. Observed lasers not firing.

  7. Clicked on your laser beam assets and went to their details panel.

Under animation where you have Use Animation Asset chose as Animation Mode. Under that there is a tab for Anim to Play. You have none assigned. I assigned the respective laser beam animation and when pressing Play in Editor I saw the laser beams appear. After that I switched them back to none and saw them disappear. I then assigned them again and they were playing again.

I believe you have the laser beam animations assigned to play in the Matinee but not in the viewport.

Let me know if this fixes things.

Thanks,

Logan

more ▼

answered Sep 17 '15 at 02:42 PM

avatar image jessekirbs Sep 18 '15 at 01:17 AM

This seems to have done the trick. Thank you very much.

EDIT: Apologies, I spoke too soon. Looks like the SpaceStation is still suffering from the same problem. Checked to make sure the animation asset was set with 'Anim to play'. Did you verify the SpaceStation actor working on your end?

avatar image Logan Bailey ♦♦ STAFF Sep 18 '15 at 02:11 PM

Hello jessekirbs,

I am glad that the animation was fixed for the lasers.

I tested the animation on your space station. I opened the skeletal mesh assigned with your space station. I then assigned your animation to it in the animations tab. Your entire space station disappeared. I do not know what caused this issue but I suspect it is specific to that animation.

Logan

avatar image jessekirbs Sep 19 '15 at 06:37 AM

Logan,

The space station comes in near the end of the sequence. Open Matinee and scroll through to the very end and you'll see it appear. It works in Matinee, not when 'Play' is active. I don't think this is an animation problem, as it looks fine in Matinee and the export was no different than any others.

avatar image jessekirbs Sep 19 '15 at 08:27 AM

I:

  1. Deleted space station asset

  2. Deleted Matinee timeline for space station

  3. Re-imported the space station asset

  4. Dropped space station into scene

  5. Selected 'Use Animation Asset'

  6. Selected the animation from the dropdown menu.

  7. Pressed 'Play, and it worked.

Seems like a problem when you have the asset automatically playing a stored animation and a Matinee timeline with the asset's animation playing at the same time. Not sure, but that's what it seems like. Thanks for your help.

avatar image jessekirbs Sep 22 '15 at 10:05 PM

Oy. It never ends. Sorry for the back and forth, but it keeps seeming as if all is good and then something else breaks. I will attach the full project so maybe you can get a big picture idea of what may be going on.

The scene in Maya is rather large. Like, huge. Is it possible the vast distances of these objects are causing them to just completely not render? Now, it just appears to be random objects that won't show up. Once it was Jupiter, then it was BigAsteroidGroup1, then Venus, etc. It happens on builds as well. I will play the build, things will seem okay, and then when my friend runs it, objects will be missing. Is it bounds scales? Or culling distances? I have no idea.

I've included the planets into the test scene. If you could take a look and see what might be causing this, that would be amazing. We're running close to a deadline and I'm starting to sweat. Thanks, Logan.

Download link:

https://www.dropbox.com/s/2ry74oosm68djsa/LunaTest.zip?dl=0

avatar image Narek1 Feb 03 '17 at 08:52 AM

Hi Jessekirbs i have the same problem with imported actors from maya. and i wont to know if you found the answer??

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

hello jessekirbs,

It could be the shear size that is causing this issue. UE4 by design is not a space simulator. We try to discourage extreme values for certain things. For instance, if you had a very far off distance, and you had a zoom function that allowed you to zoom in on it from say 3000km away, and you zoomed in on an object. If that object was close to another, or overlapping you would see artifacts occur due to UE4 trying to calculate what takes priority on screen.

The other factor is how fast you are moving. I didn't see the "objects not showing up," as you described. However, when flying around two planes, i'm assuming earth and moon, were stuck dead center of my viewport.

I would look into this and see if you can adapt your project.

https://docs.unrealengine.com/latest/INT/Engine/LevelStreaming/WorldBrowser/index.html

For examples you can go to the UE4 launcher and grab the content examples files from the Learn tab. In it is a map labeled "level streaming."

I really hope this helps and good luck with the deadline.

Logan

more ▼

answered Sep 23 '15 at 02:28 PM

avatar image jessekirbs Sep 30 '15 at 06:15 AM

Thanks for all your help, Logan. I think it is just a size problem. Will figure out a different solution next time.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had a problem like this but with Sequencer and with characters in a hallway type room. I found this solution worked fine to solve my disappearing characters but I had some anim trails through animation notifys on the animations the characters were performing which never came back. I guess that's not too bad overall really. The level the characters were in was of a modest size rather than a big space scene so I thought it might have been to do with running out of video memory or something like that ?

more ▼

answered Jun 30 '17 at 04:22 PM

avatar image

tomelgon
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question