x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[Mac OSX 10.9.5] Xcode Compiler troubles: RocketBuild.sh exit code 5

Hi all

I've been trying to compile my project code in C++ but haven't been able to do so. When I try to compile a clean Blueprint project (no C++ code added yet), I get the following error:

ExternalBuildToolExecution UE4Editor\ -\ Mac cd /Users/Shared/UnrealEngine/4.9 export ACTION= /Users/Shared/UnrealEngine/4.9/Engine/Build/BatchFiles/Mac/RocketBuild.sh UE4Editor macosx DebugGame

Setting up Mono Building UE4Editor... Creating makefile for UE4Editor (no existing makefile) Performing full C++ include scan (no include cache file) Compiling with MacOSX SDK 10.10 ERROR: Rocket: No modules found to build? Command /Users/Shared/UnrealEngine/4.9/Engine/Build/BatchFiles/Mac/RocketBuild.sh failed with exit code 5

As you can see, I have my build configuration settings set up correctly, to launch UE4Editor and target My Mac as the device:

Correct configuration

This is a screenshot of the error in Xcode: Error exit code 5

Yes, the SDK says it's compiling for OSX 10.10 and I run OSX 10.9.5, but also with the compiler settings set to 10.9 I get the exact same crash, so I decided to flip it back to default (10.10).

Running Xcode version 6.2 (6C131e).

Could you help me resolve this, please?

Product Version: UE 4.9
Tags:
more ▼

asked Sep 15 '15 at 09:04 AM in C++ Programming

avatar image

Shrooblord
91 18 20 21

avatar image vijaykam Feb 16 '16 at 11:47 PM

Hello,

I am having this issue as well. Is there a resolution?

Vijay

avatar image vijaykam Feb 17 '16 at 12:45 AM

Here is the full output text using Xcode ver 7.3

Building UE4Editor... Performing full C++ include scan (building a new target) Creating makefile for UE4Editor (no existing makefile) Compiling with MacOSX SDK 10.11 ERROR: Rocket: No modules found to build? Command /Users/Shared/UnrealEngine/4.10/Engine/Build/BatchFiles/Mac/RocketBuild.sh failed with exit code 5

The error message might give a clue to the issue. I am already using the right build scheme (My Mac).

Vijay

avatar image Shrooblord Feb 17 '16 at 12:58 PM

Hi Vijay, I haven't had time to try jarnov's latest response (see below), but I have meant to. Did his "Did you try building the "UE4Game - Mac"?" option not work for you? I wish to try this, still, when I have more time to pick up Unreal 4 again. (Wow, it's been since October that he posted that? Where has the time gone...!)

avatar image vijaykam Feb 17 '16 at 05:59 PM

Hi Shrooblord,

Thanks for your reply. I think I know what happened. My Xcode tool was set to build "UE4 - Mac" - which, I am guessing, tried to build the UE4 editor as well. I believe on Macs, you can only build the game. So when I changed it to build "Mygame - Mac", I was able to build successfully. So Jamov's answer - now that I am reading it more carefully! - is correct.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Shrooblord!

I had that same issue "RocketBuild.sh failed with exit code 5" in XCode. It was solved by changing the "UE4Editor - Mac" build scheme to "YourProjectNameEditor - Mac" (in my case: "TwinStickEditor - Mac"). I hope that helps!

Cheers, jamov

more ▼

answered Oct 06 '15 at 04:53 PM

avatar image

jamov
46 3 3 7

avatar image Shrooblord Oct 07 '15 at 11:30 AM

That's not an option for me. If I click the UE4Editor - Mac build scheme, these are my only options:

No YourProjectNameEditor - Mac

As you can see, I can only pick from

  • UE4CmdLineRun

  • UE4Editor - Mac

  • UE4Game - iOS

  • UE4Game - Mac

  • UE4XcodeHelper

Running UE4Game - Mac (as that seems the most logical option given your suggestion) still results in an exit code 5 from RocketBuild.sh.

Creating a new scheme that runs UE4Editor - Mac but is named "MyProjectNameEditor - Mac" (assuming the name of my project is MyProjectName) still results in the same error.

Additionally, there's this in the UE4Editor - Mac under Edit Schemes > Build:

Missing UE4Editor

It seems to be missing one of its targets...?

avatar image jamov Oct 07 '15 at 04:21 PM

Did you try building the "UE4Game - Mac"? On this page: https://docs.unrealengine.com/latest/INT/Programming/Development/CompilingProjects/index.html

It reads in the bottom part, regarding XCode: "When building in Xcode, you are only compiling the game project, not the Editor."

I forgot to mention that I'm on XCode 7.0.1, on OS X El Capitan (10.11) and Unreal Engine Version: 4.9.2-2707645+++depot+UE4-Releases+4.9

Edit: XCode version.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question