x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Web Browser widget crash 4.9 in empty project

We tried to use the web browser in 4.9 in our project and found out it crash the engine when trying to play in PIE. After multiple tests I have created an empty C++ project and added web browser widget pointing on http://www.bing.com on an empty level and found out it crash the engine as well.

http://puu.sh/kc6gQ/504b310102.png http://puu.sh/kc6fo/572d0942f1.png

We use an unmodified pre-compiled UE4.9

I run windows 8.1 in 64 bit

It used to work properly with 4.8

Product Version: UE 4.9
Tags:
more ▼

asked Sep 15 '15 at 01:01 PM in Bug Reports

avatar image

bigzer
620 40 59 80

avatar image Rudy Q ♦♦ STAFF Sep 15 '15 at 02:38 PM

Hello bigzer,

I was unable to reproduce this issue with the information provided. I have a few questions that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. When you say that you used an "unmodified pre-compiled UE4.9", do you mean that you used a completely clean project?

  2. If not, can you reproduce this issue in a clean project?

  3. Could you provide the full call stack from the crash that you received ( including machine id )?

  4. Could you provide a detailed list of steps to reproduce this issue on our end?

avatar image bigzer Sep 16 '15 at 03:34 AM

Hello Rudy,

  1. I mean that it is the original UE4.9 downloaded using the unreal downloader. Additionally I tried it on a clean C++ project created just for this purpose.

  2. Yes it happens on a clean project too

  3. I don't have any UE4 crash callstack showing up besides this error message : http://puu.sh/kcTeR/58ec86e508.png. If I click debug I get http://puu.sh/kcTM5/a1aeffade9.png and then http://puu.sh/kcTOv/6bc1cef09e.png and http://puu.sh/kcTQm/29be206763.png.

  4. A. Create new empty c++ project, B. Create UMG blueprint C. Add the browser widget D.open level blueprint and create widget+add viewport on begin play. E. Play game in editor.

This morning we have tested it on other computers with the same build and we don't experience the problem. We have tried on a Custom UE4.9 build and the launcher binary 4.9 build. It worked on both versions. We tried them on windows 7 and windows 8.1 64 computers and it worked properly.

I have just updated today to 4.9.1 and I can confirm I still have the issue with it.

I tried to reinstalled UE4PrereqSetup_x64.msi just in case but it didn't help. I also tried to run the editor with Administrator rights but it didn't help either. What else could I try?

Thank you

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

After some digging in I found out that ASProxy is a DLL made by Astrill, the VPN provider. It appears this problem plagues many users including GTA 5 players who crash all the time because of this (me too actually!)

I didn't have this issue with UE4 before so something curious happened.

Surprisingly my colleagues are using Astrill as well and use the same version of OS and Editor and yet they don't have this problem.

This said, for those of you in China etc who use it, you can download the Portable VPN client from the official astrill website.

It solves the problem for me :)

more ▼

answered Sep 16 '15 at 04:17 AM

avatar image

bigzer
620 40 59 80

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question