x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to avoid frame rate drop in a large night scene?

Hello,

I have a fairly big open night scene with building with self-illuminated texture and spotlights to simulate streetlights. When I enable shadows my framerate drop drastically (at about 5 fps) even when I set the shadows quality to medium in the engine scalability settings. My direct light is static.

I would like to have shadows in the scene (even with poor quality) and keep a good overall quality of texture.

I'm not experimented so it may be a basic question but is there some world, spotlights, shadows or any settings that I could change to make the scene lighter and get a fair framerate?

Thanks in advance.

alt text

alt text

Product Version: UE 4.8
Tags:
02.jpg (167.5 kB)
capture.jpg (129.5 kB)
more ▼

asked Sep 16 '15 at 03:30 AM in Rendering

avatar image

Rajuk
17 5 7 7

avatar image Jacky Sep 16 '15 at 03:32 AM

Make sure you dont have too many spotlights affecting the same objects. You could also disable shadows for some of the spotlights at least.

avatar image Rajuk Sep 16 '15 at 06:01 AM

thanks for your reply :) I have a lot of spotlight it's true. I'm not sure I get you when you say "too many spotlights affecting the same objects", they affect the road object , tree and streetlight object . How can I make a spotlight affect an object and not another?

avatar image Jacky Sep 16 '15 at 12:29 PM

What i mean by that is you need to prevent a single mesh casting shadows from multiple spotlights. You can check the attenuation radius of the lights and see where they intersect. If more than 2 lights are intersecting disable shadows for one of them. You should also consider disabling shadows for the vehicle headlights if you are having such a huge fps drop.

avatar image Rajuk Oct 15 '15 at 01:48 AM

I just had to change lights from movable to stationary and as you said prevent single mesh casting shadows from multible splotlight. Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question