x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Shadow Artifacts after Build

A few basic info: I'm creating a AV Room. It has 3 Narrow Strips for Windows from the side my main light source is positioned. The scene is relying heavily in indirect lighting, global illumination and exposure bias to light up (both values in the post process volume are set to higher values). That said, there are a few stationary and movable lights around mostly to highlight a few areas. Cascade shadows are off.

The Issue: From the start, I did a basic setup for lights in order to test my lightmaps. Everything work great and the lightmaps were "clean". After I finished the level design, I did a few changes to the basic light of my level (main lightsource, post process volume, skylight, main spot light (I use one to boost the light that comes from the window)).

After hitting build, in the darker places of the level artifacts have appeared. My first guess was lightmap issue, but the problem is that I didn't change the props or their UV, they worked fine before. alt text

What I tried: I tried to bump up the lightmap resolution but the issue, even though less noticeable is there.

Also, because my walls were one big prop, the same for the celling, I separated both down to smaller props but still, it didn't work.

Messing with the same values that I changed in the first places does nothing to the artifact problem.

I had cascade shadows on, but I disabled them in fear that they cause this, no luck.

Any thoughts why this is happening?

Product Version: UE 4.9
Tags:
light_artifacts.png (560.9 kB)
more ▼

asked Sep 16 '15 at 07:48 AM in Rendering

avatar image

ELRIIC
20 5 5 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi ELRIIC,

You can try to smooth this out by adjusting some of the settings in the World Settings under the Lightmass section.

There is a guide here on the Wiki Lighting Guide that may be be helpful as well to reduce the artifacts.

I hope this helps.

Tim

more ▼

answered Sep 21 '15 at 03:07 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image ELRIIC Sep 22 '15 at 07:13 PM

Thanks Tim!

I managed to solve the issue by changing several settings from the World Tab and also by sub-dividing my Celling and Walls into multiple pieces.

This way, I gave to each prop more space in the unwrap and better lightmap resolution.

I admit that now I have another issue, lightmap related that I cannot solve with anything I have tried so far, but I will probably post another question if I cannot find the solution.

Again, thanks a lot!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question