x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

The Move and Scale Gizmos do not render

Hey everybody, I am working on a really big scene. I just used 3ds max to pull out stems for a real basic tree. So, i export those trees into an FBX file and imported into Unreal engine 4 and they are in my content browser in a folder I named FBX. Just so I know where everything I import is. Anyway, when I drag the trees in they lay where I place them but I can't move them or scale them. I can only rotate them. When I switch to the rotate tool I can see the rotate gizmo so I can rotate them. When I select move or scale I can't see them or change them. I can adjust the move, rotate, scale in the dialog box on the right but that sucks. Does anybody know how to fix this?

Product Version: Not Selected
Tags:
more ▼

asked Apr 15 '14 at 10:13 PM in Using UE4

avatar image

NLEGITN
21 7 9 12

avatar image Jacky Apr 15 '14 at 10:18 PM

It may be related to snapping. Go to Quick Settings and disable actor and vertex snapping options if they are enabled and see if it helps.

avatar image fighter5347 Apr 15 '14 at 10:25 PM

Also press W/E/R (shortcuts for moving,scaling, rotating) and then see if it probably works. Make sure that you have saved the meshes before you place them into the level.

avatar image BreadMan017 Sep 06 '17 at 10:36 PM

I am experiencing this same bug in 4.16.2 and have done nothing mobile related. Other team members who load the same map do not experience it. Here are some screenshots, the move and scale gizmos are being obscured by the selected object, the rotate gizmo appears normally. If I get any closer to the object the gizmos are occluded entirely as their size is tied to the screen area.

Any help on this would be greatly appreciated as it is seriously impacting my ability to work. Using ctrl-click / numeric input is a far less efficient workaround.

move gizmo is obscured by the object rotate gizmo appears correctly

avatar image zoombapup Apr 04 '18 at 09:50 PM

Got exacly the same issue. Rotate gizmo works as expected, but scale and transform don't display.

Turns out deleting /Saved directory fixed the issue. But I'd really like to know what's causing it for future reference.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

If you accidentally turned them off

ou may have turned the gizmos off by accident. If that's the case, Hourences, on the forums, suggests:

  • Top menu bar - Quick Settings- Show Transform Widget.

  • Failing that, reset the viewport settings - Viewport - Show - Use Defaults.

  • Following that, reset all settings. Delete the Saved folder in your project folder, and start the editor again.

    Mobile preview render mode

    rom your description (only rotation gizmo appears) I believe it's a bug. If you're using the editor with render level set to one of the mobile preview modes and MobileHDR off, the move and scale gizmos disappear.

There's also a discussion on the issue here. Epic added it to the issues list here, but that's only related to this one, it's not THIS exact issue.

more ▼

answered Aug 03 '16 at 12:54 AM

avatar image

RVillani
1.1k 28 39 90

avatar image Cucumbear Apr 08 '19 at 05:16 AM

Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello,

Just to clarify, the gizmos for translate and scale are not appearing for you when you change modes? Are shaders still compiling? Does this happen for just the one kind of mesh? Can you Post a screenshot of the object selected without the gizmos?

Thank you!

more ▼

answered Apr 15 '14 at 11:05 PM

avatar image Alexander Paschall ♦♦ EPIC Apr 23 '14 at 06:21 PM

I have moved this to an answer so that the issue can be closed for tracking until additional information is given.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question