x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Particle Shadows seem overly dark after 4.9

After updating to 4.9, all my particle effect's materials seem to go pitch black when inside a shadow.

Even after calibrating the amount of Volumetric Directional Lighting or Volumetric Non Directional lighting on my sprite's materials, they still show pitch dark when the sun isn't shining on them.

Offcourse all Particle Materials that use emissive dont have this problem but the rest do :(.

The problem with this is that for example, concrete bullethits inside a building will show pitch black, or if you have a map based on a sunset or dawn then most of the effects show pitch black as if the self shadowing has been buffed in 4.9.

Is there any way to avoid this? Again, this wasnt happening at all before I installed 4.9.

Thanks for your help!

Product Version: UE 4.9
Tags:
more ▼

asked Sep 17 '15 at 06:45 AM in Bug Reports

avatar image

Bruno_G
51 14 26 30

avatar image Lovecraft_K ♦♦ STAFF Sep 17 '15 at 06:17 PM

Hi Bruno_G -

I have set up a test project showing the results we are getting internally with 4.9.1. Can you take a look and adjust whatever you need to, in order to get the results you are getting in your own project and then reupload it here.

Thank You

Eric Ketchum

Test Project 4.9.1

avatar image Bruno_G Sep 18 '15 at 02:50 AM

Hi Eric,

What I mean is that even when setting the directional lighting intensity to 0.1 or any low value, the spirtes still go pitch dark when inside the shadow drawn in your little project here.

Check this is my material setting:

alt text

And I get this:

alt text

So I would like to be able to tweak this darkness, its too much at the moment and it makes my white dust effects go pitch black in interiors. So for example all my bullet hit effects inside buildings show pitch black even when the level is set to daylight.

Any way to tweak this darkness?

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Bruno_G -

So what you are seeing in 4.9 is actually a correction to an issue with the Volumetric Lighting Samples that has previously been in the engine, namely that Volume lighting samples are no longer placed inside geometry. What was happening previously is that the volumetric lighting samples from behind the wall (in our example above it would be the light side of the wall) was getting passed to the particle system.

Now the more important part, how do I fix it. The first thing that will clear up the issue immediately is place a skylight in your level and even with a low intensity it will provide enough fill to see you particles. However if you cannot add a skylight, I would do a couple of things, if you are building lighting (so using stationary and not moveable) go into your World Settings>>Lightmass Settings and decrease the Volume Light Samples to 0.25(roughly) this will allow a sampling at tighter intervals for the lighting of Movable objects. You can also adjust the normals of your particle system to spherical instead of Camera facing in the Required module which can help a little bit. Finally you can adjust your Particle Color into Emissive Color as well as Base Color and adjust the intensity with a multiply in your Material which will allow you to have just a little bit of an emissive with your lit particles.

Thank You

Eric Ketchum

more ▼

answered Sep 18 '15 at 03:08 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image Bruno_G Sep 21 '15 at 02:52 AM

Yeah adding a constant of 0.05 of Emissive to my material helped, its not pitch black anymore and adding this little emissive wont over-brighten my dust sprites. Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question