Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Tutorial] Error in Visual Studio project

Trying to create a New C++ project by following these instructions:


The editor opens correctly, but Visual Studio (version: Express 2013 for Desktop)

gives the following popup:

One or more projects in the solution have not loaded correctly.

Please see the Output Window for details.

The Error is lengthy (attached here), but an overview:

error : The composition produced a single composition error, with 4 root causes. The root causes are provided below. Review the CompositionException.Errors property for more detailed information.

1) No exports were found that match the constraint: ContractName Microsoft.VisualStudio.ProjectSystem.References.IAssemblyReferencesService RequiredTypeIdentity Microsoft.VisualStudio.ProjectSystem.References.IAssemblyReferencesService RequiredCreationPolicy Shared ...

2) No exports were found that match the constraint: ContractName Microsoft.VisualStudio.ProjectSystem.References.IComReferencesService RequiredTypeIdentity Microsoft.VisualStudio.ProjectSystem.References.IComReferencesService RequiredCreationPolicy Shared ...

3) No exports were found that match the constraint: ContractName Microsoft.VisualStudio.ProjectSystem.References.IBuildDependencyProjectReferencesService RequiredTypeIdentity Microsoft.VisualStudio.ProjectSystem.References.IBuildDependencyProjectReferencesService RequiredCreationPolicy Shared ...

4) No exports were found that match the constraint: ContractName Microsoft.VisualStudio.ProjectSystem.References.ISdkReferencesService RequiredTypeIdentity Microsoft.VisualStudio.ProjectSystem.References.ISdkReferencesService RequiredCreationPolicy Shared

I've tried to create a new project with version 4.8.3 also, with the same results.

Product Version: UE 4.9
more ▼

asked Sep 19 '15 at 09:55 PM in C++ Programming

avatar image

21 2 3 5

avatar image WeekendJammer Sep 25 '15 at 01:26 AM

Tried the same solution in Visual Studio Community 2015, and it loads without any issue.

I also noticed that an error comes up (see below) when WDExpress 2013 loads, which may stem from this Nuget issue.

Gonna try using VSC 2015 for the time being.


avatar image Matthew J Sep 28 '15 at 09:59 PM

Hello jacob2512,

It seems like the issue may be with the Visual Studio 2013 install itself or the configuration of it. Could you try building a non-UE4 project to see if it results in the same errors?

avatar image WeekendJammer Oct 01 '15 at 05:14 AM

You're right!... strange, i can build existing project, but can't create any (gives the above error)... maybe it is one of the plugins acting up... will try uninstalling and reinstalling WDExpress 2013

avatar image WeekendJammer Oct 02 '15 at 06:42 AM

Nope... supposedly this is a known issue



Attempts to reinstall Update 4 (my current ISO version) give the above NuGet errors for me too... Gonna try installing WDExpress 2013 Update 5.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello jacob2512,

From what you've described, it seems like this may be an issue with Visual Studio or the plugins that you're using. I suggest speaking to Microsoft customer service or the creators of any third-party plugins that may be causing these problems to occur. I'm unable to assist with issues related to Visual Studio unless it is to do with its compatibility with UE4.

Have a nice day!

more ▼

answered Oct 07 '15 at 08:17 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question