x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

steamsockets: binding to port 7777 failed.

I know there are other questions on here, none of the answers have worked. I have a BP only project. Set up steam per Rama's tutorial. defaultengine.ini has:

[code] [/Script/Engine.GameEngine] !NetDriverDefinitions=ClearArray +NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="/Script/OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="/Script/OnlineSubsystemUtils.IpNetDriver")

[OnlineSubsystem] DefaultPlatformService=Steam PollingIntervalInMs=20

[OnlineSubsystemSteam] bEnabled=true SteamDevAppId=480 GameServerQueryPort=27015 bRelaunchInSteam=false GameVersion=1.0.0.0 bVACEnabled=1 bAllowP2PPacketRelay=true P2PConnectionTimeout=90

[/Script/OnlineSubsystemSteam.SteamNetDriver] NetConnectionClassName="/Script/OnlineSubsystemSteam.SteamNetConnection" [/code]

The DLL's are already in the right directory (seems you all started adding that into engine distributions), v132 the most recent version.

I can package the program, and when it runs I get the steam overlay in the bottom right, shift-tab opens it. So steam is working, to some extent.

When I create a session, it fails with a 'net driver listen error'. Looking in the logs I find:

[code] [2015.09.20-02.44.45:576][276]LogAIModule: Creating AISystem for world Abandoned [2015.09.20-02.44.45:576][276]LogWorld: Game class is 'L_Deathmatch_C' [2015.09.20-02.44.45:576][276]LogInit: SteamSockets: Socket queue 131072 / 131072 [2015.09.20-02.44.45:576][276]LogNet:Warning: Failed to init net driver ListenURL: /Game/Maps/Abandoned?listen?game=DM: SteamSockets: binding to port 7777 failed (0) [2015.09.20-02.44.45:576][276]LogNet:Warning: Network Failure: GameNetDriver[NetDriverListenFailure]: SteamSockets: binding to port 7777 failed (0) [2015.09.20-02.44.45:576][276]LogNet: NetworkFailure: NetDriverListenFailure, Error: 'SteamSockets: binding to port 7777 failed (0)' [2015.09.20-02.44.45:577][276]LogWorld: Failed to listen: SteamSockets: binding to port 7777 failed (0) [2015.09.20-02.44.45:577][276]LogNet:Error: LoadMap: failed to Listen(/Game/Maps/Abandoned?listen?game=DM) [2015.09.20-02.44.45:580][276]LogWorld: Bringing World /Game/Maps/Abandoned.Abandoned up for play (max tick rate 0) at 2015.09.19-19.44.45 [2015.09.20-02.44.45:580][276]LogWorld: Bringing up level for play took: 0.002452 [2015.09.20-02.44.45:581][276]LogOnline:Warning: STEAM: Can't start an online session (Game) in state InProgress [2015.09.20-02.44.45:591][277]LogNet: Browse: /Game/Maps/Menus?closed [2015.09.20-02.44.45:591][277]LogNet: Failed; returning to Entry [2015.09.20-02.44.45:638][277]LogLoad: LoadMap: /Game/Maps/Menus?closed [/code]

So it is not binding to port 7777. All other advice I saw for this (what little is out there), says it is the ini file that needs changed, I think those are old answers, my INI seems to be where it should, AND the overlay comes up..

Any ideas?

Product Version: UE 4.9
Tags:
more ▼

asked Sep 20 '15 at 02:55 AM in Blueprint Scripting

avatar image

arbopa
41 4 6 12

avatar image The Cheese Dragon Sep 20 '15 at 09:47 PM

I think I must have a similar issue, I get the overlay and didn't get any errors when packaging the game. I can also host a game, the problem is my game cant be found using hte find sessions node unless I port forward. I have done this so I can host games fine however it is a bit much to ask everyone to port forward in order to host a game so I need to fix this.

I assume the problem is to do with steam's NAT punching not being enabled or something, however I don't know how I would fix this. Any ideas?

avatar image Frozenfire Oct 21 '15 at 02:42 PM

I"m also currently facing this issue? Any response from anyone else? or did you manage to solve the problem?

avatar image Tomble38 Oct 21 '15 at 03:02 PM

I am facing the same Issue. Anyone?

avatar image Tomble38 Oct 21 '15 at 03:17 PM

I fixed it by replacing the commands I had in the DefaultEngine.ini with these updated ones:

https://docs.unrealengine.com/latest/INT/Programming/Online/Steam/index.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Had the same bug. Fix was int the DefaultEngine.ini change [/Script/Engine.Engine] to [/Script/Engine.GameEngine]

more ▼

answered May 15 '17 at 04:17 AM

avatar image

SND R Keene
958 30 118 112

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question