Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Externally Referenced warning - what does it mean?

I am curious as to the cause of this error warning:

Warning P_cloud7 ParticleSystemComponent /Game/Maps/Game.Game:PersistentLevel.P_cloud7.ParticleSystemComponent0 : Externally referenced


This is happening in a 4.8.3 project that has been converted to 4.9.1

As of right now documentation is of no help:


If someone has some idea how I can clear these out, please let me know.

Thank you.

Product Version: UE 4.9
more ▼

asked Sep 20 '15 at 04:30 AM in Using UE4

avatar image

214 16 28 36

avatar image Shanky May 12 '16 at 08:22 AM

Thanks a lot guys... :-)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

For those, like myself, wondering what exactly is going on, I debugged through this. While there might be multiple scenarios that lead to this bug, I believe they are similar to the following:

  1. In the file, **\Saved\Config\Windows\Engine.ini , in the section "[Core.System]", there are a list of Paths. These are content paths. They might look something like this:





  2. When opening a level, the engine does an "external reference" check by verifying that content/assets are within one of the above paths.

  3. Sometimes during project conversions, the project converter doesn't properly update the personal content path above ("... MyProject/Content" above). If the path to the content changed during a conversion, but the above path(s) in engine.ini weren't correspondingly changed, the engine would be performing its "external reference check" against the wrong paths. Hence, the engine will claim an object is externally referenced, when it is not.

  4. (1) Closing the project, (2) changing an outer folder name of the project, and (3) re-opening the project DOES cause the engine to properly update the paths in engine.ini, which is why people suggest renaming the project's outer folder to resolve the issue. Changing the outer folder name back to the original name is optional, and is only needed if you prefer the original path name.

more ▼

answered May 01 '16 at 10:53 PM

avatar image

121 2 57 12

avatar image JM_Lovermind May 02 '16 at 06:07 AM

Great! Finally someone explaining the magic trick ... Thanks!

avatar image Nightware Aug 31 '16 at 10:10 AM

Nice work of debugging, this helped me a lot, but you can also just delete the saved folder where this file is located. When starting your project, it gets generated again and any reference errors should be fixed :)

avatar image DeathTempler Oct 11 '16 at 02:07 AM

Directx77 Thanks!!! This has been bugging me for months!

avatar image ANoob9001 Nov 04 '16 at 04:00 PM

thanks ill try this immediately great job man

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

it means that one of the oldest and most irritating bugs known to man has not been fixed. 1 close the project. 2 in finder or file manager open the "Unreal Projects" directory 3 rename the projects route folder (yourgame to yourgame1) 4 open the project in the editor 5 file, Save All 6 Close the editor 7 in finder or file manager open the "Unreal Projects" directory again 8 rename the projects route folder back again (yourgame1 to yourgame) no more externaly referenced warnings


more ▼

answered Sep 20 '15 at 08:25 AM

avatar image

Alan Webster
860 50 34 81

avatar image mxnko Sep 23 '15 at 01:34 AM

Thanks, that was extremely odd. Is it the space in "project 4.9.1" ? I renamed directory to project491 and everything resolved.

avatar image Frall Apr 17 '16 at 12:21 AM

This seems to occur when opening a copy of your project in a new editor version since this changes the name of your project folder. Change the name back to the original folder name and the errors should be gone.

avatar image ocramot Apr 29 '16 at 12:16 PM

I agree, resetting "Project Folder name" to "Name of .uproject file" at once solved the issue.

avatar image JM_Lovermind May 01 '16 at 06:36 AM

Doesn't work with 4.12 preview.

avatar image mxnko May 01 '16 at 05:49 PM

JM_Lovermind, make sure the maps referenced in your project settings are not still pointing to 4.11.x location.

avatar image JM_Lovermind May 01 '16 at 07:53 PM

mxnko You are right, change [project_name 4.12] to [project_name 4.11] solves the problem... However, the procedure is different compared to older versions ... where it was enough to change only the name of the folder, open the project, save & rename... What is your solution?

avatar image StMalk May 11 '16 at 01:40 AM

Please how you solved it? I have the same issue with 4.12 and my copied project fro 4.11...

avatar image JM_Lovermind May 11 '16 at 06:02 AM

Hi StMalk your answer is right below from Directx77. You just only change path in Engine.ini ("Core.System" section)alt text

path_bug.jpg (255.7 kB)
avatar image normal_ST Sep 28 '16 at 08:41 PM

Thanks for info about Engine.ini, I've had this bug when I moved my game proj directory + deleted epic launcher completely(included everything in documents), all I had to do to fix this, is to remove Engine.ini from "Saved\Config\Windows", then, editor will recreate this ini, with right paths when you start your project, now Engine.ini paths to my games dir is"%GAMEDIR%Content" and not ".../../../".

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Important note for anyone still experiencing this issue after trying all of the above: Try deleting your 'Saved' folder in your project files. This worked for me after the rename trick failed, likely because I copied my whole project from another computer, and then upgraded to a newer version.

Just putting this out there since whenever I googled the problem, this thread came up first.

more ▼

answered Sep 30 '16 at 04:46 AM

avatar image

75 7 9 13

avatar image FelixoMars Nov 15 '16 at 02:02 PM

Thanks, this was the solution.

avatar image Rama Mar 12 '18 at 07:37 PM

For me in 4.18 this was the solution, but you can just delete Saved/Config, you don't have to delete all of your Saved Folder

I recommend keeping your EditorPerProjectUserSettings.ini (folder colorings, BP context menu favorites, etc)

Thank you for posting this!

blood pressure dropping rapidly now


(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question