x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

KDevelop IntelliSense not working

Hi, why the KDevelop IntelliSense is not working on Linux? It marks everything as error, while it's all right.

For example:

alt text

Product Version: UE 4.9
Tags:
screen.png (6.2 kB)
more ▼

asked Sep 21 '15 at 10:36 AM in Linux

avatar image

Scienziatogm
396 44 40 51

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Try entering .kdev/Defines.txt and .kdev/Includes.txt (they are created during project generation) into appropriate fields of the KDevelop project.

more ▼

answered Sep 21 '15 at 02:14 PM

avatar image

RCL STAFF
2.7k 59 6 88

avatar image Scienziatogm Sep 22 '15 at 06:12 AM

Thanks. I found this:

https://forums.unrealengine.com/showthread.php?73205-Setting-Up-KDevelop-for-UE4-Projects-in-Linux

But I can't find the KDevelop Custom Defines and Includes section opening the project configuration.

avatar image Kronykus Oct 24 '15 at 05:13 PM

In the root project folder, you should have a .kdev hidden folder. The defines and includes are in there.

Inside kdevelop right click the project and go to project configuration. Custom Defines and Include should be the top item in the list on the left. The tabs for includes and defines is on the right.

Edit: For what it's worth, even with all that set up, the intellisense still doesn't work properly... at least not for me. I just ignore it, until I find time to investigate using QTCreator (which I would prefer anyway).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Create a symbolic link in your project root folder:

.kdev_include_paths -> My ProjectCodeCompletionFolders.txt

And I get quite good code completion and navigation, sometimes better than in visual studio and certainly faster.

more ▼

answered Jan 20 '16 at 12:18 PM

avatar image

Gatherer
71 6 8 17

avatar image Scienziatogm Feb 05 '16 at 11:10 AM

I've done ln -s .kdev4/Includes.txt .kdev_include_paths but it's not working.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The .kdev4 (with include.txt and define.txt) are present in the UnrealEngine directory (not your project directory)

more ▼

answered Mar 21 '18 at 10:17 AM

avatar image

lgeorge3
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question