x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to Snap to Grid

Problem Description: I'm unable to snap newly created cube to grid by pressing Ctrl + End. Snap to Grid is enabled and cube is selected. After pressing the keys and checking the Edit/Undo, it states Undo Snap Origin to Grid, but the object in editor shows nothing different.

Attachment List: Picture that shows the Undo and the editor viewport.alt text

Product Version: Not Selected
Tags:
more ▼

asked Apr 16 '14 at 02:15 PM in Bug Reports

avatar image

KnightTechDev
460 45 48 65

avatar image BrɑκеPɑd STAFF Apr 16 '14 at 03:04 PM

Hi! Your mesh there appears to already have its origin aligned to the grid - what are you expecting to happen here?

avatar image KnightTechDev Apr 16 '14 at 03:31 PM

I wasn't trying to align the mesh origin with the grid. I'm expecting the mesh edges to align to the grid using the Ctrl + End key to snap to grid as is shown in this tutorial: http://www.youtube.com/watch?v=woBMRKWX0qM&list=PLZlv_N0_O1gaCL2XjKluO7N2Pmmw9pvhE

Moving the cube around and pressing the keys doesn't do anything at all, but it does show what can be seen when I check the Edit/Undo list as shown in the attached picture.

The Origin of the Mesh of course would be the Center Of Mesh, which was not what I was attempting to align.

avatar image BrɑκеPɑd STAFF Apr 16 '14 at 03:42 PM

Maybe I'm misunderstanding something, but if you've got snap-to-grid turned on in the viewport, dragging the object around is going to snap it to the grid anyway.

Are you dragging it around with snapping turned off?

avatar image [Epic]Maximusdb3 STAFF Apr 16 '14 at 04:19 PM

Hi Knight,

Ctrl + End is not a toggle for snapping but will snap the object's origin to the closest grid point when used. If you already have grid snapping turned on (which it looks like you do, judging from the screenshot you took) it will appear as nothing has happened since it's already aligned to the grid.

Also, when you're snapping to the grid you're actually snapping to the red dots and not necessarily to the grid lines.

-Max B.

avatar image KnightTechDev Apr 16 '14 at 04:29 PM

Hello Andrew and Maximus, you'll notice in the video tutorial after you create a cube exactly as he shows, he tells you to press Ctrl + End to align the cube to the grid, basically along the bounding lines (yellow lines) of the brush shown, when you look at the video you will notice the cube in fact moves. When I do it, the cube doesn't move, no matter what position of the cube along any axis, and it creates an Undo, which of course clicking the Undo does nothing either. Snapping is turned on and I know it's not a toggle. Of course pressing End Key by itself will drop a mesh to the floor I am trying to create. It's not the biggest of issues, and it doesn't stop me from positioning things manually and adjusting the Position Grid Snap Value, the problem would be that if someone that's not experienced with this comes across this as well in the first set of tutorials, might be a bit stuck trying to figure it out. Were the Hotkey's for it changed? I've also ruled out the keyboard keys sticking because the keys aren't stuck and I can type normally lol.

avatar image [Epic]Maximusdb3 STAFF Apr 16 '14 at 05:25 PM

Well the reason he moved was after he resized the mesh, he adjusted the grid from 10 to 50. Placing a mesh on a 10 unit grid will not always align to a 50 unit grid (hence why he used Ctrl + End). It is possible though to have placed a mesh on a 10 unit grid and still have it on the grid when switched over to a 50 unit grid. It sounds like this was the case for you.

If you would like to be sure this command works for you, click on the orange grid button in the upper right side of your viewport to disable grid snapping. Move you mesh around and then use the Ctrl + End command again.

-Max B.

avatar image demented_hedgehog Dec 06 '14 at 03:28 AM

I'm seeing this problem too (on linux). So is someone else: https://wiki.unrealengine.com/Talk:Introduction_to_the_UE4_Editor_-_6_-_Moving_Objects It works intermitently.

avatar image KnightTechDev Dec 06 '14 at 03:06 PM

Yep, looks like it's doing something similar on mine too, after updating to Unreal Engine 4.6 I zoomed in and noticed the BSP brushes I used for cutting doorway openings was raised along the Z-Axis by exactly 0.5, I went ahead and added the 0.5 for the Snap Sizes, the auto-snapping to grid didn't work, and used the 0.5 to manually re-position and align it properly back to floor level, and the dropping to floor stopped working for new BSP brush geometry.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Hello Max B., Did what you said and looks like it's working now, the cube moves and snaps to a grid line at a time or to both if you place cube close to the edges almost evenly, thank you! Also, it works with or without grid snapping turned on.

more ▼

answered Apr 16 '14 at 10:34 PM

avatar image

KnightTechDev
460 45 48 65

avatar image demented_hedgehog Dec 07 '14 at 05:55 AM

There's a duplicate here https://answers.unrealengine.com/questions/143168/snap-to-floor-not-working-in-ue46.html for the record they say it's fixed in 4.7.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Just had the same problem. I know it's an old thread, but since it's the first in google results, I'll leave here solution for future developers. Snapping works for origin (usually center) of the object, not its borders, so if your object has an odd size (for example 125, not 124), it will divide this, leaving 0.5 off-the-grid for both sides. So, either make the size even, or change origin to the corner. Eeasiest way to do so - select object and then right click to one of the corners. It will snap it to the grid where it should be.

more ▼

answered Jul 10 '17 at 10:56 PM

avatar image

Max Pio
18 6 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

i was trying to figure this out and it looks like you need to have grid snapping turned off and press just end not cntrl.. on my keyboard, end is a blue secondary keystroke so i need to also press the blue fn button to use the end key. so by pressing end my actor moves to the ground. however it is a few "inches" above and not planted firmly on the ground. if i zoom down to the bottom i can see it hovering above the floor a little. is that normal?

more ▼

answered Nov 04 '16 at 10:23 PM

avatar image

matthiu23
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question