x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

SpeedTree - Black Materials on Multiple Model Import

Hey all,

If I attempt to import multiple SRTs that share materials into the same folder in the content browser, the first model will import correctly, but the remaining trees will import with missing materials. This happens whether I import them simultaneously or sequentially. I can import multiple trees into the same folder that do not share any materials. I can also import the trees into individual folders and then merge the content of those folders into one without any issues. It appears to only be an issue during the import process with trees that share materials. The import process works fine in 4.7.6. But it appears to have been broken in 4.8. I've got both 4.8.3 and 4.9.1 and the import is broken in both of those versions.

You guys should have access to whatever trees you need, but I can get you models that share materials if need be.

Best Regards,

Dave

Product Version: UE 4.8
Tags:
more ▼

asked Sep 23 '15 at 03:25 PM in Bug Reports

avatar image

SpeedTree PARTNER
11 1 2 2

avatar image Tim Hobson ♦♦ STAFF Sep 24 '15 at 04:38 PM

Hi Dave,

Currently I only have access to the free assets (Broadleaf, Palm, Conifer, Euterpe) from the SpeedTree site. I've tried making a copy of the Broadleaf and importing the original and the copy, but I'm not seeing what you're describing. This could be just a flaw in how I'm doing it though or if it can be done with these meshes/materials.

I do have some questions with what may be going on:

  • When you import are you using the default settings in the import options?

  • When you say that the materials are missing, is this just the material is not imported or that it's not assigned to the mesh, but all the material IDs are still present?

If you need to share the trees to get the repro you can share them privately here in a message to me on the forums: https://forums.unrealengine.com/private.php?do=newpm&u=4894

If it can be easily done with the trees I currently have please let me know the repro to do so and I'll give it a test.

Let me know.

Tim

avatar image SpeedTree PARTNER Sep 25 '15 at 02:48 PM

Hey Tim,

  • When you import are you using the default settings in the import options?

Yep.

alt text

  • When you say that the materials are missing, is this just the material is not imported or that it's not assigned to the mesh, but all the material IDs are still present?

I misspoke. The materials are not missing,. The textures are. So the materials are present in the content browser, but some of the materials are black because the textures are missing.

Sorry for the confusion, that was my fault. I'll send you a dropbox link to some models so you can test it easily.

Regards,

Dave

avatar image reedandrader Nov 19 '15 at 08:50 PM

Having a similar problem with imports coming in black. The materials are all messed up. Everything is there (textures, meshes,materials) but the materials are all missing textures. This can be fixed manually but it's a bit tedious.

avatar image 0vr Feb 02 '16 at 04:36 AM

I'm not really sure how to fix it in some materials that use node-magic rather than simple textures plugged in :\ One in particular is set to use a mask but I'm not sure what they had used to mask the opacity.

avatar image ZoltanE Oct 30 '15 at 08:12 AM

I'm seeing a similar issue on 4.9.2: I'm trying to import a single tree, the Broadleaf_mobile from the free SpeedTree examples. The mesh ends up being black and the log has a few errors like this:
Error: Texture import failed LogEditorFactories:Warning: -- import failed LogStreaming:Warning: Failed to read file '/Broadleaf_Mobile_Atlas.tga' error. LogSpeedTreeImport:Warning: Unable to find Texture file /Broadleaf_Mobile_Atlas.tga

Materials are created and assigned but they do not contain any texture sampler nodes. I manually imported those textures and then reimported the .srt file but it still fails to import or reference those textures.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

This has been resolved with CL-2848895 and will be included in the 4.11 release. This should be testable in the next 4.11 Preview 5 release.

Thank you!

Tim

more ▼

answered Feb 04 '16 at 05:00 PM

avatar image

Tim Hobson ♦♦ STAFF
49k 886 99 875

avatar image Yahiya Jasem Apr 04 '16 at 07:16 AM

I still have this issue .. even with 4.11 release

avatar image Tim Hobson ♦♦ STAFF Apr 04 '16 at 03:58 PM

Using the sample assets I have available to test, I'm not seeing the same issue that was reported with previous versions.

If you have any additional information, such as the assets you're using or additional repro steps. Any screenshots of the results may be helpful as well.

Thank you!

avatar image jaremi76 Jul 02 '17 at 06:07 PM

Not sure if an answer was ever found for this or not but... I had just run into the same issue and had been trying to figure out a work around for it. I'm currently using version 4.10. All new trees that I have been trying to create had no textures and the materials were all black, or the billboards were all white.
I got them to import again correctly by, instead of just saving the tree as usual using "Save" or "Save as...", I used "Save as with assets..." and that imported all of the textures like it had been in previous versions of Unreal.
Hope that works for anybody who is still having issues with that.

(comments are locked)
10|2000 characters needed characters left

I had the exact same problem until I changed the file type of the textures that the ST7Compiler was generating. I'm a new user, so it took me some trial and error. The file type was set to "DDS" by default. Importing the resulting .srt file into UE4 gave me all-black materials and no textures.When I changed the file type to "TGA" it worked fine. You can specify other formats to suit your needs. Also, don't forget to choose your appropriate platform (DirectX 11, OpenGL, Xbox One, etc.). I hope this helps someone!

alt text

more ▼

answered Dec 20 '18 at 05:57 PM

avatar image

buckbiggle
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question