x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal Crash on Level Load maybe - SCREENSHOT )))

It is the first time I report bug with screenshot, but I think that is the bug that was haunting me for a long time, and I could not find possibility to generate crash report.

Here is the screenshot where it is clearly visible that something is wrong.

alt text

UnloadedActionList is somehow spoiled with Invalid entries. Hard to tell why it is there - maybe some bug in my game code? But it is for animation asset, and I am not doing with them intentionaly. Maybe some GC related stuff?

The bug which I think is connected to this - is Error loading module bug, which appears everytime I am opening project without rebuilding it. Maybe it is not related. But something definitely gone wrong.

Any help would be appreciated.

Product Version: UE 4.9
Tags:
more ▼

asked Sep 24 '15 at 05:43 PM in Bug Reports

avatar image

Yata
554 39 50 69

avatar image Doug E ♦♦ STAFF Sep 24 '15 at 06:40 PM

Hey Yata-

Could you elaborate on the exact crash you're getting? Are you referring to opening a level in the editor or loading from one level to another during runtime? Is this happening when loading a specific level? Can you post the logs from the crash for additional information? The logs are saved in the project directory's Saved/Logs folder.

Cheers

Doug Wilson

avatar image Yata Sep 25 '15 at 06:54 AM

The crash was during opening level in editor. Logs are turncated but i have visual studio debug output.

link text link text

avatar image Doug E ♦♦ STAFF Sep 25 '15 at 01:24 PM

Does this crash occur when opening a specific level or does it happen for multiple levels? Have you upgraded your engine version recently? If you're debugging through Visual Studio can you try running the project itself to generate a callstack for the crash?

avatar image Yata Sep 25 '15 at 02:15 PM

I am no longer running my project from visual studio. I had a bug, which prevented project startup without complete removal of Binary, Build, Intermediate and Saved folders and complete rebuild. It was displaying this error.

alt text

And yesterday I think I fixed. I found that some animation blueprints was referencing deleted skeleton. They where not complaining during runtime. I only noticed in debug output that unreal was trying to load this deleted skeleton. so I found which assets has path to this skeleton saved in their files. Reopened and resaved them. And it looks like this bug gun.

What concerns the topic crash - it was occasionally caught. And I really does not know how to reproduce it. Maybe this bugs where connected. Because I think one of my assets, which had deleted skeleton reference use this osi_idle animation.

avatar image Yata Sep 25 '15 at 02:43 PM

Hi Doug, You where lucky. I have the crash dump now. ))

link text

logs.zip (74.7 kB)
avatar image Doug E ♦♦ STAFF Sep 28 '15 at 03:39 PM

Does this crash happen when opening a specific level? Also, have you upgraded your engine version recently or did this crash start happening after adding/changing code? If possible, could you upload a copy of the project to dropbox and send me a private message on the forums with a link to download so I can test the project/crash on my end?

Cheers

Doug Wilson

avatar image Yata Sep 30 '15 at 08:58 AM

It is on loading a specific level. I can't upload you a project. Here is another crash dump. Bug was triggered while I was deleting animation assets in content browser.

link text

logs.zip (187.4 kB)
avatar image Doug E ♦♦ STAFF Oct 01 '15 at 05:48 PM

I'm a little confused by your last reply, did the crash happen when you opened the level (level load) or when deleting an asset after opening the level?

avatar image Yata Oct 01 '15 at 05:51 PM

The crash happened after I deleted assets in asset browser.

Fixed! UE-17698 [CrashReport] UE4Editor_CoreUObject!UStruct::IsChildOf() [class.h:400] Doug, Is it this bug fixed in 4.9.2?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Yata-

You may be correct, the callstack for your crash and the report you linked seem to match. If you have the 4.9.2 version of the engine you can check this by opening the project to see if the crash is still occurring for you.

Cheers

Doug Wilson

more ▼

answered Oct 01 '15 at 06:20 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question