x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Certain console commands not working

I have no idea if this is a bug or a mistake on my part, but console commands for Light Propagation Volumes and Distance Field Global Illumination don't work for me. I was excited to recently learn that there are console commands to tweak the quality of LPVs, namely r.LPV.RSMResolution and r.LPV.NumPropagationSteps. Trying them out however did nothing for me.

The exact command I used was, for example: "r.LPV.RSMResolution 1024" (without quotation marks). I also tried all other variations I could think of, but from what I understand this one should be correct.

Usually I would attribute this to to a problem with the LPV or with my project, but it doesn't work in a clean new project either, nor did the console commands for DFGI from this thread. Other commands (stat unit, slowmo, HighResShot, et cetera) all execute without problems.

If anyone has any ideas what I could be doing wrong or what could be going wrong, please let me know!

Product Version: UE 4.8
Tags:
more ▼

asked Sep 25 '15 at 09:00 AM in Using UE4

avatar image

Efrye
261 19 30 37

avatar image svv3dUDN Sep 25 '15 at 09:28 AM

Try add this console variables to global INI file

\Engine\Config\ConsoleVariables.ini

or create this file in project folder

avatar image Efrye Sep 25 '15 at 01:16 PM

Ah, I should've mentioned that: I already tried adding the command to the ConsoleVariables.ini but that had no effect either. I used an "equal" sign before the value (i.e. "r.LPV.RSMResolution=0"), but I also tried several other variations with no success.

Unfortunately I don't have access to UE4 right now, but I can upload a sample project and the ConsoleVariables.ini I'm using later today. Maybe that will shed some light into what's going on...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I tried out some more stuff and noticed that the commands are working in 4.9. They don't do anything in 4.8 and 4.7, so I'll just assume that there's either a bug in those versions, or that they have only been added recently in the latest version of the engine. Which, ironically, I can't use (yet) because of other LPV bugs. :D

more ▼

answered Sep 27 '15 at 01:34 AM

avatar image

Efrye
261 19 30 37

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question