x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4Editor crashes at first run (initialization)

Branch and commit at which it happens: 5fd57546cc721650026801021de0be733d48a3e9@release (4.9.1-release merged in).

Log: link text

Happens every time. No variations.

Product Version: UE 4.9
Tags:
output.log (42.0 kB)
more ▼

asked Sep 25 '15 at 01:30 PM in Installation & Setup

avatar image

Arlias
1 1 1

avatar image Doug E ♦♦ STAFF Sep 28 '15 at 03:35 PM

Hey Arlias-

Just to make sure I understand, you built the engine from the release branch and it is crashing for you? At what point does the crash occur. Does the crash occur when trying to run the engine from another branch/build?

Cheers

Doug Wilson

avatar image Arlias Sep 28 '15 at 03:54 PM

Hi,

it crashes/segfaults with these last lines from the log (Load UI at about 45%): [2015.09.25-12.55.42:208][ 0]LogStaticMesh: Building static mesh EditorCube... [2015.09.25-12.55.42:209][ 0]LogStaticMesh: Built static mesh [0.002190.2s] /Engine/EditorMeshes/EditorCube.EditorCube [2015.09.25-12.55.42:228][ 0]LogStaticMesh: Building static mesh EditorSphere... EngineCrashHandler: Signal=11 [2015.09.25-12.55.42:720][ 0]LogLinux: === Critical error: === Unhandled Exception: SIGSEGV: invalid attempt to access memory at address 0x00000002

Have not yet tried another branch, since I though the current release branch was the best fit for me. No problem in trying though.. which branches would you like me to try?

Cheers. Arlias

avatar image Doug E ♦♦ STAFF Sep 28 '15 at 04:00 PM

Can you let me know if you're able to build the engine from the 4.9 branch? This can be set during the clone process with the following line:

 $ git clone https://www.github.com/EpicGames/UnrealEngine -b 4.9

If you're still unable to build the engine can you list the steps you're taking to download/clone/build the engine?

avatar image Arlias Sep 28 '15 at 06:57 PM

Will try 4.9 branch as soon as possible. I'll let you know.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Arlias-

I just wanted to touch base with you and see if you'd had the chance to test the 4.9 branch for the same issue? It would be great to hear if the 4.9 branch worked for you however if you are still getting a crash when running then we will continue to investigate.

Cheers

Doug Wilson

more ▼

answered Oct 02 '15 at 03:27 PM

avatar image Arlias Oct 02 '15 at 03:59 PM

Sorry not yet. May day job has me kind of pinned down at the moment. Give me until the Weekend.

avatar image Doug E ♦♦ STAFF Oct 07 '15 at 06:25 PM

Hey Arlias-

I've not heard from you in a few days if the 4.9 branch gave you the same issue. For now I'm going to mark this as resolved for tracking purposes, however if you do have the chance to test this you can post a comment to reopen the post and we will investigate further.

avatar image Arlias Oct 07 '15 at 06:59 PM

Acknowledged.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question