x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blender to UE4 Normals

Having an issue with exporting an fbx and importing into ue4. My normals seem to get all jacked up, and I think it may be an issue with using the edge split modifier? I come from 3ds max originally, but trying to learn Blender. So I understand smoothing groups, but know a little bit about the edge split modifier and marking your edges as sharp as well. Is this not the process you should use when baking a normal map or exporting into unreal 4? Is there another method with Blender to do smoothing groups?

Below are a few images.

https://answers.unrealengine.com/storage/temp/60282-test_03.png

Sharp edges

https://answers.unrealengine.com/storage/temp/60284-test02.png

Normal map generated in xnormal (y- for ue4 compatability) made with custom cage using displace modifier. Turns out fine in Xnormal viewer, though it does have issues with blender's render as well.

https://answers.unrealengine.com/storage/temp/60285-test_01.png

Ue4 result :(

Tested it in blender and the normal map isn't the problem. Works just fine once I flip the green channel for use in blender.

Product Version: UE 4.9
Tags:
test_03.png (370.8 kB)
test02.png (3.1 MB)
test_01.png (822.0 kB)
more ▼

asked Sep 26 '15 at 03:04 AM in Rendering

avatar image

ridley075
37 6 7 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

You can assign vertex groups in the vertex data. It's the triangle looking tab by the object data tab. That may be what you're looking for

more ▼

answered Sep 26 '15 at 03:47 PM

avatar image

EyeDee10Tee
2.1k 59 14 128

avatar image ridley075 Sep 26 '15 at 07:54 PM

Ok, this might have worked for me. I've changed my settings back and forth now, so I'm not entirely sure. Also, instead of using the edge split modifier, I instead used the sharp edges with the auto smooth in the normals section. Just set the smooth angle to be 180, but because of the sharp edges, it'll break the normals there. I also set the exporter to use normals only, maybe that was it as well. Either way, for this object I got it to work. Thanks EyeDee!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Try to apply the edge split modifier before you export. I know the option is there in the export settings but sometimes it doesn't work well.

more ▼

answered Sep 26 '15 at 07:55 AM

avatar image

EyeDee10Tee
2.1k 59 14 128

avatar image EyeDee10Tee Sep 26 '15 at 07:56 AM

Also I noticed the edge split runs along the hands? Can I ask why?

avatar image ridley075 Sep 26 '15 at 01:40 PM

Applying it didn't help. I think because it actually splits the object into different elements at those edges, the vertices are no longer welded. I think the normals need to be split on them, not the verts, but not sure if there's a way to do that in blender currently?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question