Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Fail To Import Provioson In 4.9

I Own a Mac Pro & A High End SLI PC, I Reinstalled X Code, Epic games launcher, ue4, 4.9, 4.7, 4,8, i revoked all my certificates created new ones... new provisions... i created new projects in unreal... No Matter What I tried Nothing Works.... When I Import Provision, it waits and loads ~10 sec then it changes to no provision found again ! this goes on on mac and windows . i tried using the iphone pakager, i tried project settings.... i tried wild card, i tried editing info.plist in engine\intermediate\ios..... i tried everything,... but when i click import provision for the second time and onward.... it says ( PROVISION ALREADY EXISTS DO U WANT TO REPLACE IT ) i click yes then it loads and turn into no provision found again.... i tried generate key from unreal... i tried generate key from x code.... or manualy by keychain.... noting works..... but i have a prototye of my actual game HATBOY on my iphone right now ! from last year using ue4 4.6 !!!! Also no check mark appears not in ue4 project setting nor in iphone packager.... THANKSalt text

Product Version: UE 4.9
provision ue4.jpg (85.9 kB)
more ▼

asked Sep 27 '15 at 08:35 AM in Packaging & Deployment

avatar image

51 2 2 6

avatar image JustZht Oct 14 '15 at 11:20 AM

Hi, I have the same problem... :(
Do you figured out that problem? Thanks.

avatar image Giulio Gasperini Nov 13 '15 at 12:21 PM

Hi guys, same exact problem here! Can anyone help us please?

avatar image JustZht Nov 13 '15 at 12:58 PM

Hi,Giulio Gasperini. Did you have 'IPP ERROR' on Output log? Seems there's only a few people have this issue :-(

avatar image Giulio Gasperini Nov 13 '15 at 01:03 PM

Hi, the IPP couldn't find the file UE4Game-Info.plist and basically didn't work. I found this file in another folder of UE4 (engine/intermediate) I tried to put it where the IPP asked but no luck! Don't know what to do, really

avatar image Samantha Sutton ♦♦ STAFF Nov 13 '15 at 06:55 PM

Hey Giulio,

Have you gone through the steps again and making sure everything is set up accordingly for iOS? If you're not sure, here is the iOS Documentation page. Is this happening on every version of the engine, do you have any logs that show the actual issue? Please include as many details as possible.


avatar image Giulio Gasperini Nov 16 '15 at 10:23 AM

Hi Samantha, thanks, solved, please have a look at comments below.

avatar image WhargouI Feb 26 '18 at 11:09 PM

Recreating the mobile provision file with the same name as the certificate doesn't work for me. I have never had luck working with Apple products. I was hoping this project might be different. If there are any other workarounds, I would love greatly appreciate any and all help.


(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Everyone, Hi Giulio, Actually about 1 month ago i put the time to go through 10 hours of reading ios developer library, to really understand this whole CF Bundle , ID , identifier, profile and other apple stuff.... after several attempts i managed to get my APP on my iphone5s on UE 4.9 !!! and then i stopped reading entirely :-D Yes Samantha This Problem Goes On In All version all on os 8.1 64bit and mac pro latest os ( before el capitan ) . now before this comment i went to where GIULIO said under (ENGINE/INTERMEDIATE) and even though my problem is fixed, u r RIGHT GULIO thats exactly where the files r on my system too... :) but my screen will always stay exactly as the pic i uploaded it stays GREY and no green chechmark appears and it sais no provisioN BUT ITS THERE ! and when i try to install the game it does ! now i simply fixed my problem by changing a bunch of names... i recreated all provision profiles and certificate and stuff with the name COM.IMMORTALEADER. and i made that consistent through all parts and it worked. it's apples fault by that part, but this files going to wrong folder is ue's problem . thank u all :) <3 in details currently my BUNDLE DISPLAY NAME and BUNDLE NAME are both = wild and my Bundle IDENTIFIER is com.immortaleader. this worked for me and i never dared change it :) bu t i am testing this on 4.10 as i comment

more ▼

answered Nov 15 '15 at 08:07 AM

avatar image

51 2 2 6

avatar image Giulio Gasperini Nov 16 '15 at 10:22 AM

Thank you so much, it worked for me too! I didn't move any .plist file and i just went through the all process again, naming everything consinstently in the Apple developer site. I changed the three names (bundle, bundle id, bundle identifier) in UE4 project settings with com.giuliogas, and it worked! Thanks again!

avatar image ImmortaLeader Nov 17 '15 at 12:01 AM

Glad That i Could Help Another Fellow Developer :)

avatar image rolfesam Mar 11 '19 at 12:31 AM

Kinda confused by this answer-- dealing with the same issue and could really use a simple list of how to solve this if anyone knows <3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question