x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

how to set-up my FPS to 90

Hi everyone! I want to know how to set-up my FPS into 90? I want my FPS to be fix in 90. Thank you in advance.

Product Version: UE 4.9
Tags:
more ▼

asked Sep 29 '15 at 01:45 AM in Using UE4

avatar image

yeeen
10 3 7 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Have you tried editor viewport console command " t.MaxFPS 90" ?

more ▼

answered Oct 02 '15 at 04:01 AM

avatar image

Iridescence
66 5 5 7

avatar image Iridescence Oct 02 '15 at 04:03 AM

If this works for you please remember to accept my answer, if not you can explain in more detail and i will try to advise. Have a good day.

avatar image yeeen Oct 02 '15 at 05:22 AM

i tried the console t.MaxFPS 90 but when i play it in oculus the FPS drops in 10fps :(

avatar image phil_me_up Oct 02 '15 at 12:38 PM

You can't really lock the game at any FPS, you can only specify the maximum target FPS.

If your game is dropping below 90FPS then you'll need to optimise it so everything can run faster.

avatar image yeeen Oct 05 '15 at 05:44 AM

thank you everyone for the help :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You should have mentioned oculus in your first post and you should continue to mention it in every post you make developing with oculus.

Try this: 1) If you've messed with your GameUserSettings.ini file, change the following settings back:

ResolutionSizeX=1280 ResolutionSizeY=800 bUseDesktopResolutionForFullscreen=False FullscreenMode=0 The following steps will work at higher resolutions, but results will not be as good.

2) Start up the demo. If you're not already in stereo mode, do ~ to enter the console and then "stereo on".

3) Put on your Rift and type the following to pop up an FPS monitor in your view:

stat fps Find the most complex scene in the demo exhibiting the poorest frame rate for testing. If your frame rate is good throughout, increase your ScreenPercentage with "hmd sp 200" or "hmd sp 300" and try again.

4) Enter the console with ~ and type the following commands:

oculusdev on hmdwarp 1=1 These commands have no apparent effect, but unless you do both of them, the command in the next step will have no effect (the second command is a workaround for a bug).

5) Set your DistortionScale to 0.5 using "hmdwarp s=0.5". This should cause your view in each eye to shrink to a small rectangle. Increase it gradually by 0.1 (e.g. "hmdwarp s=0.6") until you can no longer see black around the image. For me this happens around 1.3. (If you wish, you can fine tune it by increments of 0.01 at this point). The UE4 default is 1.715, which is really high.

This parameter setting does not affect your frame rate at all, but does improve image quality dramatically. Once you've found a DistortionScale parameter you like, you can reuse it in every demo - it only depends on your vision and how close you put your eyes to the lenses.

You will need to repeat steps 4 and 5 each time you run the demo. DistortionScale cannot currently be set in Engine.ini, and I don't know if it can be set programmatically. It might be possible to bind a key.

6) ScreenPercentage varies between 30 and 300, and determines the resolution of the offscreen buffer. Start it at 30 with "hmd sp 30". Wait for 10-20 seconds for your "stat fps" reading to climb to a maximum value. Your frame rate should be maxed out, but the image will look terribly blurry.

Increase it in steps of 10 while watching your frame rate (e.g. "hmd sp 40") - once your frame rate drops below your refresh rate, take it back down by 10 and you are done. If you later encounter frame drops, you can bring it down a little more.

If you're not happy with your image quality at this point, you may wish to slightly decrease DistortionScale as in step 5, which will reduce FOV but give you more image quality in return.

Very high ScreenPercentage values (e.g. in the 150-300 range) result in SSAA behind the scenes, and are roughly equivalent to running a Unity Rift demo at a higher screen resolution. This is why I said not to use a higher resolution in step (1).

If you close the demo normally, it will save your modified ScreenPercentage to your Engine.ini file automatically, and you will not have to repeat this step.

7) Hide your FPS again with "stat fps".

more ▼

answered Oct 02 '15 at 08:12 PM

avatar image

Iridescence
66 5 5 7

avatar image Iridescence Oct 02 '15 at 08:15 PM

Note: you may need to attempt these steps several times before you get the results you are looking for, other wise it may be poor level design or some other optimization that needs to take place.

avatar image yeeen Oct 22 '15 at 12:52 AM

thanks, i will try this..if it works i'll let you know :)

avatar image yeeen Oct 23 '15 at 03:09 AM

i didn't work :(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question