x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[BUG] [Android] Playing any sound longer than 5 seconds causes the sound to trigger 3 times in quick succession

I'm a little concerned that no-one else has reported this, but I'm seeing it quite consistently. On Android, if I play a piece of music or a sound effect that is longer than 5 seconds, it seems to trigger 3 times in succession, before playing correctly. It doesn't matter whether this is an Audio Component that I activate using the Play node, or whether I use Play Sound 2D. I saw this in my own project, but was able to reproduce it in Tappy Chicken and the SideScrollerExample project, in the former by hooking the Play node up to the end of the Title Screen animation, and in the latter by triggering it from the Game Mode's BeginPlay event. I've seen it both with my own pieces of music, and with 'Starter_Music01' from the Starter Content.

This has been observed on a Samsung Galaxy Nexus, an LG G3, and a Motorolo Moto X (2nd Gen.).

Product Version: UE 4.9
Tags:
more ▼

asked Sep 29 '15 at 01:47 PM in Bug Reports

avatar image

GiraffeCat
37 2 9 17

avatar image JaridI Sep 30 '15 at 04:25 AM

I am having this issues as well on the Galaxy S4. The music on my title screen stutters a few times before playing correctly. I have tried attaching the sound in every way I know how: play sound at location, play sound 2D, and a sound que in the level itself. I have also tried changing the compression. Any suggestions?

avatar image CarlosRBSTSN Sep 30 '15 at 12:00 PM

I am having the exact same problem in 4.9.1, previously in 4.8.3 everything worked fine.

I observed this in Samsung Galaxy Note 10.1

avatar image aussieburger Sep 30 '15 at 02:48 PM

Same problem as well (Note 4) - in my case it's hard to say what is causing it exactly - some sound wavs play fine and it's just one that has this triple stutter - I see very little difference between the wav files even the length in some cases is similar. Occurring in 4.9.1 not occurring in 4.8 and earlier

avatar image CarlosRBSTSN Sep 30 '15 at 03:32 PM

As far I understand, this happens with 'Adjust Volume'. Tried using 'Audio fade in' but same result.

It does not happen when I play the sound without changing volume at all.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hey All,

I was able to confirm what you are reporting here, and have gone ahead and entered a bug report for this issue (UE-21709). Although not optimal, for now I would stick with your temporary workaround of setting the start time at .001

Once this issue has been addressed by the engineers, we will begin working on getting a fix implemented for an upcoming engine release. For updates to this issue, we ask that our users navigate to our Forums (Announcements and Releases Section) or our Documentation (Release Notes Section). We post all the bug fixes in the full engine release notes, but some are added to the hotfix notes found on the forums.

Thank you all for taking the time to report this issue, and for your patience while we tested. If you have further questions, please let me know.

Thank you,

Andrew Hurley

more ▼

answered Oct 01 '15 at 09:08 PM

(comments are locked)
10|2000 characters needed characters left

alt text Doing this will fix it for the time being

60099-untitled.png (88.6 kB)
more ▼

answered Sep 30 '15 at 03:05 PM

avatar image

d0nt4g3t
16 7

avatar image CarlosRBSTSN Sep 30 '15 at 03:35 PM

That does not work for me; just tried.

avatar image GiraffeCat Oct 01 '15 at 09:10 AM

It actually did work for me, but I didn't have to do anything with adjusting the volume, I just played the audio with a start time of 0.001. I'm going to wait for word from Epic about this issue before marking it as resolved, though.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question