x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UMG: Combo Box event "OnGenerateWidget" not called

It seems there is a bug in UMG's combo boxes. Usually one can implement the "OnGenerateWidget" event in the combo box to populate the combo box's options with custom widgets. This works fine when the widget that contains the combo box is being added directly to the viewport.

However, when that widget (which contains the combo box) is added as child to another widget, and that other widget is added to the viewport, then the "OnGenerateWidget" event function of the combo box is not being called any more.

Unfortunately this is a major bug in our project.
Any ideas, at least for a workaround?

Product Version: UE 4.9
Tags:
more ▼

asked Sep 30 '15 at 11:16 PM in Bug Reports

avatar image

haimat
231 20 36 42

avatar image Rudy Q ♦♦ STAFF Oct 01 '15 at 01:52 PM

Hello haimat,

I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints that may be involved with this issue?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Rudy, thanks for your reply. I created a new project as requested, and that helped me to track down the reason for this issue. So the problem comes after creating a new binding function for the OnGenerateWidget event. I renamed that function afterwards, which led to issue as described. When I remove the binding and re-bind to that function (even if still renamed) it works again. Thanks!

more ▼

answered Oct 01 '15 at 08:14 PM

avatar image

haimat
231 20 36 42

avatar image Rudy Q ♦♦ STAFF Oct 01 '15 at 08:23 PM

Hello haimat,

I am happy to hear that you have gotten things working again. I am going to mark your last post as the answer to this issue.

Make it a great day

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question