x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Build crashes when adding an extra gameplay module

I have this project that fails on building. When e.g. building it from Visual Studio I get the following message:

alt text

However, the specified dll file is in the Binaries/Win64 folder where it should be. The exact same project compiles fine on another computer with the same (as far as I can tell) setup.

I narrowed it down to be a matter of adding a gameplay module . I have tried with a minimal example where everything works fine until I add a gameplaymodule with a single class with a single constructor only writing an UE_LOG command.

This is really frustrating and any advise is much appreciated!

Product Version: UE 4.8
Tags:
capture.png (22.4 kB)
more ▼

asked Oct 01 '15 at 02:48 PM in C++ Programming

avatar image

SimenA
15 3 7 10

avatar image SimenA Oct 01 '15 at 04:19 PM

Yes, I already added the xxx.Build.cs and and also did the .uproject as you specify. However, I now changed the loading phase of the gameplay module from Default to PreLoadingScreen, and now it works, thanks a lot!!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Did you add it into the xxx.Build.cs as module dependency? Also try adding it to the .uproject file

 {
     "FileVersion": 3,
     "EngineAssociation": "4.9",
     "Category": "Samples",
     "Description": "",
     "Modules": [
         {
             "Name": "ShooterGame",
             "Type": "Runtime",
             "LoadingPhase": "Default"
         },
         {
             "Name": "ShooterGameLoadingScreen",
             "Type": "Runtime",
             "LoadingPhase": "PreLoadingScreen"
         }
     ],
 
more ▼

answered Oct 01 '15 at 03:38 PM

avatar image

lion032
986 31 80 55

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Not sure if this altogether solves the problem, but at least it works around it and makes the gameplay module work (Thanks to @lion032 ):

In the .uproject, in the gameplaymodule that fails, change the LoadingPhase from Default to PreLoadingScreen. In my case this made the build work smoothly!

more ▼

answered Oct 01 '15 at 04:23 PM

avatar image

SimenA
15 3 7 10

avatar image lion032 Oct 01 '15 at 04:39 PM

You are welcome!

Yes this is correct I forgot to change it in my answer.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question