x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

When cooking assets for shipping I get an error Plants was missing the usage flag bUsedWithInstancedStaticMeshes. How can I fix this?

When cooking assets for deployment I get an error "Plants was missing the usage flag bUsedWithInstancedStaticMeshes". How can I fix this? I don't know where to start troubleshooting this problem. Is there any body who can help me?

Product Version: UE 4.9
Tags:
more ▼

asked Oct 02 '15 at 11:41 AM in Packaging & Deployment

avatar image

Wamdon
1 1 2 3

avatar image Sean L ♦♦ STAFF Oct 02 '15 at 03:30 PM

Hello Wamdon,

In order to diagnose your issue, I'll need some more information from you. What platform are you packaging to, and which device are you planning to use? Could you provide the steps that you are using to package your game? Also, be sure to have a look at the packaging and cooking documentation to see if you can find information regarding the issue that you are having: https://docs.unrealengine.com/latest/INT/Engine/Deployment/index.html

Have a great day,

Sean Flint

avatar image Wamdon Oct 02 '15 at 05:58 PM

Hi, thanks for the link Sean. I am trying to package to Windows 64-bit, and I am planning to use it on a computer with Windows 10 64-bit. The set up was done in packaging settings where I allocated the asset directories and then I went to windows>windows 64-bit within the packaging options. It should probably mention that game loads fine, but the materials for the plants are missing. I have checked the asset directory includes these materials for the plants. This is what it's showing:

LogMaterial: 0.000174 seconds spent updating 1 materials, 1 interfaces, 0 instances, 0 with static permutations. LogMaterial:Warning: Material /Game/KiteDemo/Environments/Trees/ScotsPine_01/ScotsPine_01_Fronds_Mat.ScotsPine_01_Fronds_Mat needed to have new flag set bUsedWithInstancedStaticMeshes ! LogMaterial: Missing cached shader map for material ScotsPine_01_Fronds_Mat, compiling. MapCheck:Warning: Warning ScotsPine_01_Fronds_Mat Material /Game/KiteDemo/Environments/Trees/ScotsPine_01/ScotsPine_01_Fronds_Mat.ScotsPine_01_Fronds_Mat was missing the usage flag bUsedWithInstancedStaticMeshes. If the material asset is not re-saved, it may not render correctly when run outside the editor. Fix LogMaterial: 0.000184 seconds spent updating 1 materials, 1 interfaces, 0 instances, 0 with static permutations. LogMaterial:Warning: Material /Game/KiteDemo/Environments/Trees/ScotsPine_01/ScotsPine_01_Billboard_Mat.ScotsPine_01_Billboard_Mat needed to have new flag set bUsedWithInstancedStaticMeshes ! LogMaterial: Missing cached shader map for material ScotsPine_01_Billboard_Mat, compiling. MapCheck:Warning: Warning ScotsPine_01_Billboard_Mat Material /Game/KiteDemo/Environments/Trees/ScotsPine_01/ScotsPine_01_Billboard_Mat.ScotsPine_01_Billboard_Mat was missing the usage flag bUsedWithInstancedStaticMeshes. If the material asset is not re-saved, it may not render correctly when run outside the editor. Fix

Thanks Alun

avatar image Sean L ♦♦ STAFF Oct 02 '15 at 08:57 PM

Hello Wamdon,

Thank you for providing the additional information and the logs. We will be looking into the issue, and get back to you once we have a solution.

Have a great day,

Sean Flint

avatar image Wamdon Oct 04 '15 at 03:17 PM

Thank you, Sean

Alun

avatar image Wamdon Oct 02 '15 at 06:06 PM

I have just found this and it sounds lilke the same problem.....

https://answers.unrealengine.com/questions/251673/material-flag-not-saved-automatically.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Wamdon -

If you open the Material you have assigned to the Plant asset and in the Material Attributes details panel under Usage check Used with Instanced Static Meshes true, then resave your material. This should clear up any packaging issues caused by this error. If you plants use multiple materials, each material will need to have the flag set as well.

Thank You

Eric Ketchum

more ▼

answered Oct 05 '15 at 03:05 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image Wamdon Oct 12 '15 at 06:10 PM

Thank you this worked for me.

Alun

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question