x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Cannot create new folders in ..."

Hello,

I cannot create new folders in the c++ code source folder in the ue4 editor. I downloaded the Shooter Game template and when I right click on the source code folder the "new folder" button is grey out. Even if I create new c++ class in a different folder the folder doesnt appear ...

alt text

thank you for your help,

Ronan

Product Version: UE 4.9
Tags:
more ▼

asked Oct 03 '15 at 12:04 AM in Using UE4

avatar image

grandwaazoo
3 1 2 3

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Apologies, the "New Folder" option for C++ classes was never hooked up, however you should just be able to type in a sub-path when using the "New C++ Class" option, and then the addition of that class will cause your new sub-folder to appear.

The phrasing of your question makes it sound like that might not be working though? If so, has your new class definitely been compiled? (This should happen automatically unless you changed your project settings to require a manual compile and hot-reload).

more ▼

answered Oct 04 '15 at 06:03 PM

avatar image

Jamie Dale STAFF
7.4k 176 66 304

avatar image grandwaazoo Oct 04 '15 at 07:01 PM

Hey, no problem,

I tried with "New C++ class". I add my folder in the path field. I validate this, unreal creates all its stuff and compile the new class. After this the folder still does not appear in the the project. I also tried to compile in VS with the config development editor (the folder is existing on the vs side), and my folder is still unexist in UE editor :(.

avatar image Jamie Dale STAFF Oct 04 '15 at 07:29 PM

Strange. I just tested this myself and it worked as expected.

What class were you trying to create, and what path were you trying to create it at? I also assume from your screenshot that you're using the ShooterGame sample project?

Also, could you check for me that you have "Show Folders" enabled under the "View Options" in the Content Browser. Thanks.

avatar image grandwaazoo Oct 04 '15 at 08:04 PM

Okay now its working. My class did not inherit from any unreal class thats why it didn't show off . Thank you for your time, have a good sunday !

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question