x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Why is my hightmap not working?

So I import my hightmap and when I do so it does this... alt text

I even been flickering with my settings and that still has not helped. I was watching a guy do his hightmap from a later version of UE4 and it worked fine when he did it.

alt text This is the hightmap I'm using.

So any ideas to why this is happening?

Thanks for your time! ;}

Product Version: UE 4.9
Tags:
more ▼

asked Oct 03 '15 at 04:36 PM in Using UE4

avatar image

sayer6913
19 20 17 26

avatar image sayer6913 Oct 04 '15 at 04:59 PM

Anyone know why this is doing this?

avatar image Jacky Oct 04 '15 at 07:21 PM

Do you have tessellation activated in your material? I think the only time i've seen people having this problem is with tessellated landscape materials sometimes.

avatar image sayer6913 Oct 05 '15 at 07:06 AM

Ok I'll check.

avatar image Logan Bailey ♦♦ STAFF Oct 06 '15 at 06:26 PM

Hello Sayer6913,

I would like some more information regarding this issue.

First, how are you making this heightmap?

Heightmaps require a 16 big greyscale image for certain scale in order to function properly when importing them to UE4.

This is our documentation on heightmaps :

https://docs.unrealengine.com/latest/INT/Engine/Landscape/Custom/index.html

This is our documentation on recommended scales for your landscap

https://docs.unrealengine.com/latest/INT/Engine/Landscape/TechnicalGuide/index.html

I do see the stretching but only on the very edge of the map. After troubleshooting with this documentation see if this fixes the issue.

Logan

avatar image sayer6913 Oct 05 '15 at 07:20 AM

I enabled the tessellation and it still stretches. Is their any videos that may help? Thanks for your time :)

avatar image Jacky Oct 05 '15 at 07:06 PM

Dont enable tessellation if it isnt already. I meant tessellation was causing this kind of issues for some users.

Is this the only heightmap you are having this issue? Have you managed to get another heightmap working before this one? Which format are is your heightmap in?

avatar image sayer6913 Oct 05 '15 at 07:31 PM

This is the first hightmap I used, I could try a different one. And what do you mean by format? Like create asset? I'm using the first person shooter asset.

avatar image sayer6913 Oct 05 '15 at 07:51 PM

Ok, I've tried a different one and it still stretches D:

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I saved your image that you posted. I took this image into photoshop and changed this to greyscale. You had it set to RGB. After this you need to set the image channel to 16 bit. By default it is 8 bit. It works fine after that. It has some extreme points but it does work. Your white points will always be extreme. I would look into our documentation for Height maps and the recommended sizes for the landscape you are creating.

alt text

workingmap.jpg (120.6 kB)
more ▼

answered Oct 08 '15 at 02:26 PM

avatar image sayer6913 Oct 09 '15 at 01:09 AM

Ok, thank you ;)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question