x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Triggers from parent vehicle BP collide with child Vehicle BP

Hi i try do visual damage in my vehicles, and I create many triggers(red capsule and spheres) on perimeter of parent vehicle BP(and i set triggers collide with everything( other vehicles also, because i need create damage from others vehicle) with begin overlap event and do check on every BeginOverlap from collides, but i have a problem ---- so if i control parent Vehicle BP on slow speed all works fine but if i drive very fast some times i get self collide(but only some times), if I use my child Vehicle BP and i drive even slow on speed i always get self collide with child vehicle bp, so i have a question how i can save vehicle collision cheeking with other actors(vehicles) and fix self colliding with SELF vehicle BP?

I do temp fix with compare overlap actor and self actor but its temp solution and i need disable begin overlap with self BP once and for all, its possible?

UPDATE: i think there is a bug, because i try to change collision preset for my colliders triggers to ignore vehicle but its not work and when my vehicle drive all triggers sphere collides with vehicle...

PS maybe there is a batter way to do checking in specific vehicle places feel free to share your way)))

alt text

Product Version: UE 4.9
Tags:
снимок.jpg (65.1 kB)
more ▼

asked Oct 03 '15 at 10:04 PM in Blueprint Scripting

avatar image

zip
152 25 29 57

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Select all collision shapes in the PhAT (Physics asset tool) by pressing Ctrl+A then on the top you will have "Collision Off" button, this will turn off the collision between the selected shapes.

Hope this answers your question.

more ▼

answered Oct 06 '15 at 08:56 AM

avatar image

lion032
981 31 80 55

avatar image zip Oct 06 '15 at 07:58 PM

thx for reply, I try, but this doesn't help, after disable collision start be invisible for other physical object.... so this method work for me((((

avatar image lion032 Oct 06 '15 at 08:04 PM

What type of physics object is it set to? Simulated or kinematic?

avatar image zip Oct 06 '15 at 09:53 PM

vehicle wheels set to kinematic, body to Simulated, others parts to default(and i cant change that because vehicle stops work correctly its the MUST for vehicle) like in official tutorial documentation on epic...

here i record video of my problem https://www.youtube.com/watch?v=98EsKfITFtY&feature=youtu.be

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question