x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaged Unreal projects will not open on my PC

Packaged Unreal projects will not open on my PC (apologies, this seemed the most appropriate forum to post in)

Hi all, rather strange one this… indeed I have been able to find few (if any) posts anywhere with a similar problem – at least not any which don’t drive an error code. I would be so grateful for any insight / help please.

My problem is that I find any packaged (self-contained) Projects / Demos / Games using the Unreal engine will not open on my PC. I double-click the .exe, the egg timer pops up for a second and then nothing…

There are certainly UE4 developed projects the mix (the ‘Unreal Kite’ demo), but also many which I have downloaded from the Oculus VR Share Developers website which will also be UE4 and potentially (though I can’t be sure) UE3.

All Unity packaged project open fine on the PC for which I’m seeing the issue and indeed I have tried opening the problematic UE files on two other PC’s and they open fine. Clearly then, there has to be an issue with this specific PC and it’s driving me nuts trying to resolve it, as I’m rather hoping to start developing my own UE concept demos for Oculus moving forward.

I am running Windows 8.1, on a 2x Titan X rig (SLI enable or disabled), Nvidia 356.04 Beta Drivers (though the issue has remained for every past iteration I’ve ever had installed on this PC – circa 6x Nvidia driver versions over 6 months) and have applied every Windows update available. The issue was previously an annoyance (i.e. didn’t get to run the Kite demo on my rig), to now becoming a real show-stopper problem.

After pouring through these forums and trying several .DLL replacement fixes I’ve come across, used to fix other peoples similar issues starting packed UE content (all be it in those cases, it had driven an error message, where mine has not) I came across the suggestion of using Dependency Walker for 64bit to generate a log. I have complete this for two of the twelve UE packages that won’t open and have attached the log files to this post (‘Henry’, which I sourced from here: https://share.oculus.com/app/henry-trailer and ‘Mythos’ which I sourced from here https://share.oculus.com/app/mythos-of-the-world-axis ).

I’ve poured through the logs (which are a little overwhelming tbh) and can’t see any path errors, missing or invalid modules, or load failures that jump out as being the cause, though there are some related to Missing Modules for API-MS-WIN-CORE-KERNEL32-PRIVATE-L1-1-0.dll, API-MS-WIN-CORE-PRIVATEPROFILE-L1-1-0.dll and a API-MS-WIN-SERVICE-PRIVATE-L1-1-0.dll). The two examples logs I’ve given end with similar messages such as “Exited ‘package name here’ (process 0xA3C) with code – 1073741819 (0xC000000005)

If anyone has any ideas / suggestions, or better still can look at the logs with a more knowledgeable head than mine, I’d be truly grateful. Over the past few weeks I have tried the following the try to resolve:

SO FAR:

  1. Updated to Beta NVIDIA drivers (recommended by Oculus Dev), indeed rolled back a few times to earlier / later drivers and used DDU to purge system of any drivers before reinstalling.

  2. Installed / uninstalled the redist Pre-Reqs for UE4 X64

  3. Have installed / uninstalled all iterations of C++ Visual (vcredist X64) from 2010, 2012, 2013 and 2015.

  4. Downloaded and installed the latest Unreal Engine Editor (4.9.2) hoping that might add any ‘missing .DLLs back in), including a project (the Showdown VR Project), which incidentally runs perfectly (all be it that it’s not a packaged build, it’s a project that I imported into the Engine and rendered).

  5. As you can’t really reinstall Direct X on Windows 8.1, have Re-installed DX from the Unreal Engine folder.

  6. Have renamed key .DLL’s and replaced by using reinstall methods above (sorry, so many to name now – am probably not making the situation any better either!)

LOGS: link text link text

Product Version: UE 4.9
Tags:
henry.txt (562.8 kB)
mythos.txt (562.9 kB)
more ▼

asked Oct 04 '15 at 12:46 PM in Packaging & Deployment

avatar image

Scoobyroo
1 1 1 2

avatar image Samantha Sutton ♦♦ STAFF Oct 06 '15 at 05:01 PM

Hey Scoobyroo,

Have you tried simply uninstalling and reinstalling 4.9.2 and seeing whether or not your projects load up within the Editor? If your projects are opening up within the editor, but the .exe applications created from the packaging process are not opening, could you please screenshot or copy and paste the error message when trying to run these applications? Please try to run these applications as an administrator too.

Are you able to create a new template project, package and open the application without any trouble?

Looking forward to hearing back from you, thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Solved the issue! Avast was messing with UE4. Now if you too are using it, chances are you suffers from the same problem or it is also related to your own anti-virus acting the same.

Here's what I've done, but remember I'm french so i'm translating my own UI and it might not be exactly accurate:

  • Open Avast user interface

  • Go into Parameters

  • In the pop-up menu, go into "active protection"

  • then into "Files Agent" customisation

  • In the second pop-up menu, go into "exclusion (or exceptions in english maybe)"

  • Add the entire unreal editor folder (should be "/program files/epic games/*") and exclude from writing/reading/execute

  • Do the same for the folder in which you put your cooked and packaged projects

And voila! It solved it for me. Since I had the exact same issues than you all, chances are high that you suffers the same issue with avast or your own anti-virus

more ▼

answered Dec 26 '15 at 10:30 PM

avatar image

Alan LJ
51 1 65 10

avatar image Westtunger Dec 27 '15 at 01:07 PM

Hey ! I'm using avast too, and i'm pretty sure that he cause the problem ( which why that works without internet ).

Thanks you very much ! Problem solved for me =)

Ps : I'm belgian ;)

avatar image VanNolan Dec 27 '15 at 09:55 PM

Solved my issue :) Thank you Alan LJ

(By the way, I've previously tried to disable Avast instead of changing the parameters and as it didn't work (= I didn't do it correctly), I though the problem was coming from elsewhere :$)

avatar image Alan LJ Dec 28 '15 at 08:50 AM

happy to help :-)

avatar image DeXter4Win Jan 10 '16 at 06:12 PM

Works for me as well. Thank you @Alan LJ - you saved my night!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey Scoobyroo,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

more ▼

answered Oct 13 '15 at 01:26 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have the exact same problem. I am running a PC with Windows 10 right now. Just like 2 weeks ago i had no problems at all with running the exes and now I can't open any packaged projects. It doesn't matter if they are my own or example projects or originating from a different unreal 4 version. I also tested it with 2 other PCs that run the applications without a problem. It is very weird because no error message appears and there isn't even a process in the task manager for the application even though the explorer window crashes because of it.

more ▼

answered Nov 17 '15 at 08:38 PM

avatar image

launzone
26 3 6 11

avatar image je0810 Nov 17 '15 at 09:17 PM

i'm suffering a similar problem packaged project exe's just hang in task manager and task manager cannot end the process so i have to reboot to clear from TM, although the .exe from packaged project binary folder works and also is there no splash screen on packaged projects anymore ? if its been removed im ok there if its not ... its missing

avatar image je0810 Nov 17 '15 at 09:18 PM

oh forgot to add im running win7 64bit and have tried this on 4.9 and 4.10

avatar image Samantha Sutton ♦♦ STAFF Nov 20 '15 at 10:10 PM

Launzone and Je0810,

Could I please have both of your DXDiag logs? Are you also having the same exact issue as listed above?

Looking forward to hearing from you both, thanks!

avatar image launzone Nov 21 '15 at 04:00 PM

I don't know if it is the same exact Issue as listed above but as I understand it, yes. I can't open any packaged unreal projects on my PC and the projects do work on other PCs.link text

dxdiag.txt (89.3 kB)
avatar image Samantha Sutton ♦♦ STAFF Nov 25 '15 at 04:37 PM

Thank you for providing me that information. Is there an error that pops up when you try to run packaged games on your computer? Are you able to launch the project and it still populates? Is it sitting in the task manager attempting to open, or does it never actually pop up in your task manager?

What is your method of packaging? Can you please provide me with your steps?

If there are any logs you can provide from the project (saved > logs), please provide them to me for additional review. Especially if the launched packaged project is actually crashing.

avatar image launzone Nov 27 '15 at 05:29 PM

No as stated in my first commend, there are no error messages. I am able to launch the project in the editor and play the game in the editor and the standalone version. But it crashes when I open the packaged version. I don't know what populate means. It never shows up in the task manager but it somehow crashes the whole explorer. I have to restart the explorer when I try to open it. My method of packaging is simply clicking package and choosing windows 64bit. I can attach you a screenshot of my packaging preferences. But I never changed anything here since it stopped working: alt text

There are a huge bunch of Logs in that Folder, also some other folders with strange numbers. I can send you the latest one. Please tell me if you need additional ones. link text

Would be happy for any help, thanks!

avatar image Samantha Sutton ♦♦ STAFF Dec 02 '15 at 08:50 PM

Thank you for providing me with the logs. I do not see any errors within the logs themselves.

So when you're launching these projects on the other 2 computers that you have, what is the major difference between them and the computer that isn't working correctly?

I do have a thought; could you please check the applications that Windows Firewall is blocking and make sure that UE4 isn't one of them? It's possible that it was accidentally set to block UE4.

Looking forward to hearing back from you, thanks!

avatar image VanNolan Dec 10 '15 at 09:44 PM

Hello, I'm having the same problem since the latest windows updates I'd say. I have no idea where to look.

  • My NVidia drivers are untouched since more than a year.

  • The same build (= same uproject, same files, same config) was ok a week ago.

  • I've closed all the application that could be guilty (I have alt-tab issue related to adobe applications for ex).

  • The log doesn't point at anything especially

the only thing I can tell:

  • The exe starts and creates a process in the tm

  • Two other processes of the same name are created also.

  • The first one can be killed (it's often stucked at 1024 or 2048 MB in RAM) and the other ones can't (the directory can't be deleted for the reason the exe file is then locked by windows because still being used by a process).

In the meanwhile, thank you for the support you give on this forum. So far it's the first time I need to post :)

avatar image Samantha Sutton ♦♦ STAFF Dec 11 '15 at 05:30 PM

Did you check your firewall or anti-virus options and make sure that UE4 was not blocked behind any of them? Does this still happen after a restart, or when you try on another profile on your computer? Have you tried verifying your version of the engine or even uninstalling and reinstalling it?

avatar image VanNolan Dec 13 '15 at 08:14 PM

I: - Checked the firewall settings - Temporarily switched off my anti-virus - Checked the dx settings (through dxdiag)

but the result remains the same. I'm now trying to uninstall and reinstall UE

avatar image VanNolan Dec 13 '15 at 08:29 PM

For your info, on other computers the game is running well.... I tried reinstalling the launcher + verifying the installed version of UE4.9.2, but I don't see any changes.. Something's definitely wrong with my computer but who knows what..

avatar image Samantha Sutton ♦♦ STAFF Dec 14 '15 at 08:41 PM

Could I please see your dxdiag for your computer?

avatar image VanNolan Dec 16 '15 at 08:46 PM

link text

Here it is :)

dxdiag.txt (71.2 kB)
avatar image Samantha Sutton ♦♦ STAFF Dec 21 '15 at 08:59 PM

VanNolan,

Thank you for your DxDiag, I appreciate being able to verify that your computer does meet the recommended specifications. I have a few questions for you though: Does your packaged project show up in your TaskManager? Are you able to bring it to front? Does it seem stuck?

Thank you!

avatar image Westtunger Dec 22 '15 at 03:07 PM

Since i have the same kind of error ( unable to launch any .exe, they doesn't appear in the task manager and nothing happen except a freeze of the explorer window ), i will ask you if you can help me.

Everything works fine in the editor.

dxdiag.txt (71.4 kB)
avatar image Westtunger Dec 23 '15 at 05:09 PM

After some test, i've found that i'm able to run the game when i package it without internet, but if i have it during the packaging, he doesn't work

avatar image Samantha Sutton ♦♦ STAFF Dec 23 '15 at 08:21 PM

Could you please package a sample project and gather the output logs from the editor. Please obtain one log while the editor is offline and the other log while the editor is online.

avatar image Westtunger Dec 24 '15 at 11:21 AM

I'll do this during this week end, because of christmas. Thanks to you and merry christmas =)

avatar image VanNolan Dec 22 '15 at 06:30 PM
  • Does your packaged project show up in your TaskManager? > I can see the project showing up in the list of the processes.

  • Are you able to bring it to front? No, I don't see an option to do so. Alt-tab or Win-tab won't show my project.

  • Does it seem stuck? yes, stucked at 792 Kb.

Additionnal info: I recently switched to windows 10. Thinking it could change anything. When I was still under windows 7, I could also see two zombie processes of the same name of my project. Those two couldn't be killed in any way and were preventing me to delete the folder (ofc, the files were still being used by a process). The two processes have been created by the first try.

avatar image Alan LJ Dec 26 '15 at 08:56 PM

Having the exact same problem here... and it's killing me!! Packaged a project and cooked it in 4.10.1 and it just won't launch no matter what. Cooking the same one in 4.9 result in the same problem and as a matter of fact, cooking and packaging just about any project, no matter which, will end up the same. Three processes appears in task manager, one stuck at 104kb and the other two at 112kb. Stays the same and just can't even kill them. Ultimately, explorer crashes and even then I can't kill the processes (nor can I delete the package directory for that matter due to it being in use). Regrettably, I haven't cooked anything in a while and it was on a different PC so I've no ways of knowing wether it would have worked until recently...

I've enclosed the output log and my dxdiag

link text link text

outputlog.txt (334.9 kB)
dxdiag.txt (37.5 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question