x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.9] GearVR MSAA

I'm using UE4.9 with GearVR. MSAA is supposed to be enabled by default with this version, but I'm sill seeing lots of very visible jaggies. How can I check if the antialiasing is actually enabled and working?

Product Version: UE 4.9
Tags:
more ▼

asked Oct 05 '15 at 09:47 AM in VR

avatar image

devel.bmad
434 43 49 64

avatar image druidsbane Oct 08 '15 at 04:29 AM

I too have the same problem. I wonder if there are specific settings that need to be enabled or disabled to allow MSAA to work properly.

Edit: I should add that I had this issue on the Note 4 both 4.4.4 and now on 5.0.1. T-Mobile still hasn't released a 5.1.1 update and it looks like they may never do so and if any update ever comes it would be 6.0, who knows what problems that will expose.

avatar image devel.bmad Oct 08 '15 at 09:36 AM

I'm using 5.1.1 (snapdragon) and it does not seem to work on the note 4. The same projects works fine on an S6.

avatar image devel.bmad Oct 12 '15 at 10:43 AM

Any feedback about how to check if it is actually working or not?

Setting gearvr.EnableMSAA=0 in ConsoleVariables.ini file does not seem to change anything in my case.

avatar image devel.bmad Oct 28 '15 at 03:12 PM

Any feedback?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Unfortunately, bug still exists in 2017 in 4.16, it's been 2 years. Hopefully, in 2018 they will fix it.

more ▼

answered Aug 03 '17 at 09:43 PM

avatar image

smbv1
21 5 6

avatar image 6r0m Feb 12 '18 at 03:18 PM

not yet((((

avatar image smbv1 Feb 12 '18 at 03:20 PM

Why Epic ignores this critical bug for so long? or maybe it is Oculus?

avatar image 6r0m Feb 12 '18 at 03:24 PM

Very interesting thing and I assumed that without core modification there are nothing to do. Nobody are develop under this platform?)

avatar image smbv1 Feb 12 '18 at 03:26 PM

I develop for GearVR now, but they don't improve it.

avatar image 6r0m Feb 12 '18 at 03:33 PM

on Unreal Engine? very ugly aliasing - I tried to use MSAAx8, device profiler http://joxi.net/Dr8Kx5NI4OO61A but nothing work( or have you reconciled to this?

avatar image smbv1 Feb 12 '18 at 03:34 PM

The problem with MSAA not only in GearVR but also everywhere else. I also develop for HTC Vive and there also glitches on the edges.

avatar image 6r0m Feb 12 '18 at 03:41 PM

I haven't this glitches on HTC Vive (for example clean VR Template). For Gear VR you just putting MSAAx8 or there are more things to decrease aliasing?

avatar image smbv1 Feb 12 '18 at 03:43 PM

MSAA has a problem on the edges, it is a common "feature". You can't skip on this. The only way to skip it to use TemporalAA but it blurs entire view, not only the edges.

I just put 8 or 4, I personally see no difference.

avatar image 6r0m Feb 12 '18 at 03:44 PM

Can I turn on TemporalAA for Gear VR?

avatar image smbv1 Feb 12 '18 at 03:46 PM

I have not tried because for the performance MSAA is the best. I currently work on the project with MSAA and I had to remove some objects and reworks them, such as a fence or any kinds of the grid because of it oversharp.

avatar image 6r0m Feb 12 '18 at 03:50 PM

good luck, bro)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question