x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Automation Tool failed to run successfully

Hi!

I’m a beginner and trying to get my project to work on Samsung Gear VR but i have a problem trying to package the project. When I try to package the project it says that the automationtool was unable to run succesfully. How can I fix this? Heres the end of the log:link text

Product Version: UE 4.8
Tags:
more ▼

asked Oct 05 '15 at 02:40 PM in Packaging & Deployment

avatar image

Unrealistic Engineer
21 3 5 6

avatar image Samantha Sutton ♦♦ STAFF Oct 06 '15 at 07:12 PM

Hey Unrealistic Engineer,

Is this the full log or just the end, as the title describes? If it's simply just the end of the log, could you please upload the full log so I can look over the errors more closely. I also wanted to make sure that you've set up AndroidWorks properly?

Looking forward to hearing back from you, thanks!

avatar image Unrealistic Engineer Oct 07 '15 at 10:51 PM

Hey, thanks for the reply!:)

Yes, the previous message included only the end of the log, here's the full log in its entirety: link text

Can you check whether or not I've installed AndroidWorks correctly from that code?

the full log.txt (45.5 kB)
avatar image Samantha Sutton ♦♦ STAFF Oct 08 '15 at 04:24 PM

It looks like you may not have your Android SDK settings set up correctly, here is a visual example that should help you:

Android SDK

androidsdk.jpg (116.5 kB)
avatar image Unrealistic Engineer Oct 12 '15 at 02:30 PM

It seems to me that I have everything in their correct folders, the only thing I have missing is that Location of JAVA option. Could that be the answer? How do I get that option?alt text

android sdk.jpg (83.3 kB)
avatar image Samantha Sutton ♦♦ STAFF Oct 13 '15 at 06:01 PM

Hey,

Have you tried following the Android SDK Mac instructions? You need both Java 6 and 7 in order for this to work on a Mac.

Thanks!

avatar image Samantha Sutton ♦♦ STAFF Oct 19 '15 at 01:47 PM

Hey,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

avatar image Unrealistic Engineer Oct 20 '15 at 02:06 AM

Hi!

Sorry it took so long to get back, I had so many things to do. Yes, I installed both Java 6 and 7 but I still don't have Location of JAVA as an option in the Android SDK settings. Is there something else I have to do or should I try to install Java again?

Thanks!

avatar image Samantha Sutton ♦♦ STAFF Oct 27 '15 at 09:17 PM

Have you tried updating your version of the Engine after you've verified that your Java is updated? Did you get your version of the engine from Binary or Source?

Looking forward to hearing back from you, thanks!

avatar image Unrealistic Engineer Oct 28 '15 at 05:54 PM

It's binary I think, since I just downloaded it from unrealengine.com. Yes I have the latest version of Unreal Engine 4.9 and there's still no Location of Java option in the Android SDK settings. Is that because I have installed it incorrectly or is there something else I have to do?

avatar image Unrealistic Engineer Oct 28 '15 at 06:02 PM

It says in the code that "Template target file up to date so not writing." Does this mean that Java is not up to date?

Thanks!

avatar image Samantha Sutton ♦♦ STAFF Oct 28 '15 at 08:38 PM

Yes, make sure that you have BOTH Java 6 and 7 installed on your Mac. You might need to restart after it's installed.

avatar image Unrealistic Engineer Oct 29 '15 at 05:51 PM

OK, thanks! But I'm still wondering 1 question: Should that Location of Java option appear there automatically in the Android SDK settings when I have installed both Java 6 and 7 or do I have to set it up somehow in the Unreal Engine settings? My intuition tells me that it has to be set up but am I wrong about that? Should it be there automatically?

avatar image Samantha Sutton ♦♦ STAFF Oct 29 '15 at 09:18 PM

Which version of the Mac OSX are you on?

Setting up a Mac Environment (OS X Yosemite) - Install Java 6 (required) (http://support.apple.com/kb/DL1572) and Java 7 (or higher)(https://www.java.com/en/download/manual_java7.jsp) versions - Navigate to Engine/Extras/Android - Run the AndroidWorks-1R1-osx.dmg file

There's no need for device drivers on Mac

Setting up a Mac Environment (OS X El Capitan) - Install Java OS X 2015-001 (https://support.apple.com/kb/DL1572?locale=en_US) - Double click the downloaded file to unzip - Double click the package icon - Proceed with installation

Android Quick Start

avatar image Unrealistic Engineer Nov 02 '15 at 02:53 AM

I'm on OS X Maverick.

Yes, I installed again Java 6 and this time Java 8 since 7 is no longer available and I ran the AndroidWorks-1R1-osx.dmg in that folder but I still didn't get the option in the Android SDK Settings. Could it be that I have installed AndroidWorks incorrectly?

avatar image Samantha Sutton ♦♦ STAFF Nov 04 '15 at 03:41 PM

I doublechecked with our Mac Developer, Mavericks should not have any trouble getting Android set up.

As long as you have the Java for OSX and the Android SDK (which you'd install using the TADP installer in Engine/Extras/Android) it should work fine.

Keep in mind that once all of this is installed, you'll need to restart the editor. Make sure that the paths are set in the SDK Android section of Project Settings.

avatar image Unrealistic Engineer Nov 08 '15 at 04:49 PM

Well, I installed them quite a few times over and over again and I still don't get it. But my friend told me that he actually managed to package this same project in his computer without any trouble so I think I could study a little bit what kind of settings he has in place. He also found Location of Java option in the Android SDK settings.

avatar image Samantha Sutton ♦♦ STAFF Nov 09 '15 at 03:05 PM

Have you tried 'Verifying' your version of the Engine yet? Have you tried 4.9.2 or 4.10 Preview yet? If not, would you mind installing that on your Mac and seeing if those options appear or not?

avatar image Unrealistic Engineer Nov 10 '15 at 05:13 PM

I tried that and the option didn't appear but no problem, I may have found the solution: "For Gear VR development you need to run the Source version of UE4 from Github, its not that difficult to set up and get going." That's what I found from one thread and the same answer from YouTube. They also said that they got the automation tool error too when they didn't have the source version.

avatar image Samantha Sutton ♦♦ STAFF Nov 10 '15 at 07:15 PM

So I found a YouTube video that may help you with the issue you're running in to. Here is also our documentation that is on the Gear VR development.

I also wanted to point out that I spoke with our Mac Developer and Java is always installed in the same location therefore, you don't need to have that option within Android SDK.

Could you provide me with your newest logs if you're still encountering an issue?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Unrealistic Engineer,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

more ▼

answered Nov 17 '15 at 05:39 PM

avatar image Unrealistic Engineer Jan 26 '16 at 08:11 PM

Hi! Sorry it once again took so long to return to this issue but I really believed that it would be quickly done once I began building it. So I downloaded the Unreal Engine GitHub source files and began trying to build the Engine from source for Mac with XCode but I just get this error every time. Here is the log file: link text

Any idea what have I done wrong?

avatar image Samantha Sutton ♦♦ STAFF Feb 01 '16 at 06:57 PM

I'm going to run through the steps for setting up source UE4 with XCode, I'd like to make sure that no steps were missed:

Generate Project Files - Run GenerateProjectFiles.command to generate the .xcworkspace file

Launch XCode

  • Open the .xcworkspace file in Xcode

  • Double click from Finder Window

  • Open Xcode > File > Open > Select ProjectName.xcworkspace file

Build ShaderCompileWorker

  • Change the Scheme to ShaderCompileWorker - Mac > My Mac 64bit

  • Select Edit Scheme

  • Configuration is set to Development

  • Hit Cmd+K to Clean

  • Hit Cmd+B to Build

Build ProjectName

  • Change the Scheme to ProjectName - Mac > My Mac 64bit

  • Configuration is set to Development

  • Hit Cmd+K to Clean

  • Hit Cmd+B to Build

If you've gone through the steps with your source build and you're still running into this issue after checking this, please review these AnswerHub posts and respond with additional updates:

I also wanted to let you know that their is a bug in our system that showed up when searching for the error you're having. (UE-23624) was entered as when using the Clean command in XCode it'll prevent the editor from opening. I'm not quite sure if that's applicable for your issue yet.

Looking forward to hearing back, thanks!

avatar image Unrealistic Engineer Feb 02 '16 at 02:31 AM

Hi! Thanks for getting back once again!

Yes, I managed to generate the project files and open the .xcworkspacefile but got stuck already in the ShaderCompilerWorker section. Cleaning succeeded but Build failed and it gave this same error just like it did last time: "Non-type template argument specializes a template parameter with dependent type 'T'". Do you have any idea what that means? I tried to google it but couldn’t find anything that shed any light on it or how it relates to this problem.

Thanks!

avatar image Samantha Sutton ♦♦ STAFF Feb 04 '16 at 07:50 PM

Thanks for providing me with this additional information. We're looking into this further for you! :)

avatar image ZeroEightSix STAFF Feb 04 '16 at 07:56 PM

The old Clang compiler you have does not understand this code. From what I see the releases branch in GitHub is our 4.11 preview and for 4.11 we had to update the min requirements to OS X 10.10.2 and Xcode 7.2.

You could try grabbing 4.10 sources from GitHub, this should compile with Xcode 5, I believe, but even for 4.10 I'd advice updating Xcode to 6.2 (last version available for Mavericks).

avatar image Unrealistic Engineer Feb 08 '16 at 09:15 PM

Hi ZeroEightSix!

I downloaded 4.10 sources from GitHub and compiled it with XCode 6.2 but the build failed again and it gave this error this time:

Setting up Mono Building UBT... 0 Error(s) Building UE4EditorServices... 2016-02-08 08:21:24.283 defaults[2907:507] The domain/default pair of (/Users/mikkolindstrom/Library/Preferences/com.apple.dt.Xcode, IDEBuildOperationMaxNumberOfConcurrentCompileTasks) does not exist Running command : Engine/Binaries/DotNET/UnrealBuildTool.exe UE4EditorServices Mac Development Performing 16 actions (2 in parallel) [1/16] Compile CorePrivatePCH.h [2/16] Compile Module.Projects.cpp clang: error: clang: no such file or directory: '2.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk'error: no such file or directory: '2.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk'

[3/16] Compile Module.DesktopPlatform.cpp [4/16] Compile Module.Json.cpp clangclang: : errorerror: no such file or directory: '2.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk': no such file or directory: '2.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk' [5/16] Compile Module.UE4EditorServices.cpp clang: error: no such file or directory: '2.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk' -------- End Detailed Actions Stats ----------------------------------------------------------- ERROR: UBT ERROR: Failed to produce item: /Users/mikkolindstrom/Downloads/UnrealEngine-4.10/Engine/Binaries/Mac/UE4EditorServices.app/Contents/MacOS/UE4EditorServices Total build time: 5.21 seconds Command /Users/mikkolindstrom/Downloads/UnrealEngine-4.10/Engine/Build/BatchFiles/Mac/Build.sh failed with exit code 5

Is there something wrong with my files?

Thanks!

avatar image Samantha Sutton ♦♦ STAFF Feb 10 '16 at 09:01 PM

Could you upload the full log as a .txt file? That would be greatly appreciated, thanks!

avatar image Unrealistic Engineer Feb 13 '16 at 11:34 PM

Here's the entire log: link text

It seems to have some problem with my files: "no such file or directory".

avatar image Samantha Sutton ♦♦ STAFF Feb 18 '16 at 06:29 PM

Please rebuild your ShaderCompileWorker, UnrealPak and UnrealLightmass. Let me know what happens once you've done this, thanks!

avatar image Unrealistic Engineer Feb 20 '16 at 09:19 PM

Every one of them failed, same error as usual. link textlink textlink text

Should I try some other version of XCode?

avatar image Samantha Sutton ♦♦ STAFF Feb 23 '16 at 10:04 PM

Could you verify that you're on the 4.10 released version of source? When you're working with Github, you do have the capability of obtaining a build that hasn't been checked by QA which could mean you'd run into errors like these.

If you have pulled down a release version of source UE4, I would suggest starting your build over from scratch. Your project will not have a problem with this, as it'll update to whichever version you pull down from Github.

Please make sure you're following the proper instructions when build the engine from source. You can review the steps, to make sure you haven't missed a step here.

avatar image Unrealistic Engineer Mar 06 '16 at 11:41 PM

Hey, sorry for the delay! I decided to try my luck with another computer and I actually managed to build the whole Engine from source on my friend’s Windows with Visual Studio and then I packaged the Samsung Gear VR project in the Engine and the build was finally SUCCESSFUL!

Yes, the name of the version I grabbed from GitHub is 4.10.4-release. It failed when I tried to build it with XCode but with Microsoft Visual Studio on my friend’s computer it worked! I think I will try a few more times to get it working on my Mac, otherwise I have to start using my friend’s computer for packaging :D.

How exactly do I start my build over from scratch? Sorry, but I really don’t know much about XCode. I tried to follow the steps but I can’t find “UE4Editor - Mac” from my Schemes, what I found was “UE4EditorServices - Mac”.

Thanks!:)

avatar image Samantha Sutton ♦♦ STAFF Mar 09 '16 at 03:32 PM

You might need to build your version of GitHub again, or delete it and obtain a newer version of the Unreal Engine 4 through GitHub. If any of the files did not download properly, or were not set up properly through XCode, you could run into complications.

If you do try a fresh start on your Mac again and run into complications, please upload the new logs. If you make any progress on your current build and have additional questions, update those logs as well.

Good luck!

GitHub Setup Documentation

avatar image Unrealistic Engineer Mar 16 '16 at 10:59 PM

Ok, there’s one question that I need to know before I continue the Unreal Engine Source Build project on my own computer.

It turns out that there was another problem waiting after a successful build: After I had put the Oculus signature file where it belongs in the assets folder I created the final build for my phone. When I had connected my phone to the computer and was about to install the project to my phone I ran the Install_SamsungGearVR_Development-armv7-es2.bat file and this is what happened:alt text

“Check that the device has an SD card.” Is the SD card necessary to have in the device? As far as I know Samsung Galaxy S6 doesn’t have an SD card slot: http://www.samsung.com/us/support/answer/ANS00038750/846889744/. There seems to be one convenient way to get an SD card for S6: https://www.youtube.com/watch?v=_ftRlC-FijY but I have to know is it necessary. Or is the problem something else? It says that the APK file is invalid. I had to change “SamsungGearVR-armv7-es2.apk” into a zip file in order to check whether or not the Oculus signature file was found there as was explained in the tutorial. I thought it might help to change the file extension back to apk but it didn’t help. Any idea what the problem might be?

Thanks!

avatar image Samantha Sutton ♦♦ STAFF Mar 17 '16 at 07:41 PM

The S6 does not have expandable memory, so you're correct on that note. This message typically means you need to clean out your phone. If you've deployed to your phone a lot, it can eat up the space.

When you open your phones folder on your computer, do you see a lot of UE4 project folders? For example: Computer\SAMSUNG-SM-G935A\Phone\obb

Once you look within the obb, you may see a lot of files for games that you deleted a while back. Go ahead and purge those files too.

Let me know what happens once you've done that, thanks! :)

avatar image Unrealistic Engineer Mar 25 '16 at 05:21 PM

I looked into the folder and all the files that I found there are from games that I haven’t deleted from my phone and there’s only a few of those files. I think the problem is something else and I think I know what it is, it’s because this computer doesn’t have Tegra Android Development Pack installed in it! (It’s my friend’s computer) That’s what came to my mind when I read this line “C:\Users\ \Documents>C:\NVPACK\android-sdk-windows\platform-tools\adb.exe install SamsungGearVR-armv7-es2.apk Invalid APK file: SamsungGearVR-armv7-es2.apk”.

Well, I tried to install it but here we go again, :D another error:alt text

Is this error familiar and am I correct in assuming that installing the Tegra Android Development Pack might be the solution?

avatar image Samantha Sutton ♦♦ STAFF Mar 31 '16 at 09:01 PM

I have not seen that specific error previously however, I do have documentation I can provide you. Please look through the Android SDK information to ensure you've set this up correctly.

Once it's set up correctly, please let me know whether or not the error disappears.

avatar image Unrealistic Engineer Apr 13 '16 at 01:34 AM

No problem, I did it and it finally works! I finally got inside my game! And yes, the problem was of course the missing Tegra Android Development Pack that wasn’t installed in the computer!

I found a simple solution from another forum where someone had the same trouble installing that “Nsight Tegra, Visual Studio Edition” component. Someone said there that it might not be necessary to install that component depending on what kind of project you’re working on. So I decided to try and I simply left it out in the component manager and installed everything else in the Development Pack successfully! After that I ran the "Install_SamsungGearVR_Development-armv7-es2.bat" file again and surprise! There were no errors whatsoever! The installation was quick and the app was finally there in my phone! And it works perfectly in Gear VR!

Thanks again for all the help! It took some time to get it working but fortunately it does now! I guess I had a little bit too many things to focus on at the same time. I could still try to continue trying to build the source version of Unreal Engine for my own Mac but I think I’ll leave that project because I’m getting a Windows soon and then I can use the source version that I already built!

avatar image Samantha Sutton ♦♦ STAFF Apr 19 '16 at 09:20 PM

Yay! That is wonderful. Please let us know if you run into any other roadblocks along the way!

avatar image Unrealistic Engineer Jun 04 '16 at 11:44 PM

I did! As soon as I bought a new computer! :D

I tried to export my new project to Gear VR with the same source version of Unreal Engine that I had built with my friend’s computer and you never guess what happened! AUTOMATION TOOL ERROR! And this kind of error this time: “Missing UE4Game binary. You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline: UE4Game ”.

I actually forgot that it had to be a C++ project for it to work on Gear VR and that’s probably the reason why the build failed. But when I tried to create a C++ project I found out that it doesn't work and it now says that “No compiler was found. In order to use a C++ template, you must first install Visual Studio 2015.” I installed Visual Studio 2015 and launched it but it still says the same thing: “No compiler was found. In order to use a C++ template, you must first install Visual Studio 2015. ” Same problem with my friend’s computer. I opened the UE4 Source version in Visual Studio and then opened the editor and tried to create a C++ project but it doesn’t work that way either. Still no compiler was found. Do I have to do something in Visual Studio in order to create that C++ project?

Thanks!

avatar image Samantha Sutton ♦♦ STAFF Jun 08 '16 at 09:31 PM

Could you please upload your full error output logs to ensure I'm providing you with the correct information?

Please also review over this forum post and see whether or not the information provided helps resolve the issue.

Thanks!

avatar image Unrealistic Engineer Jun 13 '16 at 03:19 AM

Sorry, I always forget the full log post! :D Here it is: link text

It seems that the Visual Studio is installed in the wrong location and that’s why the editor can’t find it. They say in the forum post that you have to create some kind of “symlink” from the default path to where the installation is currently. I tried to do that in the command prompt but I only got syntax errors. Moving the folder to the correct location didn't help either.

I tried a little experiment and I found out that the original project that I used when I succeeded in creating a successful build on my friend’s computer is successful on this computer too. It manages to build the project successfully and the file for Visual Studio is ready in the folder. So I can’t create a new project but I can create copies of that original successful project and modify them. And they seem to work on Gear VR as long as I don’t change the name of the projects or that’s at least how it seems to be. I experimented with one of the projects a few times and when I changed the name of the project it didn’t open it in Gear VR but instead it just went straight to the main menu of the headset and nothing else happened. But as long as I don’t change the names, they work.

Would it be easier to just create copies out of the original successful project and build my projects on them because at least I know they will work. Are there any problems in that strategy aside from that project name issue? If there isn't any problems in that strategy, am I just wasting time trying to create a new C++ project? What do you think?

full log.txt (400.4 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I can't really tell you what to do, it's what you want to do. However, I personally always start with the quickest, easiest thing to do first. If that fails, then I completely redo what needs to be done (reinstalling VS in the correct location).

If VS is installed in the wrong area of your computer, I would simply uninstall and reinstall VS. But you can always do use the symlink from the default path to the installation where it currently is, as that's much faster.

You can try to copy your project first and see if it'll build that way, especially since it'll be easier to do than uninstalling and reinstalling VS.

more ▼

answered Jun 17 '16 at 09:10 PM

avatar image Unrealistic Engineer Jun 24 '16 at 09:16 PM

Alright, well, everything at least seems to work with the copy of the project. So I will return to this issue if I encounter any other problems and then I will try to reinstall Visual Studio.

Thanks!

avatar image Samantha Sutton ♦♦ STAFF Jun 28 '16 at 08:15 PM

You're welcome!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question