x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Gear VR builds go straight to Oculus Home 4.9

Hi guys! I can't get any UE4 4.9.2 build run on S6 Gear VR. Last time I checked, it was 4.7 and it worked, but was pretty ugly with no anti-aliasing whatsoever. I saw this video https://www.youtube.com/watch?v=TpvCLVJMpXw and decided to give it a go once more :)

I think I followed all the manuals and tutorials :/

  1. I'm making an empty C++ project

  2. Un-checking Oculus Rift Plugin

  3. Setting proper Android and Android SDK
    • click the 'Configure Now' button for Android support

    • Set the Minimum SDK version to 19

    • Check the 'Configure the AndroidManifest for deployment to GearVR'

  4. Copy OSIG file to Engine/Build/Android/Java/assets/

  5. Build

  6. Package'File/Package Project/Android/Android (ETC2)'

And after running the app and connecting Gear VR the app goes straight to Oculus Home :/

Has something in the process changed or am I still missing something?

Product Version: UE 4.9
Tags:
more ▼

asked Oct 06 '15 at 11:51 AM in VR

avatar image

Turbo Papok
17 1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi John,

Using one of my recent test Gear VR projects using the FirstPerson template I'm not seeing this on my end.

I've got a Galaxy Note 4 that I've tested on. You're settings above seem to be correct.

Can you try launching to the device without packaging and see if that works for you.

You can do this by having your Samsung plugged and in the main toolbar selecting the drop down arrow next to the Launch button. You can then select the Samsung device that is hooked up. It will take a few minutes to launch directly on the device, but see if this method works. If so, maybe we can work from there to see why it's not packaging correctly and loading like I'm seeing on my current device. We do have a S6 that I can test on as well, but I want to verify this part before checking it out from our inventory.

Thanks!

Tim

more ▼

answered Oct 06 '15 at 02:28 PM

avatar image

Tim Hobson ♦♦ STAFF
48.7k 888 103 880

avatar image eyc Oct 12 '15 at 09:51 PM

I'm having the exact same problem. Tried launching straight to the device. Also crashes. I'll update my UDN ticket.

avatar image matt.romein Oct 21 '15 at 06:01 AM

Also experiencing this issue with UE4 4.9.2 build run on S6 Gear VR, both with launching straight to the device and Build/Package on Android (ETC2). Opening app and launching just takes me straight to Oculus Home.

Edit: I can confirm same issue with both build and straight launch for UE4 4.7.6 and 4.8.3

avatar image Turbo Papok Oct 21 '15 at 01:55 PM

Hi Tim, I tried your way and it was exactly the same - a brief moment of black screen an then directly to Oculus Home app.

avatar image eyc Oct 22 '15 at 09:19 PM

I think I've narrowed it down to the FMOD plugin I was using. But no one has been able to reproduce the crashing. What OS and SDK version is everyone using?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I actually got it working with the Galaxy 6S Android 5.1.1 on UE 4.9.2 C++ thanks to this thread :

https://answers.unrealengine.com/questions/294430/packaging-for-android-fail-on-49-was-working-on-48.html

I also set my build configuration to debug mode for what it's worth.

more ▼

answered Oct 23 '15 at 03:53 AM

avatar image

matt.romein
0 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question