x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UMG scale DPI bug on older devices

Properly GUI on Nexus 4: alt text

Bug on Samsung Galaxy Note 2: alt text

Bug on Samsung Galaxy S3: alt text

Product Version: UE 4.9
Tags:
nexus4.png (1.1 MB)
note2.png (1.1 MB)
s3.jpg (74.6 kB)
more ▼

asked Oct 06 '15 at 04:57 PM in Bug Reports

avatar image

kodmistrz
334 56 83 103

avatar image Rudy Q ♦♦ STAFF Oct 06 '15 at 06:07 PM

Hello kodmistrz,

This issue sounds similar to a known issue and I have a few questions that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps or the project in order to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints that may be involved with this issue (this would also include the designer tab for the widgets)?

  4. Could you try placing your complete widget inside of scale box and having it's anchor set the full screen (This may be a possible workaround)?

  5. Could you provide the exact version of the OS that is being run on the devices?

avatar image kodmistrz Oct 06 '15 at 07:50 PM
  1. It's also problem in Tappy Chicken example project so you can look at this.

  2. Tested on Android 4.4 KitKat (Galaxy Note 2).

  3. Unfortunately trick with Scale Box didn't help :(

  4. It's a problem with r.MobileContentScaleFactor in DefaultDeviceProfiles.ini If I set it to 1 for all profiles it's working good but if I change this to 0.5 it's the problem described earlier. Galaxy Note 2 is [Android_Mid DeviceProfile] so it has default r.MobileContentScaleFactor=0.5 :( Moreover game runs slower with 0.5 than 1 and has lower resolution (?!?!) Lower resolution should run faster than higher resolution...

This issue didn't happen in 4.8 because 4.8 didn't have default set MobileContentScaleFactor in Android_Mid DeviceProfile. It's new issue in 4.9.

avatar image kodmistrz Oct 06 '15 at 08:21 PM

Tappy Chicken on Note 2: alt text

Tappy Chicken on Nexus 4: alt text

avatar image Rudy Q ♦♦ STAFF Oct 06 '15 at 08:50 PM

After looking over your last post I didn't see any clipping issues in the screen shots provided. I also ran a test with tappy chicken on our end and was unable to reproduce the clipping that was shown in the original screen shot provided in the opening post.

Are there any small steps I may have missed when launching tappy chicken to the device that you may have preformed.

Steps taken:

  1. Downloaded the 4.9.2 version of tappy chicken

  2. Opened project

  3. Launched to device

avatar image kodmistrz Oct 06 '15 at 09:04 PM

On the attached screenshots you can see that on Note 2 left and right side are cropped. On Nexus 4 is more open space. You can also test my game which is currently published on Google Play here: https://play.google.com/store/apps/details?id=com.gamednastudio.ChasingRobbers Currently this issue is reported by users of Note 2, Galaxy S3, LG P880 and HTC One X.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

After doing a bit more digging I was able to find a similar issue (UE-21815) that is affecting older iOS devices. I ran a couple of tests on the devices that were mentioned using the report as a guide and was able to reproduce the issue that you are having. I believe that this may be the same issue that you are currently experiencing.

Make it a great day

more ▼

answered Oct 07 '15 at 04:47 PM

avatar image

Rudy Q ♦♦ STAFF
47.2k 545 132 525

avatar image sarkawt909 Nov 09 '15 at 04:45 PM

so how we solve this issue ?

avatar image sarkawt909 Nov 09 '15 at 04:55 PM

i test your game on my One plus one 5.1.1 you still have some issues i think you have check enable full-screen on kitkat and above,, so none of your button are below "on screen buttons"

alt text

you see one red button at bottom barely visible

alt text

please let me know if you solved this problem , as i am facing the same thing here

avatar image Rudy Q ♦♦ STAFF Nov 10 '15 at 02:39 PM

Hello sarkawt909,

I went ahead and double checked on this issue for you. This issue has been closed as invalid. You will need to adjust your DPI scaling for your projects to better suit your needs on other devices. The DPI curve can be found in the project settings > User Interface > DPI Scaling. You can also follow the link below to the original post to find the example that was given by the developer for more information.

Link: https://answers.unrealengine.com/questions/310473/bug-dpi-scaling-on-iphone-4s-seems-to-be-incorrect.html

Make it a great day

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question