x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnyKey or InputAction not printing string

alt text

Hello I have simple but annoying problem... It's probably something that i just didn't see but here is my problem

I want to print string when I press Any key or on Input action test when i press space bar to print string as shown above in picture

I put in Project Settings --> input --> Action Mapping and created Space Bar for test

Problem i'm having is no mather what I press nothing hapens while On Play Event Begin Play Plays it and it prints string "1"

This is level blueprint and I'm stuck (it's straight forward when key pressed print string ) and i would really love to pass this problem as soon as possible

Thanks in advance...

P.S. Also same thing happened while following Tutorial for making 2DSideScroller on UnrealLearn while when I just import completed it works with no problem

Product Version: UE 4.9
Tags:
01.png (50.7 kB)
more ▼

asked Oct 07 '15 at 08:15 AM in Blueprint Scripting

avatar image

FreeDooomLC
1 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello FreeDooomLC,

Try creating your setup in a different blueprint, such as an actor blueprint. If it is not in the level blueprint, you'll need to set the blueprint to auto receive player input. To do this, go to the Details panel of your blueprint, and set Auto Receive Input to your player index using the drop down (default index is player 0). Give it a shot and let me know if it helps.

more ▼

answered Oct 07 '15 at 02:36 PM

avatar image

Sean L ♦♦ STAFF
43.6k 485 152 442

avatar image FreeDooomLC Oct 07 '15 at 02:42 PM

Already tried it out with that enabled I think you meant this one

Picture1

Block input disabled Auto receive input Player 0 Input Priority 0

02.png (44.5 kB)
avatar image Sean L ♦♦ STAFF Oct 07 '15 at 02:57 PM

Since you seem to have it set up properly, I'd like to take a look at your project, or if you'd prefer to recreate the same issue in a test project, so that I can look into the issue and see exactly what is causing it. You can upload your zipped project to Google Drive or Dropbox and send me a link and I will be glad to have a look to see what the problem is. Thank you.

avatar image FreeDooomLC Oct 07 '15 at 03:28 PM

Found the problem... Those noobiesh problems :)

essentially I was using Simulate and not Selected ViewPort to play... if you didnt recommend me to send you the problem i probably wouldn't notice the difference

Thanks Again... as they say 2 heads are better than one

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question