x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Importing models with textures from Blender

Hello forum!

I've recently just started working on 3D modeling, and I'm still quite new to both Blender and UE4.

I've made a basic chair, and inside Blender I've UV mapped it, and applied textures to it like this: alt text

But whenever I import this into UE4, I don't get the textures applied, and it looks like this:

alt text

I've looked for various tutorials and best practices online, but can't seem to find anything that works.

I'm hoping that some of you guys could help me out?

EDIT

I do have the "Import Textures" and "Import Materials" checked in the UE4 import settings

Product Version: UE 4.9
Tags:
tmp.png (1.0 MB)
asd.png (285.2 kB)
more ▼

asked Oct 07 '15 at 08:45 AM in Using UE4

avatar image

Detilium
71 2 9 10

(comments are locked)
10|2000 characters needed characters left

4 answers: sort voted first

I would guess that it is one of two scenarios:

  1. You have textured your mesh but it doesn't have a material assigned in blender. You can view a textured model if you are in the texture display mode even without a material assigned. Does UE4 create a material for you in the content browser? If not then this is your issue. Use the FBX exporter in blender if you aren't already.

  2. Potentially an issue with filepaths. I haven't encountered this though because I always keep my textures in the same directory as my .blend files.

Make sure that you have a material assigned in blender first and try to import/export again. If that doesn't work I would just manually import your textures into UE4 and create a material yourself. It doesn't take long and will save you the headache of troubleshooting the issue ;)

more ▼

answered Oct 07 '15 at 10:06 AM

avatar image

beasthacker
89 2 4 7

avatar image Detilium Oct 07 '15 at 10:12 AM

I do have a material applied in Blender, and it does crate a material in UE4. You talk about the FBX exporter? I'm not sure what this is, but I'm exporting the model from Blender as a .fbx file?

(comments are locked)
10|2000 characters needed characters left

alt text

lookey here in picture... so click on the red and white checkerd tab then click new and name it if you want. then selct image or movie next here is the tricky part. You can click the file and browse to your texture OR if you already have it like you do in your uv editor you can click the little file next to image or movie and itll show you all the images already loaded into your blend file and you can choose the texture map here and it will load. Then save your fbx again and reimport

capture.png (256.1 kB)
more ▼

answered Oct 07 '15 at 12:15 PM

avatar image

EyeDee10Tee
2.1k 59 14 126

(comments are locked)
10|2000 characters needed characters left

im gonna look into this for you right now

more ▼

answered Oct 07 '15 at 11:44 AM

avatar image

EyeDee10Tee
2.1k 59 14 126

avatar image Detilium Oct 07 '15 at 11:51 AM

Appreciate it. I could put my .blend, textures anf .fbx files in a dropbox link for you?

avatar image EyeDee10Tee Oct 07 '15 at 11:54 AM

Hello Detilium, I tried to recreate your issue. After importing the model and textures did you save them before trying to put the object in scene? When importing this way the material is not compiled until you do and wont show up

avatar image Detilium Oct 07 '15 at 11:59 AM

I just tried, but with no success. Bare in mind, I'm still not importing the textures on their own. I believe these information would be placed in the .fbx file?

avatar image EyeDee10Tee Oct 07 '15 at 11:59 AM

yes please do i can look at it now. Yes that information is stored in the fbx I generally dont import my textures this way as I use a variety of other programs to make the texture and load them all up into an actual shader. But I did apply a texture in blender and exported it to ue4 and the material showed up applied just like i had it in blender so i will for sure need to see what your setup is =)

avatar image beasthacker Oct 07 '15 at 12:02 PM

Textures will appear as a separate icon in the content browser. Double click your material to see if your texture is linked up in the material. If your textures don't appear then import the images manually for a quick fix.

avatar image Detilium Oct 07 '15 at 12:06 PM

As a separate icon? Then the textures aren't being imported. I haven't really worked with materials in UE4 yet, so how exactly would I apply the textures? Bare in mind, this chair has to textures: one for the seat, and one for the rest

avatar image beasthacker Oct 07 '15 at 12:16 PM

Problem is that you don't have a texture on your material in blender. I just checked out your file.

To get things working how you want you'll have to do the following in blender.

  1. Create another material for the seat cushion. Go into edit mode and assign the vertices for the cushion in the material panel in properties.

  2. Now you'll need to add the textures to your two materials. Click the checkered box icon right next to the materials icon in the properties panel in blender. Click new to add a texture and under the 'Image' section to select the texture for each material

avatar image Detilium Oct 07 '15 at 12:28 PM

I apologize for asking Blender option in the UE4 hub, but you say "assign the vertices for the cushion in the material panel"? Could you elaborate? I'm not sure how to achieve this.

I've tried selecting the faces for the cushion, then create new material, and hit the little button that says: "Assign" right above the material name, but that simply changes the entire chair's texture?

avatar image beasthacker Oct 07 '15 at 12:33 PM

That's the correct button. You'll need to be in edit mode and ensure the right material is selected when you assign. Select everything except the cushion, select your wood material and assign them there. Should work.

avatar image Detilium Oct 07 '15 at 12:34 PM

Emphasize on SHOULD :) - It just textures the entire chair

avatar image beasthacker Oct 07 '15 at 12:36 PM

link text

Here's how it should look for reference. Clicking the select/deselect buttons next to the assign button will show you which vertices are assigned to any given material

chair.zip (219.7 kB)
avatar image Detilium Oct 07 '15 at 12:40 PM

Alright, I see you got it working. I just don't understand why this isn't working for me. Whenever I press "assign" it (again) just assigns to every vertice

avatar image beasthacker Oct 07 '15 at 12:45 PM

Assign will assign the selected faces to the selected material.

So how I did it was select all (press A) first. Assign everything to wood material. Next I'll deselect everything. Then I'll select only the cushion faces. Select the cushion material and then assign. Note that you'll need two materials for this to work. If you only have one material I think that all faces are automatically assigned to it.

avatar image Detilium Oct 07 '15 at 12:53 PM

Yup got it.

I didn't press the little "+" in the right top corner of the materials window, instead I just pressed the "+" below the materials window.

How the should I know since I'm new to Blender. I'll try and import this, and see if this solved my problem

avatar image Detilium Oct 07 '15 at 01:02 PM

Now I just can't export at .fbx. It doesn't give me readable error, it just fails

avatar image beasthacker Oct 07 '15 at 01:05 PM

If the 'Selected Objects' checkbox is checked in the Export FBX panel on the left when exporting, it will only export what you have selected in object mode. So either select your chair first so it is outlined, or make sure that selected objects is not checked when exporting. I had this happen the other day when UE4 just failed to import with no error message.

avatar image Detilium Oct 07 '15 at 01:11 PM

It's the exporting from Blender that fails, not the import to UE4

Tried selecting a specific object, no change

Here's the erroralt text

tmp.png (109.5 kB)
avatar image beasthacker Oct 07 '15 at 01:17 PM

Hmm. Not sure about that one. Can you export from the file I sent you? I'm able to export it on my end.

avatar image Detilium Oct 07 '15 at 01:18 PM

Yes I can. No problem there what so ever

EDIT: If I remove my materials, I can export just fine.

avatar image beasthacker Oct 07 '15 at 01:25 PM

Also be sure that the first material is selected in the material panel when exporting. That will ensure that all your textures will be properly imported. It's dumb but that's how the fbx exporter likes it.

The export from blender can be a pain sometimes...

avatar image Detilium Oct 07 '15 at 01:27 PM

So just press the first material (the wood one?)?

avatar image beasthacker Oct 07 '15 at 01:31 PM

Yup. So it is highlighted.

I just tried it and with the cushion material selected it didn't import the wood texture for some strange reason :/

Keep in mind that the FBX exporter is an open source port of a proprietary format so it has some oddities and isn't perfect by any means. Figuring those out is the price to pay for free software.

avatar image Detilium Oct 07 '15 at 01:32 PM

Didn't change anything. Still can't export.

This is so strange :) I guess this issue is another thread, but thanks for the help regarding the textures. Really appreciate you spending so much time helping me solve this.

avatar image beasthacker Oct 07 '15 at 02:09 PM

No problem.

If you get really stuck I might just try starting from "scratch" now that you know how to set things up. Start a new project and go to File->Append. Select your previous blender file and go to the objects folder. The "Cube" is your chair and you can bring that into the fresh project. That might help out if you somehow messed something up that is preventing export.

Have a nice day and good luck.

avatar image Detilium Oct 07 '15 at 02:42 PM

It just brings the materials with it, and still can't export. Is there a way to append without the materials?

(comments are locked)
10|2000 characters needed characters left

think i found your problem and yes beast hacker is right you dont have the texture assigned in texture tab

more ▼

answered Oct 07 '15 at 12:09 PM

avatar image

EyeDee10Tee
2.1k 59 14 126

avatar image Detilium Oct 07 '15 at 12:12 PM

I think this is a Blender issue. When I look at the chair in Blender with "material" mode, the chair is simply white, but if I look in "texture" mode, the chair is textured.

avatar image EyeDee10Tee Oct 07 '15 at 12:16 PM

its not a bug you need a light in scene of blender for materials to show up in material mode

avatar image EyeDee10Tee Oct 07 '15 at 12:20 PM

nevermind your right. before you needed to assign a material to assign a texutre but now they have it seperated. strange

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question