Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lighting Won't Build UT Map Editor -ARGH!

Okay, so at the request of a staff member, I am posting this question, even though 800 people have asked. I am on Mac OSX 10.10.5 and Unreal Editor Version: 4.8.0-2710036+++depot+UE4-UT-Releases

My lighting won't build in the map editor. It will in the Unreal Engine Editor but NOT the UT MAP EDITOR!

See screenshot.

I have tried new maps from scratch, with one light or two lights. I have even tried with NO LIGHTS and get the error shown in the screen shot. EVEN the sample map that loads at eh beginning won't build the lighting, so it can't be something I am doing wrong with the lights.

error screenshot


I have spent hours trying to find a solution to this problem and it seems like no one knows what is going on!


Product Version: UE 4.8
more ▼

asked Oct 09 '15 at 05:06 PM in Bug Reports

avatar image

1 3 2

avatar image Adam Davis STAFF Oct 09 '15 at 05:34 PM

Hi sincitycyclops,

Unfortunately I haven't been able to reproduce this on my end.

  • What are the exact steps you are taking and do you receive any error message or warning when attempting to build lighting?

  • Have you tried building lighting inside a new, blank map with no content and a single light?

  • Is the build starting at all or does it simply refuse to build?

  • Do you have a firewall and if so have you made sure that both swarm agent and the editor have proper permissions?

avatar image sincitycyclops Oct 09 '15 at 10:05 PM

The exact steps I am taking is, I start a new blank map, I add a couple pieces of BSP (or even one piece) and add one or more lights, click BUILD and the above (see screenshot in original question) happens.
The build takes place. BSP build and NAV build works but lighting just stays at 0% and at the end says, Lighting Build Failed (See screenshot in original question). Again, the lighting builds in UNREAL ENGINE but NOT in UT MAP EDITOR. I have added swarm agent and editor to firewall and that's why it works with UNREAL ENGINE but I do not know why it doesn't work with UT MAP EDITOR.

avatar image sincitycyclops Oct 10 '15 at 05:18 PM

I made a 3 minute video to show what's happening... https://www.youtube.com/watch?v=dfLTSxQoXgA&feature=youtu.be

avatar image knepleyp Oct 14 '15 at 05:39 PM

I will look, probably missing an up to date unreallightmass binary or some such. Not a mac expert so need a bit of research time here.

avatar image knepleyp Oct 14 '15 at 09:39 PM

Just as sincitycyclops describes, it just fails with no usable logs. Filed an engine bug UE-22140. Out of ideas on what to debug, waiting on engine support.

https://unrealtournament.atlassian.net/browse/UT-1931 is the public facing UT bug.

avatar image knepleyp Oct 14 '15 at 10:20 PM

Actually got somewhat closer, has to do with some engine code I wrote I believe, hopefully can get this sorted by the next build.

avatar image fherzzz Feb 07 '17 at 07:21 PM

2 years later, I'm getting this same issue, lighting does not build. Working on a iMac 27'' 3,4 GHz Intel Core i7 16 GB video

avatar image Sean L ♦♦ STAFF Feb 08 '17 at 04:42 PM

Hey fherzzz,

Please create a new thread in the bug reports section for this issue due to the age of this thread so that we can investigate it separately.


(comments are locked)
10|2000 characters needed characters left
Viewable by all users

5 answers: sort voted first

Hi Sean, Im glad to notice you that I solved the problem by going to the Firewall settings and allow connections to the ue4 editor. Thanks for your help

more ▼

answered Feb 09 '17 at 05:46 PM

avatar image

21 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

no one can help me with this? I have a lot of content I want to make but don't want to waste time if I can't finish it!!!!

more ▼

answered Oct 12 '15 at 05:02 PM

avatar image

1 3 2

avatar image Adam Davis STAFF Oct 12 '15 at 06:09 PM

Hi sincitycyclops,

Unfortunately we do not usually have staff available for assistance on weekends, hence why no one has posted in several days. In general, we ask that you give us up to four days to respond before bumping threads so that we have time to address and attempt to reproduce your errors.

Having said that, how long are you waiting before closing down the editor?

Do you have a partition on your Mac, if so, have you tried this on the Windows OS to see if you get the same errors?

Have you updated your drivers to the latest version?

Are you using a specific type of lighting?

Have you tried verifying your engine build? To do so, go to the Launcher>UT>Create and open the launch dropdown menu, then press verify. This will check your engine files to ensure that no files are damaged or missing and repair them if so.

avatar image sincitycyclops Oct 13 '15 at 12:08 AM

I have waited various times to shut down editor.

I don't have a partition for Windows and thought about doing that but I am on a custom mac and it's a MAJOR pain. Plus, I don't have windows disks.

What drivers would I need to update for this? My video card? Not sure how video card drivers would effect lighting not building in UT editor but with mac, it's not the same as updating drivers with windows. I have all the latest updates for my machine build.

I have tried all types of lighting and always the same result - build fails.

Build verify checks out.

If my only option is installing Windows, I can at some point but it's a MAJOR PAIN. I'd rather not have windows on my machine for a number of reasons. I am guessing a few other mac users would not want that either. Especially if they have a custom mac.

avatar image [Epic] Frost STAFF Oct 14 '15 at 02:29 PM

Hello sincitycyclops,

Could you please attach your log file the next time this occurs? It should be in /Users/*username*Library/Application Support/Epic/UnrealTournament/4.8/Saved/Logs


avatar image sincitycyclops Oct 15 '15 at 12:10 AM

That path doesn't exist for me. Maybe because I am on Yosemite? I even searched for folders called 'Logs' and it's not finding anything with Epic or UT logs...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi sincitycyclops,

We have been able to reproduce this error on our end and have entered a bug report, UE-22140, to be assessed by the development staff. It is limited to Mac OSX, currently.

more ▼

answered Oct 15 '15 at 12:58 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Fixed in UT latest, if you can wait for next release you'll be fixed. If not, we could possibly email you custom binaries.

The root cause was the UnrealLightmass program crashing when calling StaticDedicatedServerCheck(). UT-specific and Mac-specific issue. Recompiled with a fix and checked into perforce.

more ▼

answered Oct 15 '15 at 02:48 PM

avatar image

1 1

avatar image sincitycyclops Oct 15 '15 at 05:21 PM

I guess that depends on 2 things: 1 - how long until next release? And, 2 - if I build a map in current release, will it be able to be imported into next release? I have put a bit of work into a map but don't want to waste time if it won't work later.

Might be helpful to note, I downloaded the Engine version 4.8.3 and the lighting builds fine there but of course the UT Map editor is still the same version that doesn't work.

If you want to email me the custom binaries, if it's not tooooooo much of a pain, and explain what to do with them, that would be cool. :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The update has not fixed this for me. It does something slightly different but same outcome; lighting does not build. It now just hangs at 0% and won't go past zero!


more ▼

answered Oct 22 '15 at 03:58 AM

avatar image

1 3 2

avatar image [Epic] Frost STAFF Oct 22 '15 at 02:14 PM

Hi Sincitycyclops,

I've been working with one of the UT programmers on this issue and we were able to fix the crash that was occurring, but we are getting support from the engine team to resolve the new issue of it hanging on 0%. Unfortunately this could not be fixed in time for the new build but we are working on getting in a fix soon. I know this is very frustrating for everyone trying to make maps on mac so I'm pushing to make this a priority before the next build is released.

Thanks -Frost

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question