x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Missing "Project" Modules

Hey, I've recently started to work on a project and downloaded it from github. When I opened my Project.uproject I got the message alt text

When I rebuild it crashes and gives me the message alt text

I've downloaded the source as well from github but I can't seem to generate project files correctly!

I am on a Mac OX Yosemite. Could someone help me out?

Product Version: UE 4.9
Tags:
more ▼

asked Oct 09 '15 at 11:21 PM in Using UE4

avatar image

Mateus Polati
31 1 3 5

avatar image Shadowriver Oct 10 '15 at 03:02 AM

You need to provide some more information, do you get any specific error on project generation?

avatar image Mateus Polati Oct 10 '15 at 03:08 AM

Yes I did!! Here is the log:

Setting up Mono Generating data for project indexing... 0%Compiling with non-standard Xcode (xcode-select): /Library/Developer/CommandLineTools/ Triggered an exception while looking for SDK directory in Xcode.app System.IO.DirectoryNotFoundException: Directory '/Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs' not found. at System.IO.Directory.ValidateDirectoryListing (System.String path, System.String searchPattern, System.Boolean& stop) [0x00000] in :0 at System.IO.Directory.GetFileSystemEntries (System.String path, System.String searchPattern, FileAttributes mask, FileAttributes attrs) [0x00000] in :0 at System.IO.Directory.GetDirectories (System.String path, System.String searchPattern) [0x00000] in :0 at System.IO.Directory.GetDirectories (System.String path) [0x00000] in :0 at UnrealBuildTool.AppleToolChain.SelectSDK (System.String BaseSDKDir, System.String OSPrefix, System.String& PlatformSDKVersion, Boolean bVerbose) [0x00000] in :0 ERROR: Invalid SDK MacOSX.sdk, not found in /Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs

logout

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I had the same problem today. I discovered that within the Xcode preferences you need to set the command line tools location to be the current version of Xcode you are using.

You can do this by going to Xcode preferences -> Locations -> Click the drop down next to Command Line Tools and then your build should work (well mine did at least).

alt text

more ▼

answered Aug 18 '16 at 07:14 AM

avatar image

liamisbest
36 11 7

avatar image jeremycouillard Sep 08 '16 at 09:04 PM

hey this worked for me! thanks!

avatar image harp07 Apr 05 '17 at 08:09 PM

Worked for me too! Thanks for this, been searching for awhile.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
 Directory '/Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs' not found. 

Seems you missing something in development tools, you sure you got XCode installed properly?

more ▼

answered Oct 10 '15 at 03:11 AM

avatar image

Shadowriver
29.5k 902 147 1064

avatar image TScrypter Sep 23 '16 at 06:55 AM

On later versions of Xcode, the SDKs are located under /Applications/Xcode.app, not command line tools. You can get around this with the following command from terminal: ln -s /Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question