x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Opening a level from "Main Menu" widget doesn't work.

I have been following the tutorials on here for the 2D paper game (side-scroller/platformer) and I was going through creating and scripting (with Blueprints) a main menu to show at the beginning of the game where a "Play" button would lead to actually playing in the level. Only problem is that it won't open the level and will just sit on the main menu. Although some objects are shown with increasing number whenever the "play" button is pressed in the World Outliner (image).alt text

I am also showing my blueprint as it exists in my "main menu" widget blueprint. (Not sure what is causing the problem so I'm just uploading this bit as it seems relevant). Thanks. alt text

Product Version: UE 4.9
Tags:
more ▼

asked Oct 10 '15 at 01:33 AM in Blueprint Scripting

avatar image

Nomeltian
41 3 4 5

avatar image Rudy Q ♦♦ STAFF Oct 21 '15 at 06:39 PM

Hello Nomeltian,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any other blueprints that may be involved with this issue?

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hi, Thanks for getting back but I've solved the problem (it was my bad blueprints). However I don't know how to close or set this question as answered.

more ▼

answered Oct 21 '15 at 06:43 PM

avatar image

Nomeltian
41 3 4 5

avatar image ToaTom Feb 29 '16 at 03:08 PM

Hi, I'm having the same problem with mine, could you elaborate on what you needed to change to make this work? Thanks

avatar image pGStoner Nov 11 '17 at 07:16 AM

I have the same problem. could you tell/show use how its done?

(comments are locked)
10|2000 characters needed characters left

hello i also do have a issue with opening levels but mine is because engine 4.9 is broken but it may be fine for you. delete the remove from parent node there is no need for it. then connect up open level and set but beware after you done that package your project and try it because there is an issue with 4.9 that packaged projects dont open up levels

more ▼

answered Oct 19 '15 at 12:45 PM

avatar image

twenty one
65 5 8 15

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question