x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Subtractive Brush Not Working

I am trying to make a window using a BSP box brush set to subtractive. I am placing it on another BSP box brush and it will not subtract.

The only way for it to work would be if I add a completely new BSP box first, and then add a completely new subtractive one. But even then, it only subtracts the new BSP box and not all the ones I have already placed prior.

Anyone know what's wrong or what I am doing wrong?

alt text

Product Version: UE 4.9
Tags:
img.png (1.5 MB)
more ▼

asked Oct 10 '15 at 06:48 AM in Using UE4

avatar image

Kuroodo Ditory
23 5 8 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I think the issue appears because of the order that these additive/subtractive shapes are created.

Additive then Subtractive works,

then create a new Additive, if you move the Subtractive shape to work with this new shape it fails.

My solution:

If you have a Subtrative shape that doesn't work just cut then paste it in the same place. This way is treated as a new entity.

more ▼

answered Aug 29 '17 at 02:58 PM

avatar image

dorusoftware
21 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello Kuroodo Ditory,

From your screenshot it looks like you have a subtractive brush inside of another subtractive brush. If this is what you are doing then it won't work. Think about if you took a glass a water and you emptied it. Then you tried to empty it again. There is no water left so there is nothing left inside the glass.

If this is not the case, you will have to build in order for the subtraction to actually take place. Also you need to have an additive brush in order for the subtraction to be taken away.

Logan

more ▼

answered Oct 13 '15 at 03:01 PM

avatar image Kuroodo Ditory Oct 13 '15 at 03:38 PM

In the image above, it is a subtractive brush inside of an additive brush.

By build do you mean build my project? Hmm, I didn't try that, but it makes sense.

Anyway, I ended up creating new brushes (with the same properties) and deleted the old ones. Then when I added subtractive brushes they worked.

I will try building next time if this happens again! Thanks!

avatar image pdcsky Jul 07 '17 at 07:17 AM

I recently had this problem as well and I can say something else to look out for is if you're working with merging different levels into one, make sure that the addition and subtractive brushes in question are made in the same level.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question