x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Is swarm agent disconnecting computer during build process??

Swarm agent seems to be diconnecting or running into some sort of error during the build process... The first comp does the build while the 2nd comp runs the coordinator... somewhere during the build process the 2nd comp doesnt seem to make it to processing mappings stage. Here is a screen shot followed by the attachedlink text text swarm log.

alt text

Product Version: UE 4.9
Tags:
swarm_issue.jpg (215.7 kB)
swarm_log.txt (28.8 kB)
more ▼

asked Oct 11 '15 at 02:29 PM in Rendering

avatar image

kurylo3d
382 21 42 60

avatar image Logan Bailey ♦♦ STAFF Oct 15 '15 at 02:06 PM

Hello Kurylo3D,

Whenever you allocate another computer, whatever task, that computer completes the task that you assign it. Then, it sends that information back to your base computer. Then all of the information on the base computer is compiled to give you a finished build.

I believe what you are seeing is intended behavior because your build reaches 100%. If you saw an error message or build does not complete then I would be inclined to think there was an issue somewhere.

Logan

avatar image kurylo3d Oct 15 '15 at 02:41 PM

According to the log there are error messages... and back when i used to use swarm agent the 2nd computer would also go through the "BLUE" (Proccessing mappings) bar... it seems like its not doign that at all.. like its losing that computer.. in fact that screenshot... is the end of the 2nd computer.. as in it does not proceed... that is start to end.. the first computer goes on for miles so to speak.. great distance.

In the log i get this happening roughly the same amount as i see no blue bars.. Its a lot of ...

"10:49:45 PM: [PushChannel] Pushing the channel ../DotNET/AutoReporter.exe has failed!"

" 10:49:45 PM: [PushChannel] Pushing the channel ../DotNET/AutoReporter.XmlSerializers.dll has failed! "

avatar image kurylo3d Oct 15 '15 at 02:47 PM

Anotehr thing when i swarm used to work properly the original computer that was running unreal was also the coordinator... now its reversed. I reversed it cause i have no idea why but the 2 comps couldnt see each other in swarm agent anymore... it was weird.. so after playing around with it i reversed it so the other is the swarm coordinator and the original still has unreal but no swarm coordinator... So yea... i have no idea why all these issues are happening right now... at this point as i said they see each other and start the build together, but no blue bar.. and lots of errors now.

avatar image Logan Bailey ♦♦ STAFF Oct 15 '15 at 02:57 PM

I'm not quite sure either. I'm investigating this further. It sounds as if the communication between the two computers and swarm is somehow being interrupted. I'll get back to you.

avatar image kurylo3d Oct 15 '15 at 03:38 PM

Thanks, little more info. 1 comp is windows 8.1, and the other is windows 7.

avatar image Logan Bailey ♦♦ STAFF Oct 16 '15 at 02:03 PM

After some research into known issues on this I believe the issue you are having is the compatibility between the different versions of windows. Do you happen to have another computer that has the either windows 8.1 or 7 on to test?

avatar image kurylo3d Oct 16 '15 at 05:48 PM

I mean no offense, but this thing was working for months on these very 2 computers with no problems at all. In fact it was working on 3 computers.. the third one however was pointless since its old as dirt and really wasnt helping. The third one had windows vista, the 2nd computer had windows 7 and the first which was the coordinator was running unreal and had windows 8.1. So it was working just fine for a long time.

Problem started around 4.9. To answer your question is hould be getting a 4th windows 8.1 alienware laptop maybe end of this month, but i need this working with all my computers again.. not going to chock it up to os... since it was working just fine with no issues.

I will say after the problem first appeared , as i said before i made the windows 7 machine the coordinator instead since thats the only way they would see each other in the agent. The windows 8 still uses unreal and launches the build. At that time when i switched it at first they didnt see each other either, but i messed with homegroups and stuff and then they saw each other, but obviously its still broken. So i do not know what to tell you.

avatar image Logan Bailey ♦♦ STAFF Oct 16 '15 at 06:00 PM

None taken. We are here for support and this is part of narrowing down what is causing issues. I did not realize that you had this working previously in another version of the engine.

I will continue to investigate this problem. If this project is one that is near completion I do recommend keeping it in 4.8. Reason being is major features such as AA have been changed in 4.9. I'm not saying this is related to your issue. However, with all new framework implemented in 4.9 there are bound to be issues that need to be addressed before proceeding with development.

I am going to pool more knowledge, and machines :), on this issue and see if I am able to reproduce what you are seeing.

avatar image kurylo3d Oct 16 '15 at 06:22 PM

Thanks. I honestly dont know exactly if it was 4.9 or one of the updates to 4.9... Not quite sure.. when i get the laptop ill continue testing if we dont find a solution. For now im just leaving it to build over night every night...

avatar image Logan Bailey ♦♦ STAFF Oct 19 '15 at 08:35 PM

We are currently in the process of pooling more resources and computers in order to test if we are able to reproduce this on our end. Thank you for your patience on this.

Logan

avatar image Logan Bailey ♦♦ STAFF Oct 23 '15 at 04:49 PM

I have been unable to track down what could be causing this issue. I have successfully synced and built to a few computers. Are there any updates with your builds?

avatar image kurylo3d Oct 23 '15 at 05:51 PM

Nope. I dont plan on trying to fix this until i get my new laptop to add to the mix. My only assumption is that before i was not using homegroups to connect my computers (as far as i knew) ... and now i sort of am with one created by my windows 8 machine. Though the only reason i did this was cause swarm couldnt see the other computer... and once i did the home group thing it could see the other computer, but the bakes obviously fail.

What was funny was that windows computers still both saw each other and could be navigated inbetween... but swarm didnt.

avatar image Logan Bailey ♦♦ STAFF Oct 23 '15 at 05:54 PM

Ok. What I will do is to mark this thread as answered for tracking purposes. As soon as you can test this please post again on this thread. I will then receive a notification when you do. At that time I will continue to work this issue with you at that time.

Logan

avatar image kurylo3d Nov 01 '15 at 02:16 PM

Alright i now have 3 computers testing and same probelm. Originally i thought my problem was that my computer running unreal was running an old version of swarm agent from 4.7... which is true. But now it is not.. every version is using swarm 4.9 with 4.9 being the building machine as well...The problem is still exists...I will try to go into as much detail as possible.

Computer "Revy": The computer running unreal. core i7 4 ghz with 16 gb ram. gtx 980. Is running windows 8.1. Its the computer that first created the homegroup. This is the computer running Unreal Editor and starting the build. Swarm agent for 4.9.

Computer "Motoko": The computer running swarm coordinator. It has core i7 2.7 ghz.. 6gb ram. nvidia gtx 780. Running windows 7. This computer is the one running the swarm coordinator. It also is using a swarm agent. Both Coordinator and agent are 4.9.

Computer "Rock": New laptop. Has core i7 2.5 ghz with 24gb ram and gtx 980m. Running windows 8.1. This computer is only running a swarm agent 4.9. All of its power settings are disabled so it never powers off since its constantly pluged in.. only thing that ever happens is screen powers off.

Network itself is set up with the "Revy" machine creating the homegroup and the other 2 connecting to the homegroup with the homegroup password. All computers see each other and are able to navigate each other in the network Via clicking on them in network window and clickign on homegroup. But heres a problem with this new laptop... First It cant navigate REVY without using the homegroup.. for instance i cant just go to network-> REVY.. i have to literally click on the homegroup user REVY. On top of that. Actually thats not entirely true.. I can navigate REVY via ROCK Network but only after REVY connects to ROCK via network... makes no sense.. after it does that it connects.

avatar image kurylo3d Nov 01 '15 at 02:21 PM

MOTOKO Doesnt see ITSELF on the homegroup at all... Rock and REVY SEE all three computers on the homegroup... MOTOKO sees both computers on the network and can navigate it via network -> ROCK .... So every computer has different issue connectivity/ networking wise to each other... despite having the following problems...

Now I will tell you they all connect to the coordinator fine eventually. Though the coordinator behaves stupid sometimes. For one i spent 30 minutes last night trying to get each computer seen in the coordinator, running, and available. You see i am assuming this is the cause since it happened 3x, but whenever my "Rock" laptop goes to screensaver mode.. the coordinator sees it as "Dead" unassigned... So basically i need to kick off the build process before the screensaver turns on or something ...Again even if its dead unassigned i could still navigate the network to each others computer on both computers no problem... Restarting agents did nothing it would just go back to dead unassigned.. and pinging the coordinator from "Rock" didnt help either.. In fact the pinging of the coordinator would fail according to "Rocks" log... like it wouldnt be able to connect.

avatar image kurylo3d Nov 01 '15 at 02:30 PM

But here was the other issue.. swarm coordinator itself was acting stupid... for example when i would restart all swarm agents via the coordinator... the swarm agent for MOTOKO would stay on restarting and never go to available or busy for that matter... all computers took longer then usual to restart agents, but this one in particular never came back... i had to restart the damn computer...

Anyway eventually after I had all 3 computers available and unassigned i was finally able to hit the build button. As you can see from the screenshots and the log... same problem. Here are both the logs for all computers and screenshots in order...As well as a screenshot of the coordinator.

Again just to reitterate.. i had it working with the original 2 and a different laptop during 4.7.. Once one of the 4.9 versions came out it stopped working.. and thats when i switched to using a homegroup for my network so the coordinator could see computers... Obviously still some issues...

avatar image kurylo3d Nov 01 '15 at 02:30 PM
motoko_log.txt (44.9 kB)
rock_log.txt (417.1 kB)
revy_log.txt (82.9 kB)
avatar image kurylo3d Nov 01 '15 at 02:32 PM

alt text

alt text

alt text

alt text

status1.jpg (82.3 kB)
status2.jpg (71.6 kB)
status3.jpg (60.4 kB)
status4.jpg (70.9 kB)
avatar image kurylo3d Nov 01 '15 at 02:34 PM

alt text

alt text

alt text

alt text

alt text

status5.jpg (64.3 kB)
status6.jpg (63.7 kB)
status7.jpg (54.6 kB)
status8.jpg (51.5 kB)
avatar image Eric Ketchum ♦♦ STAFF Nov 02 '15 at 04:57 PM

Hi kurylo3d -

So a few things to confirm that the network is up and running and you are not losing anything there:

Are the Computers in your Homegroup all running the following Services:

  • DNS Client

  • Function Discovery Provider Host

  • Function Discovery Resource Publication

  • Peer Networking Grouping

  • HomeGroup Provider

  • HomeGroup Listener

  • SSDP Discovery

  • UPnP Device Host

Are all of the Computers set to not sleep and not engage a screensaver? The screensaver is something that will eat processors to run and Coordinator always yields to activity on the Local Machines before allowing Swarm to work on those machines. You can still use the Power Management to turn off the monitor after a set number of minutes as long as it doesn't also put the computer to sleep or suspend mode.

Let me know -

Eric Ketchum

avatar image kurylo3d Nov 03 '15 at 02:38 AM

Hi Eric,

All of those seem to be running on both REVY and MOTOKO. Many were set to manual, but i decided to just switch them all to automatic.. probably wont change anything since they were running anyway. As for ROCK I do not remember if any were disabled or not, but i switched that computer to auto as well...

No screen savers or sleep modes are active on any machine.

I will kick off another build tonight or tomorrow and see the results. Though as i said.. i really didnt change anything .. otehr then set it to auto instead of manual. The stuff is already running...

Any other ideas?

avatar image kurylo3d Nov 04 '15 at 01:24 PM

Hey ERic,

Ok i tested this with my 2 desktop machines.. Revy and Motoko. No change. Still broken. Any idea whats wrong? :/

avatar image kurylo3d Nov 05 '15 at 02:21 PM

Is there anything specific i should do for windows 7 and windows 8 in terms of how the network is setup? Options to enable / disable in windows? Settings.. etc...? Anything specific really...

avatar image Eric Ketchum ♦♦ STAFF Nov 06 '15 at 04:12 PM

Not anything specific other than what I mentioned earlier. You could check to make sure that you are not blocking the ports (Specifically 8009) via your router or firewall programs. We are attempting to setup a test for this scenario and I will let you know as soon as we are able to get some results.

Eric Ketchum

avatar image kurylo3d Nov 07 '15 at 06:41 PM

my router only seems to allow you to open a port on 1 device at a time.. for instance it wont let me open 8009 on computer 2 if its already open for computer 1.

avatar image kurylo3d Nov 07 '15 at 07:10 PM

I also just realized that the Motoko Windows 7 Machine has windows firewall on... and the Rock laptop has mcafee with windows firewall.

I have since uninstalled mcafee and disabled the windows firewall on both of those machines. I will try another build test between the 3 computers tonight.

avatar image kurylo3d Nov 07 '15 at 10:53 PM

Ok after disabling all windows firewalls.. it worked for Rock laptop. That ones agent is now contributing correctly. Oddly enough though the windows 7 machine MOTOKO, which also happens to be the coordinator, still has the problem and is not working... wtf...

Its coordinating the other 2, but itself is messed up.

avatar image Eric Ketchum ♦♦ STAFF Nov 09 '15 at 07:17 PM

If you still have a copy of the 4.8 engine, try opening Coordinator up in 4.8 and running it with the 4.9 Agents and let me know if anything behavioural changes from your last test?

Thank Yuo

Eric Ketchum

avatar image kurylo3d Nov 09 '15 at 07:31 PM

I dont think i ever used 4.8. I went from 4.7 to 4.9. That being said i am currently doing 1 more test. I noticed the MOTOKO windows 7 machine also had a version of mcaffee installed for some reason. Though the firewall was still disabled in windows. I uninstalled it and kicked off one more build before I left. I will see if it worked in a couple of hours when i get back to the computers.

avatar image kurylo3d Nov 10 '15 at 10:54 AM

my bad.. i do i have 4.8... must have used it at one point for my project. I can give this a try later.

avatar image kurylo3d Nov 09 '15 at 10:18 PM

Ok.... so i tried uninstalling mcafffee off the motoko windows 7 machine and doing a bake with all 3 again to test... that did not work.. still broke. Heres whats worse. The ROCK windows 8 laptop.. made it to the blue bars once... then after that it kept stopping at the orange several times.. continuing hte problem.. so thats not really fixed eitehr... crap. Why would that be happening!? How does that even make sense?

ROCK no longer goes to dead.. its always available unassigned which was a plus of removing mcaffeee and the windows firewall.. but obviously still having problems with that comp too.

avatar image kurylo3d Nov 11 '15 at 06:35 PM

Hey Eric,

I tried using your suggestion with using the 4.8 coordinator instead with the 4.9 agents. The problem still exists.. This time The ROCK LAptop made it to blue bars a bunch of times.. but somtimes went to orange bars and restarted from what it appeared .... Its a weird thing to see. I will post logs and screenshots later.

Aside from the the Motoko windows 7 machine which is the coordinator still did not ever make it to the blue bars.... its still messed up as well... So yea... still issues...

avatar image kurylo3d Nov 12 '15 at 12:08 AM

Here are the logs from this latest test with the 4.8 coordinator and 4.9 agents.. and the above are teh screenshots of the weirdness.

link text

link text

link text

revy_log2.txt (48.9 kB)
motoko_log2.txt (8.7 kB)
rock_log2.txt (8.5 kB)
avatar image Eric Ketchum ♦♦ STAFF Nov 17 '15 at 07:10 PM

Hi kurylo3d -

Can you confirm that each of your CPUs have the latest DotNET framework installed? The easiest way to do this is to install /Engine/Extras/Redist/en-us/UE4PrereqSetup.exe. This file will ensure that the CPU has all the required prerequisites to correctly run. Also make sure you are running that file from the version of the engine you want to use.

Please let me know when you can if that was successful for you -

Eric Ketchum

avatar image kurylo3d Nov 17 '15 at 07:47 PM

Hi eric, I will give that a try when I get home, but I more then likely will not be able to test it. Reason for this is im now onto engine 4.10. Engine 4.10 with my computers at home eitehr crashes and closes the process on me of the unreal editor... or it just says build failed. Some warnings about hierarchy lods in there even though im not using those... So .. .yea... i now cant even do a build. Though my comp at work can do a build alone... so i have no idea what the heck is going on here... 4.9 i could at least start builds and test. I already uninstalled 4.9 from all my machines.

So yea I guess I will get back to you when that bug is resolved or answered... The hits just keep on comin...

avatar image Eric Ketchum ♦♦ STAFF Nov 17 '15 at 07:55 PM

If the engine is crashing are you getting a Crash Reporter Window or just a generic Windows Error and the editor closes? If the latter, can you look at this Windows Event Viewer Wiki and post the event logs from that crash as the wiki explains and I will try to help you out?

https://wiki.unrealengine.com/Windows_Event_Viewer

Eric Ketchum

avatar image kurylo3d Nov 17 '15 at 08:14 PM

When it crashes there is no message. Not from unreal crash reporter... not from windows... nothing.. its just poof where did unreal go... and i hit ctrl alt delete the unreal editor exe isnt even there.. which is very odd...

I recently switched the coordinator to this computer that is having the issue... when i went to 4.10 i switched the coordinator to the one that is runnign the edtior.. and this magic crash happens (I THINK) when the coordinator running.. otherwise if i try to do the build alone it just says build failed with no crash.

I will look through your link.

Oh and the build does not fail if i build on my computer at my job (which is a much worse computer) So it has to be something specific on that computer at home...

avatar image kurylo3d Nov 18 '15 at 12:04 PM

link text

Not sure if this was what your looking for with the crash reporter but i tried to follow instructions from your link. I selected multiple crashes.

events.rar (13.6 kB)
avatar image Eric Ketchum ♦♦ STAFF Nov 18 '15 at 04:20 PM

That was it exactly. I am going to dig through those event logs and will post back as soon as I have additional information.

Eric Ketchum

avatar image Eric Ketchum ♦♦ STAFF Nov 18 '15 at 04:47 PM

Initially it looks like there is some conflict between 32 bit and 64 bit software that is occurring. So to test, if you can go into your Engine Installation Directory (by default it is Program File\Epic Games) 4.10\Engine\Extras\Redist\en-us\ and run the UE4PrereqSetup_x86.exe file. This file will install 32bit VS2015 Redistributables which may solve the issue, let me know.

Eric Ketchum

avatar image kurylo3d Nov 18 '15 at 04:52 PM

Ill give that a try, but does that somehow mean i wont be able to take advantage of 64 bit ? I mean my comp hardware specs and os are way up to spec.

avatar image Eric Ketchum ♦♦ STAFF Nov 18 '15 at 04:55 PM

No your PC will still take advantage of 64 bit processing, but Swarm is built on 32 bit DotNET Framework, your computer will still run it, just some prereqs may not have been installed based on most of your CPU not needing the 32 bit - 64 bit communication.

avatar image kurylo3d Nov 18 '15 at 10:55 PM

Tried that.. still didnt work. Same problem. Though that being said.. it could be 2 problems were looking at that are different. 1 crashing if trying to network a build.. or 2 build failed if the comp is alone with no crash. So far alls im testing is build failed... since there is no point in coordinating if hte 1 comp fails.

Oh yea and i did notice something else interesting. If swarm agent is already running in the background started up on its own.. it says failed to connect to swarm instead of build failed.

I am attaching a screenshot of what .net framework versions are installed. I was reading at the following link something about installing another version... is this something that it looks like i should try?? alt text

netversions.jpg (40.1 kB)
avatar image Eric Ketchum ♦♦ STAFF Nov 20 '15 at 04:56 PM

Hello -

To Confirm what we have tried so far, You have ensured that your Engine Version is validated via the Launcher. If you are starting Swarm at Startup (not just starting it when you build lighting) that you are running the 4.10 version of the Agent. That you have cleaned and validated your Swarm Cache. You have installed all VS Redist Prereqs.

Now based on the issues you are describing here and in your other Swarm related HLOD question, it sounds like there is a conflict or setup issue with one of the VS Redsit or another program. To best get a handle on what might be going on I need to know exact what you have installed and what version it is.

Can you please open a Command Window as an Administrator on the PC that looks to successful build lighting but the Build Failed Message comes back and run the following two commands:

 WMIC [ENTER]
 /output:C:\SoftwareInventory.txt product get name,version,installlocation,installdate,vendor,description,installstate [ENTER]


This command will output a Software Inventory on the C:\ drive of all your installed software on the PC. Because of the nature of this file I would like you to send it to me via Private Message on the Forums. There is no really sensitive information generated by this command, but I like to err on the side of privacy.

Thank You

Eric Ketchum

avatar image kurylo3d Nov 20 '15 at 05:34 PM

Yes I have tried the validation in launcher via verify.

I have tried both ways. 1.) letting swarm launch itself when i click build .. and 2.) starting swarm on its own before i even start the editor.

Yes its 4.10. Triple checked that. I dont even have any other version installed anymore. But yes I have confirmed the directory and made a new shortcut for it.

Yes I have tried to clean and validate swarm cache inside swarm agent with its menu.

UE4PrereqSetup_x86.exe is the one u asked me to install so I have. Not sure if you want me to install anything else.

I am not home to try that command yet, but to verify did you want me to run it on the computer that fails the build? Or the work computer that at least starts running the build correctly? Or both?

avatar image Eric Ketchum ♦♦ STAFF Nov 20 '15 at 05:39 PM

You should also try to install UE4PrereqSetup_x64.exe found in the same place. If it pops up with a window just to uninstall then it has been installed already.

Thank you for confirming that I just want to make sure that I had covered some of the "Is it Plugged in" possibilities.

If you can run it on the Computer that fails to build first that is the one I want to focus on first.

Thank You Agian -

Eric Ketchum

avatar image kurylo3d Nov 20 '15 at 05:40 PM

Yea I tried the x64 as well on my own.. and it was already installed.

Thanks for the help. I will try that command when i get home in like 4 hours or so.

Did you see that .net frame work screen shot i sent u... i saw something on the forums of isntalling .net4.5 to fix something? Is that something i shoudl try...?

avatar image kurylo3d Nov 20 '15 at 10:52 PM

I do not know how to make that command work.. when i hit enter it says Invalid file name.

update Nevermind ... for some reason it wont create the file on drive C... in fact i need admin privelages just to paste a file into drive C which is odd.. Apparently windows 8 doesnt allow you to create any files on the root of your drive C...but i used another hard drive to generate the file instead. I have sent it to you in the unreal forums.

avatar image kurylo3d Nov 22 '15 at 03:13 AM

Hi Eric, I have been doing more tests on my end. As you know my "REVY" machine will not build... its a windows 8.1 comp with 4 ghz i7 and gtx 980..

My work computer which is a windows 7 3.5 ghz i7 and a gtx 590 was able to start a build but windwos complained about memory or something an hour into building and apparently shut down the edtior.. its a 12gb ram computer... but it failed.. who knows...

NOW.. i just tried my laptop which is a 2.5 ghz i7 with gtx 980m.... And it crashes unreal completely with my project... or with your simple test project it has the same problem as the "REVY" computer... The build failed error... This computer is also on windows 8.1...

I also just tried my windows 7 2.7ghz i7 with a gtx 780... That also went to lighting build failed...

Dude im really at a loss...i cant build any project on ANY COMPUTER it would seem. So far 4 computers have not been able to build... 3 of which i tried with your simple scene... How do bugs this monumental that are total show stoppers slip through your guys QA process???? This just hurts me ... i already dumped a lot of money into this project... and now were stuck....

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

alt textHoly crap. I think i finally found the answer to this problem. The trick is DO NOT USE WINDOWS HOMEGROUPS. This is aproblem in my eyes since windows homegroups are the only way my comps can access each other to transfer files, but once i remove every comp from windows home groups they seem to build together for lightmap generating.. all of them reach the blue bars multiple times. Something you guys at epic should definently look into.

working.jpg (259.2 kB)
more ▼

answered Dec 25 '15 at 01:24 PM

avatar image

kurylo3d
382 21 42 60

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Wow I finally solved the build failed problem, though the networking computers to build together problem still exists.. they all work together, but motoko doesnt reach the blue bars, and Rock seemed to reach the blue bars one time.... but then the rest no... its odd..

The build failed was fixed by disabling the "run as administrator" checkbox in windows on swarm agents exes... I had apparently set that to see if that would make the networking build work correctly.

more ▼

answered Nov 22 '15 at 11:34 AM

avatar image

kurylo3d
382 21 42 60

avatar image Eric Ketchum ♦♦ STAFF Nov 23 '15 at 02:42 PM

Hello -

I found this link on our Forums while doing some research on Swarm Agent and Coordinator and I think it explains why your three CPUS are not running constantly in Coordinator.

https://forums.unrealengine.com/showthread.php?91714-Why-does-light-building-not-use-the-swarm-regardless-of-the-power-needed&p=423658&viewfull=1#post423658

avatar image kurylo3d Nov 23 '15 at 03:07 PM

From that post it sounds like the guys otehr computers arent being used.. as though that are saying available but not being used for the build process... or maybe im misinterpreting..

In either case....Heres the thing... Revy is always the one who launches the build process regaurdless of which computer is the coordinator.. motoko or revy. Revy will always function correctly... The other like motoko will never reach blue bars ever... and Rock will maybe reach it once , but then continue ot other orange /grey bars... but wont reach blue again...

In the past this scene (which has only gotten more complicated) would take advantage of 3 computers.... All doing things in the proper order... Grey, Red, Orange, and finally blue... All machines would do this...

This is all odd behavior to me where the one doesnt even make it to blue at all...And this does not appear to be speeding up the build process from one computer doing it alone.. (though i have not verified that.) Is there a way to see how long a build process took?

And another thing.. as to that response... he says that each computer would finish processing its mappings and then see if there is more to do.. The blue bar is "processing mapping"... so it just never gets there. At least thats what it seems like unless im wrong. just seems like a waste to buy all these machines for this engine and then not be able to coordinate...

avatar image kurylo3d Nov 23 '15 at 06:53 PM

Oh and plus that doesnt explain all the "failed" error messages inside the log for swarm.

avatar image kurylo3d Dec 01 '15 at 12:03 PM

Hi ERic, cleary that link you sent me too has nothing to do with whats happening here.

I did another test with just 2 computers.. For one.. it took the same amount of render time exactly as the previous builds. For two... the motoko computer never reached the blue bars.. and only went to the other colored bars 1 time... see the screenshots.

Its been a long time since i originally asked the question and still no where near closer to finding an answer... Is there anyone else you can talk to on this? because you yourself may not have the knowledge necessary of this thing. No offense... but months are going by here without an answer....

alt text

alt text

alt text

2comptest01.jpg (79.8 kB)
2comptest02.jpg (69.5 kB)
2comptest03.jpg (67.7 kB)
avatar image kurylo3d Dec 08 '15 at 09:51 PM

Please dont accept answers that are not the answer to the original problem. I am still awaiting an answer to make all computers build together... and not just start together.

avatar image kurylo3d Dec 11 '15 at 09:31 PM

Do you guys ever plan on fixing this or does no one care?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello everyone, this weekend I was strugling with the same issue and maybe I have some new thoughts about it... I found one extreamly large mesh in my model, about 500.000 faces, and this was copied a dozen times in the project. After deleting this I got all the computers working fine (Im using four machines). So my sugestions is to look into your model to highly detailed objects, and lets try to validate this solution... Tks everyone for sharing your experiences in ue4, very helpfull.

more ▼

answered Jan 10 '16 at 08:06 PM

avatar image

Julio del Valle
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question