x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to reduce CPU load for the UE4 editor?

UE4 had a high CPU load (around 120%) on my Macbook Air 2012 running El Capitan with the latest actualisation when UE4 editor is open with the 2d platformer template. I had to reduce the Engine Scalability Settings to the minimum and lock the maximum frame rate to 15 FPS on the editor but the CPU load is still around 30%. Is there something else I can do to keep the CPU load to the minimum? Maybe some kind of rasterisation on editor UI.

Product Version: UE 4.9
Tags:
more ▼

asked Oct 11 '15 at 01:40 PM in Everything Else

avatar image

OOMMBB
50 4 9 12

avatar image addih Aug 28 '16 at 01:15 PM

Same Problem here. In another post one of the members of staff confirmed to address this issue ( https://answers.unrealengine.com/questions/7756/bug-high-cpu-usage-first-launch-and-later.html ). Although, you notice the answer is about two years old it still persists. In comparison, Unity 5 does not expose this behavior at all. I'm wondering why it hasn't been tackled sufficiently yet. Seems like everyone using UE4 runs at least an i7 capable of handling 8 threads which - if the amount of activate threads during idle remains at most 2 - may not seem to be an issue as it only loads up to 25% onto this kind of CPUs :P. Nonetheless, what is the engine doing in the background while idling? Maybe I should get a slightly bigger shoulder to carry this chunk... like... Intel Xeon E5 2667 v4 with 22c/44th...

Update: Ok, one way to reduce the CPU-load from 50% on my system to about 15% when being in Viewport mode is to set uncheck "realtime" (see figure) alt text

However, when idling around in the EventGraph/Blueprint the CPU-load is back on 50%.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question

Related Questions