x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to get an reference object from Scene Outliner into a Class Blueprint?

Ok so here is my problem.

I'm trying to follow this tutorial: https://www.youtube.com/watch?v=8ew12FLgaMs∈dex=15&list=PLZlv_N0_O1gaG5BW72It4chjhypxIO9ZB

He explains how to use the "G" key to spawn an object. It works fine because since he is using the default PlayerController, he can just use the Key Event to spawn the object on the Level Blueprint. If I'm using another controller, like for example the one in the Third Person Blueprint template, I can't use the key event in the Level Blueprint because the "MyController" from the template is apparently overwriting the controls. If I add the spawn blueprint to the "MyController" class blueprint, it doesn't let me use the TargetPoint from my Scene Outliner, if I drag it in, nothing happens, it only lets me drag it into the Level Blueprint.

Any ideas how I can make this tutorial work with the Third Person Blueprint template, or any other player controller class for that matter?

Thanks!

Product Version: Not Selected
Tags:
more ▼

asked Apr 18 '14 at 04:21 PM in Blueprint Scripting

avatar image

Kuhnen
16 1 3 6

avatar image PeterLNewton Apr 18 '14 at 08:52 PM

Hey Kuhnen,

Have you tried setting your controller in the Game Mode within World Settings? You should be able to use your controller just as he did in the Level Blueprint.

Peace

avatar image Kuhnen Apr 18 '14 at 09:08 PM

If I use the default PlayerController, it works but the character doesn't move, since his movement is set in MyController. If I use the "MyController" class the character moves but the inputs I have inside the Level Blueprint don't work.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Kuhnen,

If you are having trouble with Key events working in a Level blueprint and you are using one of the Templates, check both the PlayerController and Character blueprints in use for the template. For both of those blueprints, if present, open them up and go to the Defaults tab. Search for the Block Input option and make sure it is unchecked (this will stop blueprints lower in the input chain, like the Level blueprint, from receiving input if it is checked). As far as being able to directly reference placed Actors like the TargetPoint from the tutorial, those references can only be made in the Level blueprint.

Check the setting I've mentioned here and if you are still having trouble following the tutorial, let us know.

-Steve

more ▼

answered Apr 18 '14 at 09:59 PM

avatar image

Steve Allison STAFF
4.2k 123 58 208

avatar image Kuhnen Apr 18 '14 at 10:25 PM

Worked like a charm. Thanks a lot! :)

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question