x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Editor keeps freezing when making new Blueprint class

I made a blueprint class to a game object no problem. When I try to do it for the 2nd time my editor freezes and the window to create a new class looks like the image below: alt text

Is this a bug?

My specs: Computer: Macbook pro retina 13" Processor: 2.7GHz Intel core i5 Memory: 8GB processor Graphics: Intel Iris Graphics 6100 1536 MB

Any help is appreciated. Thanks!

Ben

Product Version: UE 4.9
Tags:
more ▼

asked Oct 14 '15 at 02:45 AM in Bug Reports

avatar image

hairspray011
8 6 5 7

avatar image Adam Davis STAFF Oct 14 '15 at 02:12 PM

Hi hairspray011,

  1. Does this occur in a clean, blank project with no additional content or is it limited to one project?

  2. Does the editor crash or do you manually close the editor when this happens?

  3. Can you post your full computer specs by going to the Mac icon>About this Mac>More Info> Add the information from this window (serial # not necessary)?

  4. Does this occur with any other type of blueprint or is it limited to game objects?

avatar image hairspray011 Oct 16 '15 at 12:17 AM
  1. No, seems to be okay until I add more code and content.. especially blueprint classes based off my C++ code.

  2. the editor freezes and doesnt crash. I have to force close it myself.

  3. my specs:

(translated from japanese to english .. sorry if it sounds odd) Computer: MacBook Pro ID: MacBookPro12,1 Processor name: Intel Core i5 Processor speed: 2.7 GHz No. of processors: 1 Total no. of cores: 2 2D cache: 256 KB 2D cache: 3 MB Memory: 8 GB Boot ROM version: MBP121.0167.B07 SMC Version (system): 2.28f7

  1. Happens with a blank blueprint project and third person blueprint project

avatar image Adam Davis STAFF Oct 16 '15 at 02:55 PM

What code are you adding to the project that you are trying to create blueprints based off of. Can I see a snippit of the code?

avatar image hairspray011 Oct 17 '15 at 12:22 AM

My header file:

 /**
  *    Photo.h
  *
  *     Author: Benjamin Lo
  *    Date: 2015/10/14
  */
 #pragma once
 #include "GameFramework/Actor.h"
 #include "Photo.generated.h"
 
 UCLASS()
 class DETECTIVEOFFICE_API APhoto : public AActor
 {
     GENERATED_BODY()
 
 public:    
     
     APhoto();
 
     UFUNCTION(BlueprintCallable, Category = Accesors)
     const     FString GetMessage() const;
 
     UFUNCTION(BlueprintCallable, Category = Modifiers)
     void     SetMessage(const FString newMessage);
 
 protected:
     UPROPERTY(EditAnywhere, Category = Message)    
     FString _message;
     
 };

My implementation file:

 /**
  *    Photo.cpp
  *
  *     Author: Benjamin Lo
  *    Date: 2015/10/14
  */
 #include "DetectiveOffice.h"
 #include "Photo.h"
 
 
 /**
  *    Constructor
  */
 APhoto::APhoto()
 {
     // dont do anything yet
 }
 
 
 /**
  *    Get message from a world object
  */
 const FString APhoto::GetMessage() const
 {
     return _message;
 }
 
 
 /**
  *    Set message to a world object
  */
 void APhoto::SetMessage(const FString newMessage)
 {
     _message = newMessage;
 }

avatar image Adam Davis STAFF Oct 19 '15 at 03:10 PM

Can you send me a sample project that is displaying this behavior? I have not been able to reproduce this on my end.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I'm happy to hear this is no longer occurring for you. I am marking this as answered for tracking purposes. If you experience this error again, please post here with updated information and we can continue attempting to reproduce it.

more ▼

answered Oct 26 '15 at 02:31 PM

avatar image hairspray011 Nov 13 '15 at 03:15 PM

alt text

Hi, I'm experiencing this problem again after upgrading from 4.8 to 4.9.2 I was able to add new blueprint classes without issue a few days ago but now I have the same problem again.

I am pretty sure my newly added classes don't affect me adding new blueprints because i commented them all out, compiled and tried to add blueprint but fail.

This seems to be a known issue with mac users, is there a reason why?

EDIT: the editor just freezes until forever or until i decide to force close the entire thing.

avatar image Adam Davis STAFF Nov 13 '15 at 03:36 PM

Can you send me a sample project this is occurring in? I'll be happy to try this on my end and see if I can reproduce it with the same project.

avatar image hairspray011 Nov 15 '15 at 12:19 AM

Hi Adam

I uploaded my project to google drive below. Thanks!

https://drive.google.com/file/d/0B_C-1Ms3AKY3ZV9lZ1R2d3l0WHc/view?usp=sharing

avatar image Adam Davis STAFF Nov 16 '15 at 07:36 PM

Hi hairspray011,

We tested this on a mac and did not see any freezing. Having said that, have you checked how much space you have available on your harddrive? There have been instances in the past where freezes will occur if there is not enough harddrive space available. Try checking this to see if freeing up some space reduces the amount of freezing you are seeing.

avatar image hairspray011 Nov 17 '15 at 12:20 AM

Hi Adam

I have over 4+GB of free space in my HDD. I have in the past removed unwanted apps and files because I thought this would be the easiest solution but this did not resolve my issue.

avatar image Adam Davis STAFF Nov 17 '15 at 05:52 PM

That is highly dependent on how much space you have removed. Unfortunately 4 gb is not enough to make a meaningful impact on this error if it is actually caused by space needs. Many projects easily can go from a few hundred mbs to 20-30 gbs depending on what you are attempting to accomplish and how detailed of assets you are currently using. Try freeing up a significant amount of space to see if this is the error.

avatar image hairspray011 Nov 17 '15 at 06:02 PM

Hi Adam

I freed up to 13GB of free space but the issue still persists

avatar image Adam Davis STAFF Nov 18 '15 at 02:26 PM

Try freeing up to at least 30 gbs, if this does not address the error we can safely assume that this is not the problem you are seeing. I will continue attempting to reproduce this error on my end.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi hairspray011,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error please comment with the requested information.

more ▼

answered Oct 23 '15 at 02:26 PM

avatar image hairspray011 Oct 26 '15 at 05:33 AM

Hi Sorry for the late reply. Im still not sure why but after uninstalling 4.9 and installing then using 4.8 i receive no more issues

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question