x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal Engine 4 wants to install on drive F:

Hello.

I decided to install Unreal Engine 4 on my computer to start off a project I've been thinking about for a while now. But when I try to install Unreal Engine through the EpicGamesLancherInstaller(blablabla).msi, I get a notification window saying the F: drive is invalid.

The only drives I have are C: (Main portion), D: (For games, media, such things) and E: (DVD-drive).

I use an external HDD when I record for YouTube and such, which is F:

But I don't have the external HDD hooked up when I try to install UE4. And when I do hook it up, I get to the start installation screen, showing me the path of install, but it wants to install on the F: drive, and I don't want it to.

I have used UE on this computer in the past, but that's years ago, and any trace of UE have been long removed from the computer.

Is there a way to change the install directory prior to installing?

I have read a few other threads from users with the same issue, but they either got solved by extensive manual re-location of files (Even after updates) or software that is not available to W10

Product Version: Epic Games Launcher
Tags:
more ▼

asked Oct 16 '15 at 02:22 PM in Installation & Setup

avatar image

FreemoX
0 1 2 2

avatar image 0xDEADBEEF STAFF Oct 16 '15 at 02:48 PM

For some reason the installer thinks you still have a valid Launcher install on your F drive and it is trying to upgrade it. If you did have the launcher installed at one point, this means that it probably didn't uninstall properly. Can you check to see if there is an entry here: Start->Control Panel->Uninstall a program

If you do have an entry for the launcher in the list, right click it and select uninstall.

avatar image FreemoX Oct 16 '15 at 02:50 PM

I already thought that this was the case, so this was one of the first things I checked. There are no entries of anything related to Epic Games or Unreal Engine

avatar image 0xDEADBEEF STAFF Oct 16 '15 at 03:39 PM

Sorry for the delay, had to do some digging. Sounds like the original uninstall method used in this case did not clean up the registry keys associated with the launcher. This means that at some level, Windows still thinks it is installed. This link goes into some of the boring details behind the way Windows Installer stores info about installations it thinks are valid. LINK

I suspect we'll have to cleanup some registry entries to get you past this issue. The hard part will be finding the right ones to remove since Windows uses arbitrary GUIDS to store the info we are after. You may have some luck with third party registry cleaners like Microsoft's FixIt but I'm not sure how many run on windows 10.

Depending on how comfortable you are with making registry changes, one of the first steps would probably be to open regedit and navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products. Once there, 'Find Ctrl-F' anything launcher related to see if you can find an Unreal Engine or Epic Games launcher entry. Let me know if you have it and we can try a few things.

avatar image FreemoX Oct 16 '15 at 03:48 PM

I actually checked the registry after I posted my last reply, and I removed the registry keys (there were 2) from the Epic Games folder in the SOFTWARE directory, as well as the directory you posted. Tried installing again, but no luck, it still wants to install on F:

And Fixit doesn't work on W10. I read another post where this solved the issue, but I found that it's not compatible with W10 (For some odd reason...) and this is one of the software I mentioned in my question.

I appreciate the time you take to research. I've tried a lot myself, but I think you know where I ended up

avatar image 0xDEADBEEF STAFF Oct 16 '15 at 03:53 PM

Did you happen to take down any info from the registry entry you removed from HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products?

avatar image FreemoX Oct 16 '15 at 09:31 PM

Sorry for late reply, was at work.

Take down any info, you mean write it down, or? I did not take a note of anything, I simply removed them.

I have temporarily installed UE4 on a USB drive, so I'm running it from there as of now, but the loading is slooooow, so I still want to figure this out

avatar image 0xDEADBEEF STAFF Oct 23 '15 at 06:30 PM

So sounds like you took some action that may have removed some of the data we normally use to find all the associated registry bits that need to be removed. I'm trying to figure out if we can discover these additional entries another way.

avatar image FreemoX Oct 23 '15 at 07:02 PM

Wouldn't there be a way to simply remove everything related to a single software to completely remove the associated registry entries and files signed by a publisher/developer/creator? Without re-installing Windows, obviously

avatar image 0xDEADBEEF STAFF Oct 23 '15 at 08:54 PM

So one of the links I posted in a previous response covers some of the complication involved in manually figuring out what to remove in the registry. Here is the link again for reference Link. In a nutshell, Windows Installer stores info in a manner that is not so easy to manually decipher without doing some cross referencing of entries. At least I have not found a good way of doing what you ask. Unfortunately, in this case, we no longer have the entry I have used as a starting point in the past. I'll have to do some more investigation but I don't have the answer yet. Things are further complicated since I don't have a clear picture of what entries you have and/or which ones were removed.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Guys, I have found a solution for this problem. So I downloaded this application called "Revo uninstaller" and selected Epic Games on the list. It deletes all the leftovers from the registries. After I finished deleting everything it let me install the launcher :) I hope it helps!

more ▼

answered Dec 05 '17 at 09:09 PM

avatar image

Harlena
6 1 1

avatar image yiati Mar 26 '18 at 02:29 AM

This was the only thing that I managed to get working. My problem was that I had fornite/epic games launcher installed on a separate drive in the past, and transferred it to my current drive. Apparently a lot of stuff was leftover in the registry and still marked with the old F:\ drive instead of what is now my C:\ drive. Revo Uninstaller with the advanced scan mode found everything related to Epic Games for me, and I was able to successfully delete everything. Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi FreemoX,

We haven't heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you're still experiencing this issue, please try the suggestion that I mentioned above then post back here with the requested info.

If you need anything else, feel free to ask.

more ▼

answered Nov 02 '15 at 03:38 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question